Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 13:35
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Bug: mkswap
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
psiklops

Joined: 26 Mar 2013
Posts: 2

PostPosted: Wed 27 Mar 2013, 11:11    Post subject:  Bug: mkswap
Subject description: /lib/libblkid.so.1: version `BLKID_2.21' not found
 

I am running Precise-5.5 Live on AMD 2800+ 4GB RAM and wanted to create a 4GB Swap file:

Code:
dd if=/dev/zero of=swapfile bs=1M count=4000


Code:
mkswap swapfile


and received this error message:

mkswap: /lib/libblkid.so.1: version `BLKID_2.21' not found (required by mkswap)

None the less the lib is present in /lib/

Is there a patch out there for this?

--------------------------------------------------------------

SOLVED:

Since libblkid is part of util-linux, i downloaded:

http://ftp.de.debian.org/debian/pool/main/u/util-linux/util-linux_2.20.1.orig.tar.gz

Code:
tar xfz util-linux_2.20.1.orig.tar.gz


Code:
cd util-linux-2.20.1


Code:
./configure && make && make install


cd to swapfile directory

Code:
mkswap swapfile


Setting up swapspace version 1, size = 4194300 KiB
no label, UUID=WhatEverNumbersDashesAndLetters


Cheers,

PsiKlops

Last edited by psiklops on Wed 27 Mar 2013, 11:31; edited 1 time in total
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5459
Location: Finland

PostPosted: Wed 27 Mar 2013, 11:23    Post subject:  

http://www.murga-linux.com/puppy/viewtopic.php?p=693082#693082
Back to top
View user's profile Send private message 
psiklops

Joined: 26 Mar 2013
Posts: 2

PostPosted: Wed 27 Mar 2013, 11:55    Post subject:  

pemasu wrote:
http://www.murga-linux.com/puppy/viewtopic.php?p=693082#693082


Kool Thanx.

Does my way of solving this Issue apply to be correct ? Or does it impose security or other issues ? Better said, is it better to upgrade util-linux using your suggested method ?

Cheers,

PsiKlops
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5459
Location: Finland

PostPosted: Wed 27 Mar 2013, 12:07    Post subject:  

You will miss Barry`s patches.

http://bkhome.org/sources/alphabetical/u/util-linux-2.21.2-patched_f2fs.tar.gz

u: puppy
p: linux

I recommend to use that pet.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0495s ][ Queries: 12 (0.0062s) ][ GZIP on ]