Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 16:40
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Puppy Power
How fast is Puppy Linux?
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Author Message
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Thu 14 Feb 2013, 20:34    Post_subject:  How fast is Puppy Linux?
Sub_title: I want to know what boot times everybody's getting!
 

Hey, I just thought it might be interesting to see how fast Puppy boots up for everybody. Please include as many details as you can think of.
Start your stopwatch as soon as the BIOS (+grub) finish loading, and stop it as soon as the desktop is completely loaded (Wallpaper, taskbar, icons.)


I'll start:

Boot Time: 46 seconds.
Version: Slacko 5.4.
Installation type - Frugal, with 2 GB Heavily encrypted save.
RAM: 3 GB of RAM (+2 GB Swap on an internal HD.)
Processor: 3 GHz Pentium 4, multithreaded.
Boot Device: 4 GB USB 2.0 Flash Drive (SanDisk Cruzer Edge.)
SFS's: 1 (Gimp)

_________________
Version 27. Dotpet. Click here.
(SFS available too!)


Edited_time_total
Back to top
View user's profile Send_private_message 
alphadog


Joined: 07 Dec 2010
Posts: 95
Location: Deepest Wiltshire UK

PostPosted: Fri 15 Feb 2013, 15:16    Post_subject:  

Here you go:-

Boot time = 18 secs (WOW!!)
OS =Wary 5.3 ( Full HDD Install)
RAM= 1Gb
Processor = Intel Core 2 Duo 6300 @1.86 GHz

Please forget PCs listed in my signature. Sig to be updated.

_________________
Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown
Back to top
View user's profile Send_private_message 
amigo

Joined: 02 Apr 2007
Posts: 2278

PostPosted: Fri 15 Feb 2013, 15:36    Post_subject:  

Boot time: 11 seconds
CPU: Pentium 4 2.00GHz
RAM: 512MB
OS: Linux kiss 3.0.21 KISS-5.0

Sorry, I couldn't resist -since I don't run Puppy...
It boots to CLI login in 6 seconds!
Back to top
View user's profile Send_private_message 
jakfish

Joined: 18 Jul 2008
Posts: 757

PostPosted: Fri 15 Feb 2013, 16:49    Post_subject:  

Are we working with the "true" boot time, meaning when you push the power button? Or are we doing the "feel good" one, from grub or the puppy menu?

Jake
Back to top
View user's profile Send_private_message 
plankenstein


Joined: 15 Nov 2008
Posts: 121
Location: Arkansas, USA

PostPosted: Fri 15 Feb 2013, 18:32    Post_subject:  

@ amigo,

I would like to check out this linux kiss that you're using, but can't seem to find any info on it. Could you direct me to a url with more info or a down load location?

_________________
I carefully plan ALL my random acts! Laughing
Back to top
View user's profile Send_private_message 
dk60902


Joined: 26 Sep 2010
Posts: 223
Location: In front of my computer

PostPosted: Fri 15 Feb 2013, 22:44    Post_subject:  

It would be helpful to know whether it is a full vs. frugal install, hard drive installation vs. USB boot vs. CD/DVD.
_________________
HP P6115y/AMDX2 2.5 GHz/8GB RAM/750GB/WinVista Home Prem SP2 64 bit Dual Monitor (Saluki23 w/ Compiz, Slacko533 PAE w/ Compiz on USB stick)
Compaq Presario 2195us 1GB RAM Lupu 5.2.8.5 off CD/Retired WinXP 4/8/14
Nexus 5 (rooted), Lumia 820 WP8.1
Back to top
View user's profile Send_private_message 
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Sat 23 Feb 2013, 02:31    Post_subject:  

jakfish wrote:
Are we working with the "true" boot time, meaning when you push the power button? Or are we doing the "feel good" one, from grub or the puppy menu?

Jake


I recommend doing the "feel good" one - it's actually more accurate for testing OS speed. As soon as the BIOS finishes, and the Grub screen (if you have one) is over, start your stopwatch. E.G., I have a bootable USB stick. I boot up, press F12, arrow down to "USB Device", then press enter and start the timer at the same time.
If you use another timing system - for example, starting the timer when you press power, mention that in the post.

_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send_private_message 
amigo

Joined: 02 Apr 2007
Posts: 2278

PostPosted: Sat 23 Feb 2013, 02:59    Post_subject:  

Yes, the 'feel good' is the only way to do a comparison between different machines -since the BIOS load-times will vary greatly from one box to another.
@plankenstein, KISS is not really ready fro prime-time as I have never yet built an installer. There are packages and sources here:
http://distro.ibiblio.org/amigolinux/distro/kiss-4.0/
if you know how to shoe-horn them into a partition....
Hint, the 'tpkg' package format is actually just tar.xz archives.
Back to top
View user's profile Send_private_message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Sat 23 Feb 2013, 14:39    Post_subject:  

Boot time: 17 seconds
CPU: AMD FX 8320
RAM: 8GB
OS: PupRescue Precise (5.4.3)

Boot time: 23 seconds
CPU: I-5 Quad Core
RAM: 3GB
OS: PupRescue Precise (5.4.3)

_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Tue 26 Feb 2013, 04:54    Post_subject:  

Newer Puppy kernels have the printk.time=1 boot parameter compiled into the kernel and a
Code:
tail -n1 /tmp/bootkernel.log
shows [ 36.894621] seconds . The bootkernel.log file gets written by /etc/rc.d/rc.sysinit . If I add xwin i am approximately at roundabout 1 minute since I added a test for
Code:
cat /proc/loadavg
to become lesser than 3 or otherwise sleep 2 seconds as
Code:
until [ "`cat /proc/loadavg | cut -f 1 -d '.'`" -lt '3' ];do echo -ne "\rWaiting for load average to drop below 3 :`cat /proc/loadavg` ";sleep 2s;done;echo  ###+++2011-11-30
and a test for
Code:
while [ "`pidof rc.services`" ] ; do echo -n '.. ' ; sleep 2 ; done ; echo
while [ "`pidof pup_event_backend_modprobe`" ] ; do echo -n '.. ' ; sleep 2 ; done ; echo

the programs that are loading additional drivers to finish .

I am running
Code:
lscpu
Architecture:          i686
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel

a Core2 @ 2.6 GHz, using the cpufreq_ondemand,acpi_cpufreq drivers compiled as modules managed by the standard Puppy CPU Frequency Scaling Interface /usr/local/cpu-freq/cpu_freq , that uses a range from 1,6-2,6 GHz . RAM=4GB , PUPMODE=2(full install) .
Back to top
View user's profile Send_private_message Visit_website 
gameboyab


Joined: 01 Sep 2012
Posts: 42
Location: Anytown, USA

PostPosted: Wed 27 Feb 2013, 02:14    Post_subject:  

Here's a low-end one.
1.6 GHz AMD Athlon 2000+
Slacko 5.4
Full Hard Disk install: 35 Seconds

CD boot-
Copy to RAM: 1:35
Don't copy to RAM: 1:56 Neutral
It's faster to copy to RAM than not?!

_________________
Not running as root is the cause of my inferiority complex.
Desktop: 2 GHz Core 2 Duo - 2 GB RAM
Laptop: 1.5 GHz Pentium M (III) - 1 GB RAM
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Wed 27 Feb 2013, 04:36    Post_subject:  

Lupu 528-005 frugal on NTFS HD with 630MB save file
took 45 seconds. Most of the time it spent with drivers.

I am experimenting with using no save file so that is adding to the boot time.
If one already have set up a save file then the boot goes faster
the script says Smile So I will test with both to see the difference

frugal on HD with Slacko and Lupu and HP AMD dual core
bought some 3 years ago?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
6502coder

Joined: 23 Mar 2009
Posts: 105
Location: Western United States

PostPosted: Tue 12 Mar 2013, 22:50    Post_subject: not bad for an ex-Win98 machine  

Wary 5.1.4.1 frugal
333 Mhz Pentium 2 laptop, 192 M ram, 512 M savefile
"feel good" boot time: 45 secs
Back to top
View user's profile Send_private_message 
Wognath

Joined: 19 Apr 2009
Posts: 191

PostPosted: Wed 13 Mar 2013, 16:39    Post_subject:  

Good idea for a topic! My data:

1.6GHz VIA Nano processor, 3 G ram
frugal HD installs in a Linux partition
Puppy 431 30 s
Precise 5.5 50 s
Windows XP awake from hibernation 14 s Sad

----------------------

In menu.lst I try to avoid searching, for example
Code:
kernel (hd0,2)/Precise/vmlinuz pmedia=atahd pdev1=sda3 psubdir=Precise

So why does "Searching for Puppy files" still take Precise 8 s? (2 s in 431)
And why does Precise stay on black screen for over 15 s after "Starting X"?

Edited_time_total
Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Wed 13 Mar 2013, 22:06    Post_subject:  

Quote:
So why does "Searching for Puppy files" still take Precise 8 s? (2 s in 431)

Code change in initrd.gz . Helped me out in a special case i cannot remember right now anymore, where Puppy-4.3.1 failed to boot.
Some sleep delay was added i think for slow USB external drives
and probably by default now searches all detected partitions despite the entries in the kernel line. Try to boot without any psubdir and pdev1 entries if that makes a difference.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Taking the Puppy out for a walk » Puppy Power
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0877s ][ Queries: 13 (0.0049s) ][ GZIP on ]