Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 10:40
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Instalar/Install Puppy Precise 5.4.3 Retro desde/from USB
Moderators: rarsa
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Coco_alx_coco_2

Joined: 03 Feb 2013
Posts: 9

PostPosted: Sun 03 Feb 2013, 19:44    Post_subject:  Instalar/Install Puppy Precise 5.4.3 Retro desde/from USB  

Hola de nuevo. Tengo un viejo PC PCChips Xcel2000 con 192 MB de RAM a 500 Mhz, con un HD de 15 GB y sin lectora de CD/DVD al que le instalé, mediante una memoria USB, el SO Puppy Precise Retro 5.4.3. La instalación se completó satisfactoriamente. Mi problema es que ahora no sé como reparar el GRUB, ya que al iniciar el sistema, arroja el error 21 ("Selected disk does not exist"). Entiendo que el problema puede venir dado por el lado de que cuando inicié el sistema con el USB, éste se montó en /dev/sda1 y el disco rígido como /dev/sdb1. Cuando configuré GRUB, guardé los datos en /dev/sdb, pero al parecer, cuando quito el USB, el disco rígido pasa a ser /dev/sda y eso me genera el problema. He probado modificar las líneas del GRUB y el Menu.lst, pero sigo sin poder iniciar el sistema. ¿Cómo puedo reparar el GRUB?

Gracias!
------------------------------------------------------------------------------------

Automatic translation! Sorry if you do not understand!

Hello again. I have an old PC with 192 MB PCChips Xcel2000 500 Mhz RAM, a 15 GB HD without your CD / DVD that I installed through a USB memory, the OS Precise Puppy 5.4.3 Retro. The installation was completed successfully. My problem is that now I do not know how to repair the GRUB because after reboot, throws the error 21 ("Selected disk does not exist"). I understand that the problem can be given by the side of that when booting with USB, it is mounted on / dev/sda1 and hard drive as / dev/sdb1. When configuring GRUB, save your data in / dev / sdb, but apparently, when I remove the USB hard drive becomes / dev / sda and I generated the problem. I tried to modify the lines of GRUB and menu.lst, but still can not boot. How I can fix the GRUB?

Thanks!
Back to top
View user's profile Send_private_message 
vicmz


Joined: 15 Jan 2012
Posts: 1154

PostPosted: Tue 05 Feb 2013, 17:16    Post_subject:  

Puedes instalar en el disco rígido. Si tienes otro Linux puedes conservarlo y usar el mismo grub para los dos sistemas, pero tienes que hacer una instalación frugal de Puppy, que no requiere formatear el disco, nada más tener el espacio suficiente para Puppy + archivo de sesión.

Hay una herramienta para hacer instalaciones frugales, se llama AFI ↓. Siempre la uso, pero tienes que descargar este archivo ↓ y ponerlo en el disco en el que vas a instalar Puppy para que lo reconozca como sda (solamente si no hay un archivo similar --de otro sistema ya instalado-- en ese disco que lo identifique como disco de arranque). La desventaja es que tienes que usar AFI desde Puppy Linux, pero si puedes, y si instalas en el disco rígido, ya no necesitarás tener el pendrive enchufado. Es más, puedes agregar instalaciones frugales de otras versiones de Puppy, que se guardarán en carpetas individuales, cada una con su propio archivo de sesión y entrada de menú grub.

Nota: después de instalar con AFI, usa Menú > Sistema > Grub4dos para que te cree un menú con más funciones (arrancar Puppy, arrancar Puppy solo en RAM, arrancar Windows si está instalado, etc.).
AFI_image-12.png
 Description   
 Filesize   59.55 KB
 Viewed   690 Time(s)

AFI_image-12.png


_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send_private_message 
Coco_alx_coco_2

Joined: 03 Feb 2013
Posts: 9

PostPosted: Tue 05 Feb 2013, 17:54    Post_subject:  

Hola, vicmz. La verdad es que no termino de entender cómo resolvería eso mi problema. Puppy ya está instalado en el disco - una instalación FULL. El problema es que el GRUB no lo encuentra. Cuando hice la instalación desde el USB al disco, procuré hacer todos los cambios en el MBR del disco (dev/sdb) -ya que el USB usaba el punto de montaje /dev/sda, no sé por qué-, y en la primera partición del disco (dev/sdb1), en la otra partición tengo una SWAP que no sé si el sistema tomará... no importa. Ahora voy a probar iniciar con un Live-CD y reparar el GRUB. La otra solución que veo es hacer una copia del Puppy en un CD e instalar sin pasar por el pendrive... Voy a seguir probando...
Back to top
View user's profile Send_private_message 
scifictn

Joined: 12 Jul 2008
Posts: 85

PostPosted: Sat 09 Feb 2013, 13:45    Post_subject:  

Hola, que tal!!

Podrias mostrar el archivo menu.lst que estas usando??.

Saludos desde Hermosillo Sonora Mexico!!
Back to top
View user's profile Send_private_message 
mama21mama

Joined: 03 Apr 2010
Posts: 526
Location: Lincoln, Buenos Aires, Argentina

PostPosted: Sun 10 Feb 2013, 02:24    Post_subject:  

Coco_alx_coco_2 wrote:
Hola, vicmz. La verdad es que no termino de entender cómo resolvería eso mi problema. Puppy ya está instalado en el disco - una instalación FULL. El problema es que el GRUB no lo encuentra. Cuando hice la instalación desde el USB al disco, procuré hacer todos los cambios en el MBR del disco (dev/sdb) -ya que el USB usaba el punto de montaje /dev/sda, no sé por qué-, y en la primera partición del disco (dev/sdb1), en la otra partición tengo una SWAP que no sé si el sistema tomará... no importa. Ahora voy a probar iniciar con un Live-CD y reparar el GRUB. La otra solución que veo es hacer una copia del Puppy en un CD e instalar sin pasar por el pendrive... Voy a seguir probando...


Mira esta guia a ver que paso te saltaste

http://mamalibre.no-ip.org/pub/puppylinux/lupu-525.pdf

Saludos
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
Coco_alx_coco_2

Joined: 03 Feb 2013
Posts: 9

PostPosted: Mon 11 Feb 2013, 18:48    Post_subject:  

mama21mama wrote:
Coco_alx_coco_2 wrote:
Hola, vicmz. La verdad es que no termino de entender cómo resolvería eso mi problema. Puppy ya está instalado en el disco - una instalación FULL. El problema es que el GRUB no lo encuentra. Cuando hice la instalación desde el USB al disco, procuré hacer todos los cambios en el MBR del disco (dev/sdb) -ya que el USB usaba el punto de montaje /dev/sda, no sé por qué-, y en la primera partición del disco (dev/sdb1), en la otra partición tengo una SWAP que no sé si el sistema tomará... no importa. Ahora voy a probar iniciar con un Live-CD y reparar el GRUB. La otra solución que veo es hacer una copia del Puppy en un CD e instalar sin pasar por el pendrive... Voy a seguir probando...


Mira esta guia a ver que paso te saltaste

http://mamalibre.no-ip.org/pub/puppylinux/lupu-525.pdf

Saludos


Sí, esos pasos sirven para cuando uno instala la distro desde el CD. Pero al instalar desde un pendrive USB, la estructura de las particiones montadas, cambia de nombre: el USB pasa a ser /dev/sda y el disci rígido /dev/sdb. Una vez terminada la instalación (en /dev/sdb, porque quiero que la distro se instale en el disco rígido), al retirar el USB, el GRUB no encuentra los datos de booteo. Supongo que debe ser porque el disco vuelve a ser /dev/sda y entonces, el GRUB se pierde...
Back to top
View user's profile Send_private_message 
vicmz


Joined: 15 Jan 2012
Posts: 1154

PostPosted: Mon 11 Feb 2013, 22:35    Post_subject:  

¿Y si pruebas copiando todo lo que hay en tu pendrive de Puppy y reiniciando el equipo sin el pendrive?
_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0639s ][ Queries: 13 (0.0043s) ][ GZIP on ]