Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 06:30
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Unable to Mount NTFS GPT USB drive (Solved)
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
calemblake

Joined: 07 Feb 2013
Posts: 6

PostPosted: Thu 07 Feb 2013, 06:51    Post_subject:  Unable to Mount NTFS GPT USB drive (Solved)  

Any Advice would be most welcome,

I have an issue with precise puppy and FatSlacko being unable to mount my USB drive. The drive is an NTFS GPT partition, about 20% of the time It is able to mount sucessfully, the rest of the time I can see the drive listed under
/dev/disk/id/

When I attempt to manually mount the drive with this command
mount -t ntfs /dev/sdc /mnt/sdc1

I get the message invalid NTFS partition. The partition works fine on windows and 20% of the time in puppy.



Can anyone suggest another tool to auto mount drives? Im going crazy looking for the solution[/img]
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11121
Location: Arizona USA

PostPosted: Thu 07 Feb 2013, 09:18    Post_subject:  

I believe Windows has a utility called chkdsk or something like that, which will look for and repair filesystem errors without messing with the data. Have you tried that?
Back to top
View user's profile Send_private_message 
calemblake

Joined: 07 Feb 2013
Posts: 6

PostPosted: Thu 07 Feb 2013, 17:15    Post_subject:  

Thanks for the quick reply!

Yes i already ran checkdisk an didnt have any luck
Back to top
View user's profile Send_private_message 
calemblake

Joined: 07 Feb 2013
Posts: 6

PostPosted: Sat 09 Feb 2013, 02:52    Post_subject:  

bump

This bug is causing me alot of pain, please someone rescue me.
Back to top
View user's profile Send_private_message 
amigo

Joined: 02 Apr 2007
Posts: 2261

PostPosted: Sat 09 Feb 2013, 03:18    Post_subject:  

I'm not sure puppy has support for GPT partition tables.
Back to top
View user's profile Send_private_message 
calemblake

Joined: 07 Feb 2013
Posts: 6

PostPosted: Sat 09 Feb 2013, 03:34    Post_subject:  

Yes it does, here is a screenshot of the GPT NTFS partition table working.
It took 3 disconnect/reconnects to get this working.

Back to top
View user's profile Send_private_message 
bigpup


Joined: 11 Oct 2009
Posts: 5237
Location: Charleston S.C. USA

PostPosted: Sat 09 Feb 2013, 13:25    Post_subject:  

Just to eliminate a possible cause.
Have you tried connecting using a different USB port?
Different USB cable?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send_private_message 
npierce

Joined: 28 Dec 2009
Posts: 858

PostPosted: Sat 09 Feb 2013, 14:55    Post_subject:  

calemblake wrote:
When I attempt to manually mount the drive with this command
mount -t ntfs /dev/sdc /mnt/sdc1

I get the message invalid NTFS partition.

What was the full error message?

If one attempts to mount an entire partitioned drive as an NTFS partition (as it appears you have done), the message will say,
Quote:
The device '/dev/sdc' doesn't seem to have a valid NTFS.

The error message then goes on to give advice on what might have gone wrong.
Back to top
View user's profile Send_private_message 
calemblake

Joined: 07 Feb 2013
Posts: 6

PostPosted: Mon 11 Feb 2013, 07:04    Post_subject:  

Hey guys,

Yes this USB port is definitely working, I connected another disk on the USB port and it works fine. I have already swapped out the USB cable

There is only 1 partition on the disk and it is NTFS GPT.
The exact error message I get is
"There is no NTFS file signature found on this disk" when I issue the mount command.

I am toying with the mtab and fstab files to try and get it work, If i had to guess id say it has something to do with the "fsck" which runs on an interval within linux.

I plan to download tune2fs and see if i can rectify this issue.
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11121
Location: Arizona USA

PostPosted: Mon 11 Feb 2013, 09:28    Post_subject:  

If there's nothing on it, perhaps reformatting it to NTFS with Gparted will fix the problem.
Back to top
View user's profile Send_private_message 
calemblake

Joined: 07 Feb 2013
Posts: 6

PostPosted: Sat 23 Mar 2013, 20:50    Post_subject: Answer  

Thought I would be diligent and reply back that I have found the answer.

The problem is the fschk that occurs once in every 30 connections.
You can disable the fschk with either these 2 commands.

tune2fs is installed by default already on fatslacko. This fixed the issue for me...

Quote:

tune2fs -c -1 `mount | awk '$3 == "/" {print $1}'`
or
tune2fs -c -1 /dev/yourhdd
Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Tue 26 Mar 2013, 00:49    Post_subject:  

is it really sometimes working 20% of tries ?
Code:
mount -t ntfs /dev/sdc /mnt/sdc1

shouldn't be the right syntax.
npierce said
Code:
mount -t ntfs /dev/sdc1 /mnt/sdc1

beware of the two sdc1 , not sdc and sdc1

*
Another thing to consider: Puppy's /bin/mount and /bin/umount are wrapper scripts to mange the drive icons on the desktop and run /bin/ntfs-3g binary if -t ntfs given.
You might try to bypass the wrapper by
Code:
mount-FULL /dev/sdc1 /mnt/sdc1

or
Code:
ntfs-3g /dev/sdc1 /mnt/sdc1



*
tune2fs is made to work on ext[2-4] formatted partitions, not on ntfs.
But since you are a real awk freak, I must believe, that you know what you are doing.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0721s ][ Queries: 12 (0.0108s) ][ GZIP on ]