Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 27 Dec 2014, 17:28
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.6.2.1 with kernel 3.6.2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 9 of 10 [143 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 03 Feb 2013, 15:51    Post subject:  

Artsown. Rerwin created first test pet. It has solution to turn off wireless automatic power saving property...if the solution works. Install the pet and reboot. Of course disable your solutions first. Please, post feedback here.

Also pdiag tarball posted here might help. If it works or not.
wifi_power_off-1.pet
Description 
pet

 Download 
Filename  wifi_power_off-1.pet 
Filesize  633 Bytes 
Downloaded  208 Time(s) 
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 147

PostPosted: Sun 03 Feb 2013, 16:54    Post subject:  

Pemasu, on sqeeze I removed the line that does my fix, then installed the
Pet and rebooted. Frisbee took a long time to connect and wlan0 power
management was ON instead of OFF. Second reboot the same. On the
third, Frisbee couldn't establish a connection, presumably because pwr
mgmt is ON instead of OFF.

Remember that on squeeze I had to move my fix to later in the startup
sequence than usual, I placed it after the sleep 5 line in Frisbee_tray
in the /root/startup group.

Sorry, I forgot the tarball and I'm not in sqeeze right now. Let me know
if you or rerwin need it.

Also, I wonder is his Pet is ok to try on Slacko 5.4? It might be interesting
to see if it works there but not on squeeze.

Art
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 03 Feb 2013, 16:57    Post subject:  

Artsown. It would help if you test this pet in all problematic puppy distros. This pet is just first trial to find generic solution. And pdiag or pmodemdiag tar balls would help. Pdiag is more sophisticated, if you copy it from squeeze puppy.

In console: which pdiag and you find out where it is.
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 147

PostPosted: Sun 03 Feb 2013, 17:30    Post subject:  

Pemasu, here's the result of pmodemdiag in squeeze. The console reported there is no pdiag.
pmodemdiag-20130204.tar.gz
Description 
gz

 Download 
Filename  pmodemdiag-20130204.tar.gz 
Filesize  25.7 KB 
Downloaded  193 Time(s) 
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 147

PostPosted: Sun 03 Feb 2013, 17:39    Post subject:  

Pemasu, here's the pmodemdiag result fpr Slacko 5.4 which also
starts up with power management ON for wlan0 and which also
has no pdiag.
pmodemdiag-20130203.tar.gz
Description 
gz

 Download 
Filename  pmodemdiag-20130203.tar.gz 
Filesize  27.22 KB 
Downloaded  193 Time(s) 
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 147

PostPosted: Sun 03 Feb 2013, 18:06    Post subject:  

Pemasu, here's pmodemdiag result for Precise 5.4.3
Precise also start up with pwr mgnt ON and the Pet
installed.
pmodemdiag-20130203.tar.gz
Description 
gz

 Download 
Filename  pmodemdiag-20130203.tar.gz 
Filesize  27.73 KB 
Downloaded  200 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 03 Feb 2013, 18:14    Post subject:  

Artsown. Yes, the syntax in the /etc/network/if-up.d/wifi_disable_power_management file:
Code:
/sbin/iwconfig "$IFACE" power off

does not reach wlan0

If I run that command in console, I get error.

If I run in console: iwconfig wlan0 power off, power management will be disabled in my wireless chip.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Tue 05 Feb 2013, 12:14    Post subject:  

Heh. Next trial for rt2500pci wlan power sawing disabling.

Quote:
I created a new Startup script that tests for a certain message ("wlan0: RX AssocResp from 00:12:17:49:03:56 (capab=0x411 status=0 aid=3)") to obtain the interface ID. That may not be the only message associated with the problem -- or it may be only a coincidence. But I have to start somewhere.

If users with different problematic drivers need the fix, I would need to see their pmodemdiag to look for signature messages, if any. If a message test is not adequate, we could put the script in the "firmware tarball/directory" for particular drivers. But let's try the easier approach first, in case it is sufficient.


Here is this version for Artsown to test. The script was quite hitech to me. I hope it works.
wifi_power_off-2.pet
Description 
pet

 Download 
Filename  wifi_power_off-2.pet 
Filesize  753 Bytes 
Downloaded  203 Time(s) 
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 147

PostPosted: Tue 05 Feb 2013, 15:28    Post subject:  

pemasu, the tarball was done in Slacko 5.4. Power management
on wlan0 is ON after installing the pet and rebooting.

Aty
pmodemdiag-20130205.tar.gz
Description 
gz

 Download 
Filename  pmodemdiag-20130205.tar.gz 
Filesize  28.26 KB 
Downloaded  191 Time(s) 
pmodemdiag-20130205.tar.gz
Description 
gz

 Download 
Filename  pmodemdiag-20130205.tar.gz 
Filesize  28.26 KB 
Downloaded  198 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Tue 05 Feb 2013, 15:32    Post subject:  

Artsown. Oh well. I believe Rerwin follows this thread and sees the result. The right syntax is still under development...as some sites announces...lol
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 147

PostPosted: Tue 05 Feb 2013, 16:15    Post subject:  

pemasu, I don't understand the logic of testing to see if wlan0 power
management is ON or OFF. It's ON by default on all Pups I've looked
at lately, including 5.2.8 Lucid on a 2.X kernel which has never given me
any wireless problem. The wireless bug began to appear when 3.X
kernel use started. Racy 5.3.9 with 3.0.25 kernel has the bug. Slacko
5.3.1 on a 2.X kernel does not have the problem but 5.3.3 on 3.1.10
kernel does.

Art
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Tue 05 Feb 2013, 16:18    Post subject:  

Artsown. These scripts try to determine the need to power off the wlan. And it should power it off. The purpose is trying to find a little more clever generic script to power off wlan power saving feature.

It just looks like these scripts just does not achieve the goal

But...even though you told the power saving is on...the kernel messages tell this:
Feb 5 19:19:23 puppypc10806 user.notice wifi_disable_power_saving: wlan0: power saving disabled to stabilize connections

Are you sure the iwconfig tells that Power Management is On ?
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 147

PostPosted: Tue 05 Feb 2013, 16:49    Post subject:  

Pemasu, yes I'm sure. In fact, Slacko lost connection, presumably
due to have it ON. But I'll try it again to make double sure.

Art
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 147

PostPosted: Tue 05 Feb 2013, 16:55    Post subject:  

Pemasu, tried it again and same thing. Wlan0 power management is
ON at startup with the second pet installed.

Art
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3451
Location: Ontario

PostPosted: Tue 05 Feb 2013, 17:21    Post subject: pburn fixed  

Zigbert has fixed the bug in pburn that caused a pipe error
when using pburn in Exprimo

http://murga-linux.com/puppy/viewtopic.php?p=682520#682520

______________________________________________________
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 9 of 10 [143 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0944s ][ Queries: 13 (0.0212s) ][ GZIP on ]