Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 19:29
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
How to use Intel 82652EZ NIC in Quirky 1.4?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Fri 01 Feb 2013, 20:10    Post_subject:  

That's the right kernel version for Quirky 1.4. Run:
Code:
depmod -a
modprobe e100
Back to top
View user's profile Send_private_message 
rvijay

Joined: 07 Mar 2011
Posts: 25

PostPosted: Fri 01 Feb 2013, 20:59    Post_subject:  

rcrsn51 wrote:
That's the right kernel version for Quirky 1.4. Run:
Code:
depmod -a
modprobe e100


Tried this,

depmod -a
didn't give any error messages so seemed to have worked.
modprobe e100 failed saying unable to find module.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Fri 01 Feb 2013, 21:54    Post_subject:  

Is your CD burnt from the original Quirky 1.4 ISO?

I just made a Quirky 1.4 flash drive and the e100 module was there.
Back to top
View user's profile Send_private_message 
rvijay

Joined: 07 Mar 2011
Posts: 25

PostPosted: Fri 01 Feb 2013, 22:09    Post_subject:  

rcrsn51 wrote:
Is your CD burnt from the original Quirky 1.4 ISO?

I just made a Quirky 1.4 flash drive and the e100 module was there.


I think so but it has been a long time. How can this be verified ? Also, how can I verify that the e100 modules are in the CD and also in the flash drive ?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Fri 01 Feb 2013, 22:12    Post_subject:  

Look in the folder /lib/modules/2.6.31.14/kernel/drivers/net for the file e100.ko
Back to top
View user's profile Send_private_message 
rvijay

Joined: 07 Mar 2011
Posts: 25

PostPosted: Fri 01 Feb 2013, 22:32    Post_subject:  

rcrsn51 wrote:
Look in the folder /lib/modules/2.6.31.14/kernel/drivers/net for the file e100.ko


When I load regular, the dir net and e100.ko are there. However, when I load puppy from USB, then entire net dir is missing. I created one and then tried to copy the e100.ko file, then tried modprobe e100, didn't help.

It appears that this can be a remastered CD as the background is a nice scenary. Wonder how come there is so much change due to remastering.
Back to top
View user's profile Send_private_message 
rvijay

Joined: 07 Mar 2011
Posts: 25

PostPosted: Fri 01 Feb 2013, 22:40    Post_subject:  

zq140014.sfs is only 1.5MB approx. on USB however, in live cd it is more like 32MB. Trying to copy it failed.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Fri 01 Feb 2013, 23:33    Post_subject:  

rvijay wrote:
zq140014.sfs is only 1.5MB approx. on USB however, in live cd it is more like 32MB. Trying to copy it failed.

The real Quirky 1.4 does not have this file. The original version is here.
Back to top
View user's profile Send_private_message 
rvijay

Joined: 07 Mar 2011
Posts: 25

PostPosted: Sat 02 Feb 2013, 00:22    Post_subject:  

I got the original file, md5sum was verified to be ok. Then mounted it and copied all files to the USB drive. However, when I try to boot from USB, it says OS not found.
Back to top
View user's profile Send_private_message 
rvijay

Joined: 07 Mar 2011
Posts: 25

PostPosted: Sat 02 Feb 2013, 11:45    Post_subject:  

I burned a new CD, booted of it and then installed puppy fresh to USB drive. Now, it works fine. Thanks. Smile
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0540s ][ Queries: 12 (0.0044s) ][ GZIP on ]