Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 15 Sep 2014, 05:34
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Upup Precise 3.7.2 with kernel 3.7.2, no pae
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 8 [118 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Author Message
charlie6


Joined: 30 Jun 2008
Posts: 1007
Location: South of Belgium

PostPosted: Mon 14 Jan 2013, 14:43    Post subject:  

Hi Keef,
thanks a lot for your post !
i surely have learned something !
would you mind:
1) add:
1.1)
Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
#from kernel 2.6.35 and later the "SendCoreEvents" after InputDevice is no longer required
   InputDevice    "stylus"
   InputDevice    "eraser"  # <<< please do INSERT THIS LINE
EndSection

and modify
1.2)
Code:
Section "InputDevice"
      Identifier    "stylus"
      Driver        "wacom"
      Option        "Device" "/dev/input/wacom"
      Option        "Type" "stylus"
      Option        "USB" "on"
      Option        "Mode" "Relative"
#      Option        "Mode" "Absolute"
EndSection

and add this to get the eraser (i.e. the pens tail tip end...) working:
1.3)
Code:
Section "InputDevice"
      Identifier    "eraser"
      Driver        "wacom"
      Option        "Device" "/dev/input/wacom"
      Option        "Type" "eraser"
      Option        "USB" "on"
      Option        "Mode" "Relative"
#     Option        "Mode" "Absolute"
EndSection


some cursors arrows behaviour might change ...maybe better ! if not, please disregard.

charlie
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7801
Location: qld

PostPosted: Mon 14 Jan 2013, 16:50    Post subject:  

Just an FYI post...

Regarding the "modesetting" Xorg driver.

In my Slacko tests I did find that this can conflict with some other xorg drivers. It is included in Slacko but it is hidden away in /usr/lib/x with possibly other alternate drivers. There is a problem (bug) with that approach though as xorgwizard does not know about the modesetting driver. Consequently, it is not moved to /usr/lib/xorg/modules/drivers and so is unavailable to xorg.

I am going to add a case to xorgwizard that handles this scenario such modesetting is moved if chosen. Possibly udev rules should be written that on the detection of a cedaview or poulsbo graphics card that the modesetting driver is automatically moved. Jury is out on that one. I am already doing preliminary work on this.


pemasu, sorry for brief off topic here...

@ aarf, who unfortunately can't post here. Good you got modesetting to work in Upup with RoDoN's compile. Regarding Slacko, you must uninstall the Upup version. Then run this command
Code:
mv /usr/lib/x/drivers-alternate/modesetting_drv.so /usr/lib/xorg/modules/drivers/

Then run xorgwizard, choose modesetting driver, that should work. Modesetting is known working with cedarview in Slacko.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 14 Jan 2013, 17:29    Post subject:  

01micko. Thank you of the input. Intel gma 500 (Poulsbo), gma 600, gma 3600 (Cedarview) and 3650 (Cedarview) which uses gma500_gfx.ko and can use xorg modesetting driver have been troublesome PowerVR based graphics.

The graphics support in linux is only usable. No 3D acceleration. But it is better than nothing and intel atom based notebooks are not for power hungry usage anyway.

If you can edit xorgwizard so that gma500_gfx.ko can be used with included xorg modesetting driver, it would be great thing for these intel atom comps with above gma graphics.
Xorgwizard handled xorg driver translocation from alternate to normal location so that the xorg modesetting driver would be in use would be great.

I would include that xorgwizard of course to my builds. Thanks of your initiative. And thanks to aarf who brought this need to my attention. I didnt know of the work done in Slacko. Now I know.

Cheers.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 14 Jan 2013, 18:49    Post subject:  

I am still quite newbie for compiling ati-amd-fglrx-drivers for petting. But...I have learnt to compile and create them inside extracted ati folder and have learnt to patch the kernel module source before running the installer. So....these might even work.
I created ati-12.10 pet for modern graphics, like mine. Tested the pet with my dual graphics. And then I created ati-12.6-legacy pet.

Cave out. For me suspending does not result working waking up.
There is ati own fixes for that inside: /usr/share/doc/fglrx/examples/etc
You can try to copy the stuff to right places and test them. I havent had time to do so....maybe next time when I boot with ati and watch movies through hdmi from my 42 inch lcd tv. Then I have a reason to try them with suspending.

I created quickpet for this 3.7.2 kernel version. Under drivers sections you find those ati-amd-fglrx pets and also newest nvidia 310.19 pet.

They are in upup repo, so those who want to scan it...find them there. Nvidia 310.19 is there as sfs also. You can download it with Precise sfs downloader also...There are now quite many ways to install stuff...

Test...enjoy...or blame me...
quickpet_upup-precise-kernel-3.7.2-0.2.pet
Description 
pet

 Download 
Filename  quickpet_upup-precise-kernel-3.7.2-0.2.pet 
Filesize  104 KB 
Downloaded  172 Time(s) 
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7801
Location: qld

PostPosted: Mon 14 Jan 2013, 21:35    Post subject:  

Further to gma/poulsbo/cedarview issues I have patched xorgwizard to move the modesetting driver from the alternate location to the real location where Xorg can find it, I have also patched xorgwizard-automatic to move the modesetting driver if it detects one of these cards based on device ID, now my database may be incomplete, I don't know. But if your machine is over 6 months old it will almost certainly be listed. Newer ones might be too.

I have not packaged this as a pet as it is only if you have an intel atom infected with the gma 500 (Poulsbo), gma 600, gma 3600 (Cedarview) and 3650 (Cedarview) which uses gma500_gfx.ko.
The package is structured just like a pet to easily merge into the filesystem. The packages contains: a patched /usr/sbin/xorgwizard, a patched /usr/sbin/xorgwizard-automatic and a new script called xcedarview.sh, called from xorgwizard-automatic.

Get the package here:
http://01micko.no-ip.org/testing/xorgwizard_patched_modesetting-130115.tar.bz2 25.1kb

If you know what you are doing you can do it with no X. Ideally that's how it should be done, but for testing purposes there are 2 things to test.
    1.drop to prompt (yau may already be there Razz ) and run xorgwizard
    Choose the "modesetting" driver, start x with xwin

    2. From the prompt delete or move /etc/X11/xorg.conf
    If you have ordinary Intel a test will be performed to see if you have a gma device and you will be informed. If you have the device you will then be informed that "modesetting" driver is moved to it's proper location or if it's not there then a "NOT FOUND" message occurs. .


NOTE: you'll also need the modesetting driver in the correct location for the test!! Here it is:
http://01micko.no-ip.org/testing/xf86-video-modesetting-0.6.0-i486_ALT_upup.pet

This is RoDoN's pet just moved. Why is this necessary? Well .. if you have an nvidia and use xorgwizard then it's "modesetting" gets chosen and X crashes unrecoverably! That's why I moved in the first place.

Good Luck!

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
RoDoN

Joined: 09 Sep 2011
Posts: 10
Location: Russia

PostPosted: Tue 15 Jan 2013, 02:11    Post subject: gma500  

pemasu, 01micko
Thanks!

For normal work gma500_gfx + modesettting_drv driver poulsbo.ko need to delete or rename to the poulsbo.ko.not

Last edited by RoDoN on Tue 15 Jan 2013, 02:17; edited 1 time in total
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 15 Jan 2013, 02:13    Post subject:  

01micko. Thanks !!!
I will check them out soon. What do you think of the poulsbo.ko stub driver. It might inhibit the use of gma500_gfx.ko and modesetting driver.
Would it be still reasonable to blacklist it in the build with MODULESCONFIG ?
Post edited because RoDon above answered it already.


Heh. RoDon beat with 2 seconds. Congratulation. You won ice cream. I will fax it to you.

Last edited by pemasu on Tue 15 Jan 2013, 02:18; edited 2 times in total
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7801
Location: qld

PostPosted: Tue 15 Jan 2013, 02:17    Post subject:  

Yes RoDon is correct, I should have mentioned that. My next slacko will be with out it (only k3.3x and above exhibits this, there is a test for it in my xorgwizard-automatic).
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
davids45


Joined: 26 Nov 2006
Posts: 647
Location: Chatswood, NSW

PostPosted: Tue 15 Jan 2013, 03:53    Post subject: ATI AMD Drivers
Subject description: Working in Full & Frugal Upup
 

G'day pemasu,

Quote:
I am still quite newbie for compiling ati-amd-fglrx-drivers for petting. But...I have learnt to compile and create them inside extracted ati folder and have learnt to patch the kernel module source before running the installer. So....these might even work.
I created ati-12.10 pet for modern graphics, like mine.


And mine, too (Radeon HD5450 card).

Ran your ati pet and then downloaded the ~50MB driver package with no problem.
I installed first to a Frugal Upup-3.7.2 with a 256MB save-file. A red warning about the save-file remaining (~80MB) and I increased the save file size to 512MB for next boot. But the new driver did load and run well after I did the 'aticonfig --initial' step and restarted X.

But on shutting down to 'reboot' there was a problem - the computer did not shut down and the text displayed seemed to be part of the start up messages and the computer hung. I hit the 'reset' button and re-booted the Frugal-3.7.2 which started up with the ATI driver and a good display. Shutting down now went as expected with no strange message or hanging.

I then installed the ati-fglrx driver on my Full Upup-3.7.2 with the same result. Good install, good initial display, but again hanging on trying to reboot the first time; 'reset' and re-booting to the Full Upup and everything was good.

David S.
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1007
Location: South of Belgium

PostPosted: Tue 15 Jan 2013, 04:03    Post subject: wacom stuffs already included in uPup Precise 3.7.2 ...  

Hi,
@keef
thanks again for your post !
I presume it would no longer be necessary to compile the xf86-input-acom driver ... related to the present distro as also puppies with «new» kernel as uPup-54X7 and dPup-Exprimo-3.6.2, and maybe others!
Please consider and read
http://www.murga-linux.com/puppy/viewtopic.php?p=677882#677882
I suggest we to continue posting about wacom subject in the thread Forum index/House Training/Howto/«How to set up a Wacom Tablet».
Hope this helps
Charlie

Last edited by charlie6 on Tue 15 Jan 2013, 12:49; edited 1 time in total
Back to top
View user's profile Send private message 
LateAdopter

Joined: 27 May 2011
Posts: 149
Location: Reading UK

PostPosted: Tue 15 Jan 2013, 07:41    Post subject:  

Hello Pemasu

Thanks for this, it's working fine on my system.

I compiled TurionPowerControl and then added my usual p-state voltage configuration via rc.local. It is working perfectly, thanks for cpuid and msr.

Amazingly, almost immediately you have posted a fglrx legacy .pet. I have installed that and it is worked with no problem.

I notice that it does not install the GLX stuff which I thought ATI pets normally do. I don't play 3D games, so I don't need it. I expect I could install it from the Ubuntu repo.

Maybe other Puppies come with GLX installed, and I haven't noticed. The r600g has it built-in.

If this is not the expected behaviour, please tell me and I will investigate the log files further.

My main interest is playing pack my MPEG video recordings. Now I can try installing the latest XBMC-XVBA package from the wsnipex PPA on launchpad. Then I can compare it with software decoding using VLC and the Xorg r600g driver.

Thanks again
Back to top
View user's profile Send private message 
LateAdopter

Joined: 27 May 2011
Posts: 149
Location: Reading UK

PostPosted: Tue 15 Jan 2013, 10:18    Post subject:  

Hello Pemasu

The problem seems to be that the radeon kernel module is still being loaded, which breaks fglrx acceleration.

I think the radeon module should be blacklisted by blacklist-radeon.conf, and this is not present.

I tried creating blacklist-radeon.conf but it disappeared from modprobe.d after a reboot. So radeon is still loaded.

What is the correct way to disable it?

Thanks.

EDIT: I spotted my mistake, it should have been blacklist-fglrx.conf. I'll try again!

EDIT2: No, that didn't work either!

EDIT3: I renamed radeon.ko which stopped it from loading.

But I still get: AIGLX error: failed to load OpenGL driver.

libgl1-mesa-dri and libgl1-mesa-glx are both shown as installed in the Package Manager
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 15 Jan 2013, 12:51    Post subject:  

LateAdopter and davids45. There was missing files. My way to create packages seems to miss some installer stage. fglrx_dri.so was placed to wrong location. Also some other scripts and files were missing.

I tested the reuploaded ati pet and it should work now. Suspending started to work for me, radeon will be blacklisted, dri has been enabled.
I have reuploaded both ati pets. Oh yeah...ati-12.6 legacy fglrx.ko needed heavy patching. It is possible that the fglrx.ko kernel module is defective due to that heavy patching. Kernel 3.7 might still miss some crucial patch. Time will tell...
I cant test 12.6-legacy pet. I dont have suitable ati card.

I hope the pets are now complete enough.
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1007
Location: South of Belgium

PostPosted: Tue 15 Jan 2013, 13:01    Post subject: Firefox18 for your language  

Hi,
here choose the firefox18.tar.bz2 for your language:
http://www.mozilla.org/en-US/firefox/all/
cheers, charlie
Back to top
View user's profile Send private message 
LateAdopter

Joined: 27 May 2011
Posts: 149
Location: Reading UK

PostPosted: Tue 15 Jan 2013, 14:30    Post subject:  

Hello Pemasu

I started with a new savefile and installed your updated ATI legacy 12.6 pet.

Everything seems to be working correctly now.

Athlon II X2, 785G (RS880G) chipset.

glxgears runs
hardinfo shows the ATI GL driver
Xorg log shows AIGLX loaded and initialised

Looking good

Many thanks
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 8 [118 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0997s ][ Queries: 13 (0.0053s) ][ GZIP on ]