Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 16 Apr 2014, 04:33
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
OnlinePuppy (based RetroPrecise542)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Author Message
kros54

Joined: 17 May 2009
Posts: 100
Location: member of Hungarian Puppy Linux Community

PostPosted: Sat 15 Dec 2012, 14:04    Post subject:  OnlinePuppy (based RetroPrecise542)
Subject description: Simple openbox, tint2panel
 

New puplet based on Retro Precise Puppy 5.4.2.2
installed Openbox, wbar, tint2panel.
(Hungarian edition has been, OnlinePuppy, OfficePuppy and adjusting MetroPuppy, based on Lucid525-clon, Justin Bieber Linux by sheepy)

OnlinePuppy menu structure is slightly modified.
Is primarily intended for online use, the some office programs: Abiword, Gnumeric is deleted.
SeaMonkey replaced Firefox.
SeaMonkey and Firefox 3 open browsertab if 270 MB RAM-use, Opera browser 370 MB of RAM-use. Firefox into a better, more extras on it.

Simple, but quickly get used to.
Download: ftp://puppylinux.hu/puppylinux/ISO/OnlineRetroPrecise542En.iso

Original forum threed:
http://puppylinux.hu/phpbb3/viewtopic.php?t=644&p=8790#p8790
OnlineEnglish2.jpg
 Description   
 Filesize   76.29 KB
 Viewed   1860 Time(s)

OnlineEnglish2.jpg

OnlineEnglish.jpg
 Description   
 Filesize   44.72 KB
 Viewed   1841 Time(s)

OnlineEnglish.jpg


Last edited by kros54 on Sat 02 Feb 2013, 13:49; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 3779
Location: Gatineau (Qc), Canada

PostPosted: Mon 14 Jan 2013, 14:26    Post subject:  

Hello, kros54.

Your work looks very interesting, but the download from Canada is painfully slow : 43 to 45 Kb/s, 1 hr 15 min. predicted for the download... I'll wait it out, but all Puppyists may not have such patience...

May I suggest that
Just a thought. Sincerely,

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 3779
Location: Gatineau (Qc), Canada

PostPosted: Tue 15 Jan 2013, 15:15    Post subject:  

Hi.

I didn't get very far... OnlinePuppy gave me a kind of kernel panic with lots of binary digits at boot (when he's searching for the precise---.sfs file).

Obviously, it's working on your machine. Could the iso have been corrupted during the download? Can't tell, really.

Problem too difficult to pin down. Sorry.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
Tote


Joined: 19 Jan 2012
Posts: 216
Location: South Wales

PostPosted: Tue 15 Jan 2013, 16:58    Post subject:  

Download ok here, 15- 20 mins, 250kbs.

Manual frugal instal, celeron M 245RAM

Installed latest Opera sfs, works fine, no problem. Had to switch keyboard layout for UK. Can't get any sound, little red X over the speaker tray icon. Haven't tried ALSA wizard yet. Had the option to install Precise Service Pack, so I did. I don't know if's that's recommended, didn't make anything bad happen. There's nothing in the Personal link from main menu, window doesn't appear. Other than that seems to be working well.

Still playing with it...desktop quick and snappy, very low CPU.
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2035
Location: Germany

PostPosted: Tue 15 Jan 2013, 17:53    Post subject:  

Hi.

Download speed seems to be alright here. Downloading currently 3 files (2 iso, 1 sfs, 135 to 195 mb sized). Speed on OnlinePuppy is: about 200kb/sec, both other files are about 70 kb/sec.

Quote:
May I suggest that

you divide the iso in 3 or 4 parts

There is no need to split a 195 MB ISO file. Sign in to mediafire. It hosts files up to 200 MB, max. size (all files added) is 50 GB and all you have to do is to log in once every 3 months.

Btw: if OnlinePuppy runs on my system, I'll try to make an VSP OnlinePuppy out of it.

RSH

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 3779
Location: Gatineau (Qc), Canada

PostPosted: Tue 15 Jan 2013, 18:07    Post subject:  

I don't know what happened yesterday. Today I'm getting a speed of 280 K/s to 600 K/s. I'll make a fresh disk from the newly downloaded iso and try again.

Sincerely,

m0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 3779
Location: Gatineau (Qc), Canada

PostPosted: Tue 15 Jan 2013, 22:36    Post subject:  

Hi,, kros54.

Sorry in advance but here we go. Please note that the following criticism is done in a spirit of collaboration and improvement, and not to put anybody down. Your work appears good, but it still has irritants. Your distro has a couple of things that in my opinion need improvement at the desktop level.
I did not check other aspects.

First, please see attached illustration of the problems.

When I changed a couple of things and went back to the initial console to do
xwin openbox
it launched without openbox !!!
Same with openbox-session, same with ob.
The solution is to manually go to /usrbin/ and click on the openbox executable, or open a console and issue the command. Very weird problem.

The wbar command in .xinitrc : this should be changed to respect the user's customization. Otherwise, the user will have his wbar and your wbar, always. It would be better if there was a way to remove the bottom wnbar and not the left wbar, that the user could access, but I don't think there is such a command available.

In .xinitrc again, change the line
if [ "$CURRENTWM" != "jwm" -a "$CURRENTWM" != "icewm" ];then
etc. etc.,
to include lxp-icewm, in case somebody likes this variant of icewm. It's easy to do if you modulate the $CURRENTWM string.

You have no backgrounds for 1280x1024 resolution. I had to modify this one manually. A large number of people still have traditional screens hooked to tower computers.

You can see also that for some reason the sound scale shows up, and it cannot be closed before openbox is launched manually.

I did not test the sound, incidentally, nor any other function of this Puppy. The wm problem is very limiting for moving around and testing things, as you no doubt understand.

Finally, I noticed that your OnlineRetro Puppy did not create a pupsave file, even if it did ask for the usual parameters at shutdown.

In the hoipe that the above comments will be helpful.

Best regards,

musher0
problem.jpg
Description  openbox has stepped outside for a moment !
jpg

 Download 
Filename  problem.jpg 
Filesize  32.42 KB 
Downloaded  201 Time(s) 

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
RSH


Joined: 05 Sep 2011
Posts: 2035
Location: Germany

PostPosted: Tue 15 Jan 2013, 23:57    Post subject:  

Quote:
Can't get any sound, little red X over the speaker tray icon. Haven't tried ALSA wizard yet.

Yes! This something a lot of derivative builders run into it.

The basic idea that they have, is to modify the .retrovolrc to give the sliders another design, another color. Then they put it into /tmp/toot at remastering (as far as I know, the remaster script doesn't keep this file automatically).

The result is a (for them ones) nice looking slider bar of retrovol - BUT NO SOUND on other machines.

Whenever you won't get sound from a derivative, search for /root/.retrovolrc, remove it and do a remaster - or do edit the puppy's main sfs manually and remove this file.

After reboot, you should have sound on any machine! Wink

I can't remember how often I did tell this to derivative builders... Rolling Eyes Laughing

Also: it's no fun to have several puppy derivatives using equal name as the original main sfs file is named. Therefor I will rename all my VSP Puppy Derivatives to come.

---

Ok, downloaded, installed my currently 20 .pet files (about 2MB) and made a VSP-OnlinePup beta-test Version from it. Boots into desktop still after remastering.

The One-Click-VSP-Puppy-Builder is not far away, so I did decide to make Online Puppy one the the next VSP Puppy OS's.

Both wallpapers are very nice (though I do not use an OS for its wallpapers) and the tint2 panel looks interesting. Must have a few looks into the config files etc.pp. Smile

RSH
VSP-OnlinePuppy.jpg
 Description   
 Filesize   46.86 KB
 Viewed   1276 Time(s)

VSP-OnlinePuppy.jpg


_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
kros54

Joined: 17 May 2009
Posts: 100
Location: member of Hungarian Puppy Linux Community

PostPosted: Wed 16 Jan 2013, 14:56    Post subject:  

Thanks for the helpful comments and advice.
I will create a bug fix.
The newer version of wbar was deleted, replaced tint2menu.
Thus, the RAM used even less.
The new iso-file makes available dropbox.com
tint2menu.jpg
 Description   
 Filesize   42.29 KB
 Viewed   1162 Time(s)

tint2menu.jpg

Back to top
View user's profile Send private message Visit poster's website 
RSH


Joined: 05 Sep 2011
Posts: 2035
Location: Germany

PostPosted: Wed 16 Jan 2013, 16:07    Post subject:  

Is it already uploaded?
_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
kros54

Joined: 17 May 2009
Posts: 100
Location: member of Hungarian Puppy Linux Community

PostPosted: Thu 17 Jan 2013, 00:46    Post subject:  

Wbar deleted. Instead tint2menu.
What's new: pidgin installed. wallpaper in several sizes.
RAM usage is even lower, at about the same as during the JWM.
Openbox is intended for use in online activities.
ftp://puppylinux.hu/puppylinux/ISO/onlineRPtint2EN.iso
Dropbox will also.
online-tint2EN.jpg
 Description   
 Filesize   80.96 KB
 Viewed   1008 Time(s)

online-tint2EN.jpg

Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 3779
Location: Gatineau (Qc), Canada

PostPosted: Thu 17 Jan 2013, 16:20    Post subject:  

kros54 wrote:
Wbar deleted. Instead tint2menu.
What's new: pidgin installed. wallpaper in several sizes.
RAM usage is even lower, at about the same as during the JWM.
Openbox is intended for use in online activities.
ftp://puppylinux.hu/puppylinux/ISO/onlineRPtint2EN.iso
Dropbox will also.


Thank you, kros54.

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
RSH


Joined: 05 Sep 2011
Posts: 2035
Location: Germany

PostPosted: Thu 17 Jan 2013, 20:38    Post subject:  

OK.

Downloaded agin, and:

- again the .retrovolrc in /root
- again no sound after booting into the desktop

- could NOT execute bash scripts from geany
- - wrong preferences set (geany here uses xterm instead of rxvt)

That's a bit too much of NO FUN.

Sorry

RSH

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
kros54

Joined: 17 May 2009
Posts: 100
Location: member of Hungarian Puppy Linux Community

PostPosted: Fri 18 Jan 2013, 00:50    Post subject:  

I'm trying to repair the errors.
Please be patient until. iso until canceled.

The previous version of wbar correct the problem
1. delete the. xinitrc 185 line:
Code:
sleep 3 && wbar -above-desk -jumpf 1 -pos bottom -offset 23 -nanim 3 -zoomf 2.8 -idist 20 -isize 25 -bpress -balfa 0 -falfa 100 &


2. root/.wbar file second line overwrite this:
Code:
c: wbar --bpress --above-desk --pos bottom --offset 23 --isize 25 --idist 20 --nanim 3 --zoomf 2,800000 --jumpf 1,000000 --balfa 0 --falfa 100


save, relaod.
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 3779
Location: Gatineau (Qc), Canada

PostPosted: Sat 19 Jan 2013, 00:25    Post subject:  

Hello, kros54.

Just a word, not to sound impolite.

I am presently quite busy doing research with a buddy on a simple Business package for Puppy distros. So I have little time left to test your distro -- or any other Puppy for that matter. I will try to get to it in the future, but I am not promosing anything for the short term.

But please continue your good work.

Sincerely,

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0764s ][ Queries: 13 (0.0048s) ][ GZIP on ]