Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 12:08
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Quel Puppy choisir pour un netbook ou astuce résolution
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
gilloraymondo

Joined: 03 Dec 2011
Posts: 257

PostPosted: Sun 13 Jan 2013, 09:39    Post subject:  Quel Puppy choisir pour un netbook ou astuce résolution  

Bonjour,

Mon netbook (Asus EeePC 701 SD avec 8GO de SSD) a une seule résolution disponible : 800x480

Avec toutou linux, j'ai un gros problème : je ne vois pas le bas des fenêtres. Il est vrai qu'avec la fonction maximiser, on arrive quand même à s'en sortir. Mais ce n'est pas pratique. La fonction "déplacer", ne permet pas de faire remonter les fenêtres trop grandes suffisamment haut.
Avec Lucid Puppy, c'est un peu mieux. On peut, avec la fonction "déplacer", faire remonter les fenêtres trop grandes, jusqu'à voir le bas des fenêtres en cause.

Parmi toutes les puplettes et versions disponibles, il y a de quoi s'y perdre pour trouver la version adéquate.
La 1ere question est : existe t il une version puppy avec la résolution 800x480 ?
A défaut;
2ème question : Quelles sont les versions qui, comme Lucid Puppy, permettent, avec la fonction "déplacer", de faire monter les fenêtres suffisamment pour voir le bas des fenêtres trop grandes ?
Ou encore;
3ème question : peut on ajouter un paquet qui résoudrait ce problème de résolution ? Je pose cette question car j'ai vu que sur ubuntu, il y avait un paquet (xrandr) pour modifier artificiellement (scale) la résolution. Ce serait parfait, mais, avec la souris, plus moyen d'atteindre la partie droite de l'écran, ni la partie basse..... Donc plus moyen d'accéder à l'ascenseur, par exemple.....
Merci pour vos lumières
Cordialement
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Sun 13 Jan 2013, 14:01    Post subject:  

Bonsoir gilloraymondo,

La résolution d'écran actuelle n'est-elle pas déjà en 800x480 ?
Malheureusement la plupart des applications ne sont pas prévues pour cette faible résolution ce qui n'a rien à voir avec la résolution de l'écran sous X...

La puplette la mieux adaptée pour les 701 et encore disponible est Puppeee1.0 (avec une réserve pour le WiFi du 701 SD), mais elle commence à dater, ensuite la Fluppy...

La fonction : déplacer, est sous quel gestionnaire de fenêtres ?
On peut ajouter OpenBox sur Toutou...

La commande xrandr est normalement présente pour voir le détail des options disponibles dans la console :
Code:
xrandr --help


Les EEEPC utilisent 915resolution pour la carte graphique, pour connaitre les modes disponibles dans la console :
Code:
915resolution -l

(-l comme -list) cependant pour l'écran interne en 7" des 701 c'est en 800x480 maximum !

Voir ma réponse pour un écran virtuel en résolution supérieure :
résolution écran eeepc 701


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
gilloraymondo

Joined: 03 Dec 2011
Posts: 257

PostPosted: Sun 13 Jan 2013, 18:09    Post subject:  

Bonjour Médor,

Et merci pour ta réponse.

La fonction "déplacer" ou "move" : c'est avec un clic droit sur le bandeau de la fenêtre en haut. C'est bien plus efficace que "maximiser" avec Lucid Puppy.
Avec "déplacer" avec Lucid Puppy, je peux toujours accéder au bas de la fenêtre. Mais avec Toutou linux, ou precise, le bas reste invisible, et la fonction maximiser n'est pas toujours efficace.

Xrandr, c'est parfait. J'ai essayé avec lubuntu. Je ne savais pas que c'était disponible sur Puppy. Mais il y a un problème énorme qui rend cette solution inutilisable : pas moyen d'accéder avec la souris à la partie droite, et au bas de l'écran !!!!

Si ce problème pouvait être réglé, ce serait tout simplement parfait. Mais je ne sais pas si c'est possible.

Donc, il semble que la seule solution soit de s'orienter vers les puppy qui, comme Lucid Puppy, permet, avec la fonction "déplacer", d'avoir toujours accès au bas de l'écran.

Mais il y a beaucoup de versions, et pour l'instant, je n'ai trouvé que Lucid puppy qui permette celà (et aussi lubuntu, mais c'est plus lourd....)
Il y a d'autres versions de puppy, pas trop anciennes de préférence ?

Mais peut être qu'on peut ajouter un paquet pour permettre cette fonction à d'autres versions de toutou linux ?

Par contre, pour Internet, tout va bien, il suffit de faire en même temps ctrl , Fn et M, ou, au contraire, ctrl , Fn et +

Ce problème de résolution est vraiment embêtant car, avec son faible poid, il me parait tout à fait évident que Puppy serait le système d'exploitation révé pour les petits netbook qui ne disposent pas de beaucoup de place sur le disque dur (SSD).

Cordialement
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Sun 13 Jan 2013, 19:23    Post subject:  

Re,

Il faut modifier /etc/X11/xorg.conf pour pouvoir utiliser un écran virtuel d'une dimension plus grande, puis la commande xrandr comme expliqué sur le lien, ça donne une espèce de loupe de la résolution normale 800x480 de l'eeepc 701 sur un écran virtuel plus grand et à la souris on peut déplacer cette loupe en poussant le curseur de la souris sur le coté voulu...

Lucid comme Asri-300 utilisent OpenBox comme gestionnaire de fenêtres par défaut (JWM en option), Toutou et Precise n'utilisent que JWM par défaut d'où la différence de comportement de "Déplacer" par clic droit sur le titre de la fenêtre !

Il existe depuis quelques heures une version de Precise NOP 5.4.3 (135 Mo) avec XFCE 4.10 en remplacement de JWM !


Cordialement,
Médor.
Precise NOP 5.4.3.jpg
 Description   
 Filesize   85.02 KB
 Viewed   526 Time(s)

Precise NOP 5.4.3.jpg


_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
gilloraymondo

Joined: 03 Dec 2011
Posts: 257

PostPosted: Mon 14 Jan 2013, 03:09    Post subject:  

Bonjour Médor,
Et une nouvelle fois merci.
Je vais tester la nouvelle version de precise. J'avais essayé precise dès sa sortie et j'avais abandonné en raison de la résolution et de l'impossibilé absolue de voir le bas de certaines fenêtres.
J'essaierai aussi l'autre solution que tu proposes. Je n'exlue pas de te redemander ton aide car je ne suis pas sûr d'avoir tout compris sur la façon de procéder pour éditer X11.
Bien cordialement
Back to top
View user's profile Send private message 
gilloraymondo

Joined: 03 Dec 2011
Posts: 257

PostPosted: Tue 15 Jan 2013, 10:39    Post subject:  

Bonjour Médor,
Je suis en train de tester la solution que tu m'as suggeré : Precise NOP 5.4.3.
Pour l'instant, j'en suis seulement à l'essai sur une clé USB "live".

A première vue, cette nouvelle version de Puppy me semble tout simplement géniale.

J'ai toutefois un problème que je n'arrive pas à résoudre : installer amsn
Avec toutou linux ou Lucid Puppy, il suffit de télécharger le .pet de toutou linux (ce n'est pas une version à jour mais ça marche et c'est l'essentiel).

Mais avec precise NOP 5.4.3, si on fait ça, apparemment ça marche, mais après avoir éteind et redémarré, là, catastrophe, plus rien de rien ne fonctionne.

Installer des paquets depuis les dépôts ubuntu installés par défaut ne me pose aucun problème. Mais il est vrai que je connais un peu ubuntu.

Mais, pour des raisons de droits ou de philosophie, certains paquets ne figrent pas, ou ne figurent plus dans les dépôts ubuntu, comme amsn ou skype.
Mais si sur ubuntu il suffit d'ajouter le dépôt medibuntu en ligne de commande, là je ne sais pas du tout ce qu'il faut taper.

Quelqu'un le sait ?

Merci
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Tue 15 Jan 2013, 14:53    Post subject:  

Bonjour gilloraymondo,

Bien curieux ce dysfonctionnement au redémarrage !

Il existe la version amsn-0.98.9 dans les dépôts Ubuntu pour la 12.10 mais je n'ai pas vu une version spécifique pour Ubuntu 12.04 LTS sur Pkgs.org : les paquets proposés sont ceux des dépôts officiels.

Pour le PPM on peut ajouter l'URL d'un dépôt, voir dans les préférences > Add repo help : il faut éditer manuellement des fichiers...
Par contre je ne vois pas de paquet pour amsn sur le site et il ne semble pas être possible d'accéder directement aux paquets sans passer par la page html ou par aptget !

Ici j'utilise plutôt Pidgin qui est multiprotocole tout en occupant moins d'espace disque...
Avec la dernière version de Skype 4.1 pour Linux il est possible de se connecter également sur msn !
Il semble qu'il n'y ai plus de version statique de disponible sur le site officiel ce qui impose d'ajouter QT 4 (assez lourd juste pour une application...) je vérifierai la version statique que j'avais téléchargé si elle possède la connexion sur msn car pour l'instant j'ai monté un sfs d'une ancienne version.

Suite :
il faut passer à Skype 4.1 pour pouvoir se connecter à Windows Live Messenger !
(Lien rectifié...).

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou

Last edited by Médor on Thu 17 Jan 2013, 17:04; edited 2 times in total
Back to top
View user's profile Send private message 
gilloraymondo

Joined: 03 Dec 2011
Posts: 257

PostPosted: Tue 15 Jan 2013, 18:45    Post subject:  

Bonjour,

Et merci pour ta réponse Médor.

J'ai bien vu qu'avec la dernière version de skype, sur windows, on peut se connecter sur MSN : il y a une rubrique identification skype et une autre rubrique à droite pour l'identification avec son identifiant et mdp MSN

J'ai bien trouvé skype sur les dépots de precise NOP, mais il n'y a que la rubrique identification skipe et pas la rubrique à droite, d'identification avec son identifiant et mdp MSN.

Bon, là je ne sais pas comment faire pour ajouter amsn.
Sur ubuntu, je sais faire en ajoutant, en ligne de commande, le dépôt medibuntu, puis avec sudo apt-get install. Mais là, sur précise NOP, en ligne de commande, les commandes ubuntu ne sont pas reconnues, et je ne sais pas quoi taper.

J'ai essayé d'installer Gdebi, ce qui m'aurait permis d'installer amsn téléchargé par ailleurs, mais il manque une dépendance dans les dépôts, du moins c'est ce que m'indique le PPM....
Donc, pour l'instant pas de solution
Merci à celui qui pourra m'apporter ses lumières
Cordialement
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Thu 17 Jan 2013, 16:42    Post subject:  

Bonsoir gilloraymondo,

J'avais rectifié/complété mon message précédant pour Skype 4.1.

Il n'existe aucun paquet pour amsn dans les dépots de medibuntu !
Gdebi est installé par défaut sur Ubuntu de la v 8.04 LTS jusqu'à la 10.04 LTS, il faut satisfaire de nombreuses dépendances en python et au final pas sûr qu'il puisse fonctionner correctement sur Puppy !


Voici la page de description de amsn-0.98.9 pour Ubuntu Precise 12.04 :
http://packages.ubuntu.com/precise-backports/amsn
Amsn dépend principalement de Tcl/Tk 8.5 (>= 8.4).
Site officiel du projet : aMSN.

aMSN 0.9.8 fonctionne ici sur Pecise NOP même après avoir redémarré l'ordi Wink
J'ai installé les paquets suivant :
amsn_0.98.9-1ubuntu1~ubuntu12.04.1_i386.deb
amsn-data_0.98.9-1ubuntu1~ubuntu12.04.1_all.deb
(aMSN est divisé en deux paquets chez Ubuntu/Debian).

Puis dans le PPM chercher > Find: Tcl > recherche dans tous les dépôts puis dans la liste installer tcl8.5_8.5.11 et tk8.5_8.5.11-1
Je ne l'ai pas installé mais la libsnack2 et/ou la libsnack2-alsa peut être utile (liens sur la page "precise-backports" au dessus).


Pour les messageries en ligne une solution fort simple sans ajout d'aucun logiciel dédié (donc l'espace disque est totalement préservé...) il suffit de se connecter directement par le navigateur sur : https://imo.im !
Protocoles disponibles : MSN, Skype, Facebook, GTalk, Yahoo, Jaber, AIM, ICQ ainsi que Stream et VKontakte en plus de IMO (facultatif) !
On peut se connecter sur plusieurs comptes simultanément...

Bref, on a largement débordé du sujet initial, un fil dédié à la Precise NOP (FR...) serai plus opportun Very Happy

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0816s ][ Queries: 13 (0.0041s) ][ GZIP on ]