Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 23 Aug 2014, 09:45
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
I moved from Slacko 5.3 to 5.4 and now have more problems
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
consentient

Joined: 23 Oct 2012
Posts: 23

PostPosted: Sun 16 Dec 2012, 12:54    Post subject:  I moved from Slacko 5.3 to 5.4 and now have more problems  

Background: I decided to install 5.4 because of a problem I had previously had on 5.3 where the X Server kept crashing at random. I was advised that 5.4 had more support for Intel graphics cards, and so I downloaded the 5.4 ISO, burnt it, booted into it, and burned the ISO to USB.

I am now running the 5.4 install and so far the X Server issue has not repeated. However:-

1. I can no longer easily write to my NTFS partitions. Previously this was no problem at all.

2. The process of saving the contents of RAM to the savefile - that happens a few times per hour - now takes an absolute age. With 5.3, my 4GB savefile never took more than 20 seconds to save. Now it takes well over a minute and the CPU usage is maxed out and nothing else works at all. Previously, I could still do other things, provided they did not use too much CPU. Now I just have to sit and wait until I can use my PC again.

This is not acceptable to me. If I can solve both of these problems in short order I will continue to use and recommend Puppy. Otherwise I will have to seek alternative OS's.

Any help is much appreciated.
Back to top
View user's profile Send private message 
SFR


Joined: 26 Oct 2011
Posts: 1053

PostPosted: Sun 16 Dec 2012, 14:34    Post subject: Re: I moved from Slacko 5.3 to 5.4 and now have more problems  

consentient wrote:
2. The process of saving the contents of RAM to the savefile - that happens a few times per hour - now takes an absolute age. With 5.3, my 4GB savefile never took more than 20 seconds to save. Now it takes well over a minute and the CPU usage is maxed out and nothing else works at all. Previously, I could still do other things, provided they did not use too much CPU. Now I just have to sit and wait until I can use my PC again.

Similar problem here...

Slacko-5.4-PAE, 4GB slackosave.2fs on NTFS partition (compression = off, savefile defragmented), pmedia=ataflash (to have "save-on-demand" ability).

In my case it's less predictable - sometimes works fast and smooth, sometimes even totally hangs and the only solution is power button.
It happens more often when relatively bigger files are being copied from /initrd/pup_rw to /initrd/pup_ro1.

I've noticed that using directly:
Code:
cat /dev/zero > /initrd/pup_ro1/root/bigtestfile

sometimes creates the empty file smoothly (HDD led flashes until finished), but sometimes after 100-200MB, HDD led goes out for over a dozen seconds (or much longer), then just a few MB are being written and so on.

I can't find any pattern in that behavior, but hopefully my observations will help someone to find the source of the problem.

EDIT: Corrected the code above.

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5086
Location: Charleston S.C. USA

PostPosted: Sun 16 Dec 2012, 16:11    Post subject:  

Quote:
This is not acceptable to me. If I can solve both of these problems in short order I will continue to use and recommend Puppy. Otherwise I will have to seek alternative OS's.

Realize that Slacko 5.4 may still have problems. You seem to have found one.
Slacko is at the cutting edge of Puppy development.
Takes a while for all the bugs to show up and get fixed.

One of the older versions of Puppy may work better for you.

As my main operating system, I use Lucid Puppy 528.005 for just that reason. It got well tested and bug fixed.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
slenkar

Joined: 10 Jul 2009
Posts: 204

PostPosted: Sun 16 Dec 2012, 17:06    Post subject: Re: I moved from Slacko 5.3 to 5.4 and now have more problems  

consentient wrote:
Background: I decided to install 5.4 because of a problem I had previously had on 5.3 where the X Server kept crashing at random. I was advised that 5.4 had more support for Intel graphics cards, and so I downloaded the 5.4 ISO, burnt it, booted into it, and burned the ISO to USB.

I am now running the 5.4 install and so far the X Server issue has not repeated. However:-

1. I can no longer easily write to my NTFS partitions. Previously this was no problem at all.

2. The process of saving the contents of RAM to the savefile - that happens a few times per hour - now takes an absolute age. With 5.3, my 4GB savefile never took more than 20 seconds to save. Now it takes well over a minute and the CPU usage is maxed out and nothing else works at all. Previously, I could still do other things, provided they did not use too much CPU. Now I just have to sit and wait until I can use my PC again.

This is not acceptable to me. If I can solve both of these problems in short order I will continue to use and recommend Puppy. Otherwise I will have to seek alternative OS's.

Any help is much appreciated.


Well at least the X server doesnt crash anymore Very Happy Very Happy Very Happy Very Happy

Just politely post about the 2 new problems on the precise thread and they might get solved.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0582s ][ Queries: 12 (0.0060s) ][ GZIP on ]