Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 03 Sep 2014, 02:05
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Slacko 5.4 How do I change clock to 12 hours? (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Author Message
angelsonefive

Joined: 12 Dec 2012
Posts: 5

PostPosted: Wed 12 Dec 2012, 17:06    Post subject:  Slacko 5.4 How do I change clock to 12 hours? (Solved)  

OSMO and pupclockset 1.9.2 have no effect. Is there another way to change from military time to 12 hour clock?
Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3365
Location: Oregon

PostPosted: Wed 12 Dec 2012, 17:24    Post subject:  

Right_click on the digital clock in the task bar.
Select "Digital Clock" settings.
In the window that appears, change the "%R" to "%1:%M %p" .
Then close the window and restart the the window manager.

That worked for me in Slacko 5.4 running comp-fusion.
Back to top
View user's profile Send private message 
angelsonefive

Joined: 12 Dec 2012
Posts: 5

PostPosted: Fri 14 Dec 2012, 10:51    Post subject:  

Doesn't work, both left and right click simply open the OSMO calendar
Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3365
Location: Oregon

PostPosted: Fri 14 Dec 2012, 12:13    Post subject:  

In the case of not seeing that option when right-clicking on the taskbar digital time display, you can try another solution.

Click on the House on the desktop to open ROX in the /root directory.
Then Click on the EYE to show hidden files.
Next, right-click on .jwmrc-tray and select Open as text.
At the end of that file, you will see a line that says:
"<Clock format="%H:%M">minixcal</Clock>" without the outside quotes.

Change that line again without the outside quotes to:
"<Clock format="%1:%M %p">minixcal</Clock>"

Restart the window manager and you should be greeted with am/pm type of time display.

This is for the Openbox and JWM window managers by the way.

It does not work when running xfce4 as window manager and also with comp-fusion.

Let us know if it works for you.
Back to top
View user's profile Send private message 
angelsonefive

Joined: 12 Dec 2012
Posts: 5

PostPosted: Sun 16 Dec 2012, 02:00    Post subject:  

I made sure that my window manager is JWM and I pasted the line below, then restarted the window manager and also the X server but still shows 22.57 as the time format.


<Clock format="%l:%M %p">minixcal</Clock>
Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3365
Location: Oregon

PostPosted: Sun 16 Dec 2012, 02:36    Post subject:  

I do not know what is going on with the forum . But the character after the first percent sign is the numeral 1.
It is not showing as that so I will try doing a paste of it to this message in a code box.
I did not do it because the line was again changed.

So here it is manually I hope.



<Clock format="%1:%M %p">minixcal</Clock>

That seemed to work although I had to edit the line as a paste into the message had changed the %1 to a %l (lower case L).

So be sure that the character after the first percent sign is the numeral one.

It should then work for you.
Back to top
View user's profile Send private message 
postfs1


Joined: 27 Mar 2010
Posts: 831

PostPosted: Sun 16 Dec 2012, 03:28    Post subject:  

8-bit wrote:
I do not know what is going on with the forum . But the character after the first percent sign is the numeral 1.
...


Cache from the search engine --->
10949.13428.0.14776.png
 Description   
 Filesize   23.94 KB
 Viewed   680 Time(s)

10949.13428.0.14776.png


_________________
  • I don't know why laboratories are named a hospitals.
  • The alive personage is like a tea bag with granules of unknown density inside, at that one the packet was made of organic material and was placed in the evaporated liquid or liquid.

Back to top
View user's profile Send private message 
Jasper


Joined: 25 Apr 2010
Posts: 1111
Location: England

PostPosted: Sun 16 Dec 2012, 08:47    Post subject:  

Hi,

If all else fails - left click on /root/.jwmrc-tray, then arrow
down to the bottom of the file, then amend the Clock line to:
<Clock format="%H:%M">minixcal</Clock>
then save
then use Menu>Shutdown>Restart JWM

My regards
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11034
Location: Arizona USA

PostPosted: Sun 16 Dec 2012, 09:41    Post subject:  

8-bit wrote:
I do not know what is going on with the forum . But the character after the first percent sign is the numeral 1.
It is not showing as that so I will try doing a paste of it to this message in a code box.
I did not do it because the line was again changed.

So here it is manually I hope.



<Clock format="%1:%M %p">minixcal</Clock>

That seemed to work although I had to edit the line as a paste into the message had changed the %1 to a %l (lower case L).

So be sure that the character after the first percent sign is the numeral one.

It should then work for you.

I edited your previous post to change the "l" in that line to a 1. It seemed to take, so I don't know what happened when you posted it. Did you try to edit that post and nothing changed?
Back to top
View user's profile Send private message 
russoodle


Joined: 12 Sep 2008
Posts: 659
Location: Down-Under in South Oz

PostPosted: Sun 16 Dec 2012, 10:50    Post subject:
Subject description: my results in JWM
 

8-bit wrote:
<Clock format="%1:%M %p">minixcal</Clock>

That seemed to work although I had to edit the line as a paste into the message had changed the %1 to a %l (lower case L).

So be sure that the character after the first percent sign is the numeral one.

It should then work for you.

I'm using Slacko with JWM.

Below, in the clock-parameters image, is what i get using "%1...." as per your advice, 8-bit....no disrespect, but the numeral "1" doesn't seem to be a valid parameter....in the 12-hr clock image, the lowercase "L" is used.
12hr-clock.png
 Description   only used the "%p" here to show the AM time
 Filesize   73.51 KB
 Viewed   619 Time(s)

12hr-clock.png

clock-parameters.png
 Description   sorry it's not clearer but scaled down image size
 Filesize   71.65 KB
 Viewed   618 Time(s)

clock-parameters.png


_________________
This aging business really bugs me - it didn't bother me years ago, so why is it happening now??
meownplanet - puppylinuxstuff
Back to top
View user's profile Send private message 
CatDude


Joined: 03 Jan 2007
Posts: 1470
Location: UK

PostPosted: Sun 16 Dec 2012, 10:52    Post subject:  

Hi

I do not think that %1 (that's a number one) is a valid parameter.

According to this page the closest things resembling it are either a lower case letter ell, or an uppercase letter i

The images below show the result of using:
    %1:%M %p (a number one)
    %I:%M %p (an uppercase letter i)

in Slacko-5.4 running Compiz and the LXPanel.

In both instances there is no AM/PM shown after the time. Confused

CatDude
.
a-number-one-i-dont-think-so.png
 Description   
 Filesize   48.9 KB
 Viewed   633 Time(s)

a-number-one-i-dont-think-so.png

still-no-AM-PM.png
 Description   
 Filesize   47.59 KB
 Viewed   642 Time(s)

still-no-AM-PM.png


_________________

Back to top
View user's profile Send private message 
Jasper


Joined: 25 Apr 2010
Posts: 1111
Location: England

PostPosted: Sun 16 Dec 2012, 11:35    Post subject:  

Hi CatDude et al,

If am/pm is needed does:

<Clock format="%l:%M %p">minixcal</Clock>

that's a lower case L - work.

My regards

PS the space beween %M and %p inserts a space in the output.
Back to top
View user's profile Send private message 
CatDude


Joined: 03 Jan 2007
Posts: 1470
Location: UK

PostPosted: Sun 16 Dec 2012, 12:56    Post subject:  

Hello Jasper

Jasper wrote:
Hi CatDude et al,

If am/pm is needed does:

<Clock format="%l:%M %p">minixcal</Clock>

that's a lower case L - work.

My regards

PS the space beween %M and %p inserts a space in the output.


It's not so much that it is needed, more curiosity as to why it doesn't show in LXPanel.

Anyway mate, to answer your question, no it does not work (in the LXPanel)

CatDude
.
with-the-lowercase-L.png
 Description   
 Filesize   44.86 KB
 Viewed   610 Time(s)

with-the-lowercase-L.png


_________________

Back to top
View user's profile Send private message 
Jasper


Joined: 25 Apr 2010
Posts: 1111
Location: England

PostPosted: Sun 16 Dec 2012, 13:21    Post subject:  

Hi CatDude,

Thanks for joining with your expertise.

I have reread angelonefives words twice more and I still miss
any mention of LXPanel (or for that matter am/pm).

Either I missed the reference, or you, in your wisdom, made
that assumption or already knew otherwise.

I have never used LXPanel, but it does seem that the 12 hour
clock is available, perhaps without am/pm.

My regards
Back to top
View user's profile Send private message 
CatDude


Joined: 03 Jan 2007
Posts: 1470
Location: UK

PostPosted: Sun 16 Dec 2012, 16:06    Post subject:  

Hello Jasper

Jasper wrote:
..I have reread angelonefives words twice more and I still miss
any mention of LXPanel (or for that matter am/pm).

Either I missed the reference, or you, in your wisdom, made
that assumption or already knew otherwise.


Laughing Sorry for any confusion caused,
but my first post was in response to 8-bit's statement:

8-bit wrote:
...But the character after the first percent sign is the numeral 1.

and i was pointing out that that did not appear to be true According to this page

Jasper wrote:
..I have never used LXPanel, but it does seem that the 12 hour
clock is available, perhaps without am/pm.

That is quite correct,
and the only reason i mentioned LXPanel is because of this:

8-bit wrote:
...That worked for me in Slacko 5.4 running comp-fusion.

Which is exactly what i am running here, and that includes using the LXPanel

CatDude
.

_________________

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0883s ][ Queries: 13 (0.0046s) ][ GZIP on ]