Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 16:49
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
snap2 rotating snapshot backups for Puppy
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 11 of 11 Posts_count   Goto page: Previous 1, 2, 3, ..., 9, 10, 11
Author Message
lstandish


Joined: 06 Jun 2008
Posts: 126

PostPosted: Mon 24 Sep 2012, 18:33    Post_subject:  

Hi Pete,
ext 4 should be fine. snap2 is a frontend to rsync, so I think it will work on any file system that support hard links, which is all Linux filesystems, I believe.
Back to top
View user's profile Send_private_message 
Pete22


Joined: 08 May 2009
Posts: 241
Location: Utah, USA

PostPosted: Tue 25 Sep 2012, 19:58    Post_subject:  Thanks  

That's wonderful news.

My next step is to get it setup and working.


Pete
Back to top
View user's profile Send_private_message 
Jasper


Joined: 25 Apr 2010
Posts: 1145
Location: England

PostPosted: Wed 10 Oct 2012, 14:02    Post_subject:  

Hi,

I use Snap2 with ext4. It's superb, reliable and fast - it even reports how fast - the incremental option is usually >100 times faster than a full backup.

My regards
Back to top
View user's profile Send_private_message 
lstandish


Joined: 06 Jun 2008
Posts: 126

PostPosted: Wed 10 Oct 2012, 15:47    Post_subject:
Sub_title: has anyone ever backed-up to remote server?
 

I'm glad you've found the program useful, Jasper.

Do you (or anyone else who reads this forum post) use snap2 to backup to *remote* media via Internet? This would normally be to a VPS (virtual private server) or a dedicated sever.

I ask because in the years since I wrote snap2, I've never heard that anyone (besides myself) has used the backup-to-remote-server option.
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1465
Location: Malvern, Worcs, UK

PostPosted: Wed 28 Nov 2012, 13:04    Post_subject:  

Hi lstandish

I'm a happy user of snap2 on Slacko 5.3.3 at the moment.

I've been looking into upgrading to a more recent Puppy - and the one that seems to meet my needs is the LxPup variant of Precise.

I've been trying to get Snap2 running today and have run into problems, so I'm wondering if you can advise?

On LxPup (and also on Upup Precise that LxPup is built on) I get gui problems.

I've spent all day looking at your gtkdialog code but have come to the conclusion that I'm unable to work out what's going wrong.

What I've done is replace all occurrences of GTKDIALOG with GTKDIALOG -d in /usr/bin/snap2 and then run snap2 in a terminal - the output is:
Code:
sh-3.00# snap2
widget_entry_refresh(): <label> not implemented for this widget.
widget_entry_refresh(): <label> not implemented for this widget.
widget_entry_refresh(): <label> not implemented for this widget.
widget_combobox_input_by_command(): <input> not implemented for this widget.
/usr/bin/snap2: eval: line 660: syntax error near unexpected token `<'
/usr/bin/snap2: eval: line 660: `<window title="snap2 v4.25 | User root | Settings: default.set"><hbox><vbox><text use-markup="true"><label>"<b>Backup Configuration in 4 Easy Steps</b>'

I'm wondering if the multi-line text message in ADD_DIALOG is throwing it?

The version of GTKDIALOG in LxPup is:
Quote:
sh-3.00# gtkdialog -v
gtkdialog version 0.8.3 r473M (C) 2003-2007 Laszlo Pere, 2011-2012 Thunor
Built with additional support for: Glade.


Hope we can work out whats wrong and get it going
Cheers
peebee

p.s. Snap2 4.25 works OK in Precise 5.4.1 with gtkdialog version 0.8.0 (C)

Snap2 4.25 run from terminal in Slacko 5.3.7.7 gives similar "not implemented for this widget" errors but works. gtkdialog version 0.8.2 r455M (C) Built with additional support for: Glade, VTE.

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
peebee


Joined: 21 Sep 2008
Posts: 1465
Location: Malvern, Worcs, UK

PostPosted: Wed 12 Dec 2012, 15:40    Post_subject: Problem update  

Update on my problem above....

After lots of testing and dialogue with Thunor - gtkdialog guru - it would appear that there are some versions of gtkdialog (a version of gtkdialog that is r472 to r482 inclusive) where Snap2 does not work properly - however it does work with earlier versions and with the latest version as at 12/12/12 - r493

If you have problems with Snap2 then you may need to downgrade or upgrade the version of gtkdialog on your Puppy.

In tracking down this conclusion, Thunor has recommended the amendments shown below to /usr/bin/snap2 (which improve it but do not cure the underlying problem).

Thunor explains the changes:
http://www.murga-linux.com/puppy/viewtopic.php?t=82648&start=22

These changes have been incorporated into the /usr/bin/snap2 in the attached pet WHICH ONLY CONTAINS THE UPDATED /usr/bin/snap2.

Cheers
peebee

Changes:
Quote:
Move the "Select a Directory" text at line 478 into the entry tag using fs-title=\"Select a Directory\" and delete the <label></label>.
Do the same at lines 500 and 517.

at line 631 is "<input>ls</input>" just remove it

You should try adding " | grep =" to the end of the GKDIALOG part so that you'll get something like:
Code:
for STATEMENTS in $($GTKDIALOG --program=MSG_DIALOG | grep =); do

There are seven of them, search for "eval".
snap2-4.25-update.pet
Description  Slightly changed version uploaded after download #5 - sorry!
pet

 Download 
Filename  snap2-4.25-update.pet 
Filesize  15.75 KB 
Downloaded  317 Time(s) 

_________________
LxPup-14.10 = Puppy + LXDE

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Thu 13 Dec 2012, 09:37    Post_subject:  

@peebee

I've just had a look at the snap2 source within your pet and you've left the test code in there that I gave you, this at line 654:
Code:
$GTKDIALOG -v; echo "$MAIN_DIALOG" > /tmp/snap2_MAIN_DIALOG; $GTKDIALOG --program=MAIN_DIALOG; exit

It's not meant to be left in there. Maybe I should've mentioned that it's only test code, it was simply for you to gain access to the otherwise obscured output and send it to me. Anyway, you ought to remove it. The rest of it looks fine.

If anyone has installed the above update then simply open /usr/bin/snap2 and remove that line at 654.

Regards,
Thunor
Back to top
View user's profile Send_private_message Visit_website 
peebee


Joined: 21 Sep 2008
Posts: 1465
Location: Malvern, Worcs, UK

PostPosted: Thu 13 Dec 2012, 15:44    Post_subject:  

thunor wrote:
you've left the test code in there that I gave you, this at line 654:


OOOOps...sorry....

Pet amended and reuploaded after download #5 - apologies to those who have downloaded.....

PeeBee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 11 of 11 Posts_count   Goto page: Previous 1, 2, 3, ..., 9, 10, 11
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0879s ][ Queries: 13 (0.0179s) ][ GZIP on ]