Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 15:43
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
This forum, dillo, utf-8 and international text with diacretica like
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
LaRioja

Joined: 23 Feb 2012
Posts: 20
Location: Augsburg/Germany

PostPosted: Sat 08 Dec 2012, 11:28    Post_subject:  This forum, dillo, utf-8 and international text with diacretica like  

Hello,
I stumbled over a strange problem reading this forum with the
small dillo webbrowser. When reading the german section I
always get stange characters where letters with diacretica are supposed
to be like 'Für deutschsprachige Anhänger'
instead of 'Fr deutschsprachige Anhnger'.
(I even don't know if this will be encoded well when sending this text.)
When I look at the sourcecode of the page loaded it says to be
charset=iso-8859-1 in the header. But in reality the text is utf-8,
so I guess the server sends the pages with a different encoding than
that mentioned in the source-header.
Some browsers like dillo take this seriously and interprete the text strictly
others like seamonkey successfully guess what the text should be.

Have you experienced similar things browsing this forum?
Which browser did you use?
(English speaking people surfing the english topics
should never get annoyed about this, I guess.)

Is there a way to get this into order?
(I appreciate dillo for it's speed and small footprint.)
Back to top
View user's profile Send_private_message 
Jasper


Joined: 25 Apr 2010
Posts: 1204
Location: England

PostPosted: Sat 08 Dec 2012, 11:54    Post_subject:  

Hi Flash, LaRioja et al.

Quote:
Jasper,

i've looked into the issue ...

Dillo will only display special chars correct if

a) the charset is set to utf-8 as burunduk mentions
b) special chars are escaped properly (what as far as i see/understand does not happen for the message-body in the forum)

so it seems this is more a phpBB issue, than a dillo issue. Other browser just seem to be more fault-tolerant.

aragon


My query was raised here:
http://murga-linux.com/puppy/viewtopic.php?p=665640&sid=8ff79f936eb90879bc7edc39a0b40dcd#665640

My regards
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0396s ][ Queries: 12 (0.0031s) ][ GZIP on ]