Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 08:10
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
ArchPup - Puppy based on Arch Linux
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 8 of 14 [207 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, 11, 12, 13, 14 Next
Author Message
mavrothal


Joined: 24 Aug 2009
Posts: 1686

PostPosted: Wed 05 Dec 2012, 08:42    Post subject:  

simargl wrote:
It is original linux-api-headers from Arch. I did not compile it, because glibc needs them and
I thought that recompiling them could create some compatibility issues. You have list of
files from that package here /var/lib/spkg/installed/linux-api-headers.


It's a good idea the kernel headers to come from the kernel in use.
For most user-space apps kernel headers make little difference so you should not be worried for this kind of packages.
But kernel related stuff (drivers, fs etc) may not compile or compile but fail to work if build against a different kernel.
So I would think to run linux-api-headers/PKGBUILD against your patched and configured kernel source and include this in the build.

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
slenkar

Joined: 10 Jul 2009
Posts: 214

PostPosted: Wed 05 Dec 2012, 09:53    Post subject:  

simargl wrote:

@slenkar: Can you if test this works
Code:
 git clone git://github.com/keenerd/packer.git


yep that worked,
Was that to test if I can use git?
Back to top
View user's profile Send private message 
simargl
Guest


PostPosted: Wed 05 Dec 2012, 10:02    Post subject:  

I tried to compile linux-api-headers and got this after make headers_check
Code:
perl: warning: Falling back to the standard locale ("C").
/usr/src/linux-3.6.8/usr/include/asm-generic/fcntl.h:4: included file 'linux/types.h' is not exported
/usr/src/linux-3.6.8/usr/include/asm-generic/ioctls.h:4: included file 'linux/ioctl.h' is not exported
/usr/src/linux-3.6.8/usr/include/asm-generic/siginfo.h:5: included file 'linux/types.h' is not exported
/usr/src/linux-3.6.8/usr/include/asm-generic/signal.h:4: included file 'linux/types.h' is not exported
/usr/src/linux-3.6.8/usr/include/asm-generic/statfs.h:4: included file 'linux/types.h' is not exported
/usr/src/linux-3.6.8/usr/include/asm-generic/termbits.h:4: included file 'linux/posix_types.h' is not exported
make[2]: *** [/usr/src/linux-3.6.8/usr/include/asm-generic/.check] Error 123
make[1]: *** [asm-generic] Error 2
make: *** [headers_check] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

It's definitely related to aufs, becuase without aufs patches it compiles fine. But how to fix this?
Any ideas?
@slenkar: Yes, that was for testing git, so if that works you can now use packer Smile
Back to top
mavrothal


Joined: 24 Aug 2009
Posts: 1686

PostPosted: Wed 05 Dec 2012, 13:45    Post subject:  

simargl wrote:
I tried to compile linux-api-headers and got this after make headers_check


I _think_ this may have to do with how you got, patched and packaged your source and not with the aufs code per se.

Trying
Code:
make INSTALL_HDR_PATH=/root headers_install
I do get the same perl warning but the aufs_type.h and version.h are properly exported.
These are sufficient to allow aufs-utils compilation. I attache the compiled utilities in case someone else wants to try them.
aufs-util3-archpup.tar.gz
Description  aufs-utils for archpup 1204-1
gz

 Download 
Filename  aufs-util3-archpup.tar.gz 
Filesize  52.18 KB 
Downloaded  274 Time(s) 

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
T_Hobbit


Joined: 27 May 2006
Posts: 400
Location: Portugal - Lisbon

PostPosted: Wed 05 Dec 2012, 18:28    Post subject:  

simargl wrote:
So I got only one response on request for testing udev Sad. OK
See this linux-firmware-20121118.tar.xz in ftp://ftp.archlinux.org/other/linux-firmware/
It contains all linux firmware and needs only simple compressing to sfs module.
I will leave that to interested users (if any). Today will make final update to version 1204
with new udev and some other stuff.


I try your fix but no luck. Will try again later more carefully.
Also still trying to figure out where to create the savefile...

_________________
T_Hobbit
Idea Rebuilding old DOS Machine for Wing Commander Privateer and Puppy Exclamation Old spare parts to give away - anyone interested Question
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 1686

PostPosted: Thu 06 Dec 2012, 03:43    Post subject:  

simargl wrote:
I tried to compile linux-api-headers and got this after make headers_check
Code:
perl: warning: Falling back to the standard locale ("C").
/usr/src/linux-3.6.8/usr/include/asm-generic/fcntl.h:4: included file 'linux/types.h' is not exported
...

It's definitely related to aufs, becuase without aufs patches it compiles fine. But how to fix this?


I would think your solution is this one

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
simargl
Guest


PostPosted: Thu 06 Dec 2012, 08:41    Post subject:  

New release 1204-2 will soon be available...
@mavrothal: I will use original linux-api-headers package for Arch.
As some test, today I've tried to make nvidia kernel module on my
older computer. It compiled and loaded without problems, so will keep it this way.
Back to top
mavrothal


Joined: 24 Aug 2009
Posts: 1686

PostPosted: Thu 06 Dec 2012, 08:59    Post subject:  

simargl wrote:
@mavrothal: I will use original linux-api-headers package for Arch.
As some test, today I've tried to make nvidia kernel module on my
older computer. It compiled and loaded without problems, so will keep it this way.

Is your baby Smile
Do consider adding aufs-utils in the build though.

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
slenkar

Joined: 10 Jul 2009
Posts: 214

PostPosted: Thu 06 Dec 2012, 12:46    Post subject:  

compiling AUR apps seems to work as long as Udev is installed and not the archlinux devel package
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 901
Location: London, England

PostPosted: Thu 06 Dec 2012, 23:49    Post subject:  

Testing ArchPup 1204-2 now and seems good.
Keyboard needed setxkbmap gb to give me UK layout.
Managed to compile and install DeaDBeef from source and used pacman to install other packages like XArchiver, Linphone and Seamonkey.

I am able to add icons as launchers in the panel and stuff like that.
I did try to set the panel to auto-hide and it does work but the action of passing the cursor to the edge to reveal the panel seems a bit fiddly. Will do some more testing tomorrow.

_________________
Oscar in England

Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 2096
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Fri 07 Dec 2012, 05:14    Post subject:  

Hi

Did download .2 and copy it into my installation instead of .1 but have to come back to .1 because it will not start at all!

an other message in relation with .2:

Médor wrote:
Bonsoir Oui,

Je télécharge la 1024-2 en espérant que le WiFi fonctionne ! Ce n'est pas le cas sur la 1024-1 Evil or Very Mad
Mes commentaires étaient à propos de la première version, je réactualiserai en conséquence...

Édité :
Malheureusement toujours aucun répertoire firmware dans /lib Shocked
Même en les ajoutant ça ne fonctionne pas Rolling Eyes

Cordialement,
Médor.


he also seems don't to be really enthousiast Embarassed

I thing about the matter to install new kernels not being from Puppy and not really being from GNU! I don't know Arch. Where is the source from Arch's kernel?

http://www.fsf.org/events/join-the-fsf-and-friends-in-updating-the-free-software-directory-5

and especially

http://directory.fsf.org/wiki/GNU_Linux-libre

http://www.gnu.org/software/hurd/hurd.html

at your place, I would let the link to the download of the .1 version ALSO appear together with the other new link in the message #1 of this thread a good week for thus having difficulties to use version .2 ...

Kind regards

Note: perhaps it would be a good thing to find a link to a help file in the menu and in the help file a begin to actualize a history of the version changes so that the user can see and understand with what he is operating now!
Back to top
View user's profile Send private message 
simargl
Guest


PostPosted: Fri 07 Dec 2012, 05:33    Post subject:  

@slenkar: Hi, udev package is different than in Arch, compiled and added in IgnorePkg list.
You should not reinstall it or your machine might be unbootable, Xorg won't work etc.

Hi oui,
Did you try to boot it without savefile, using option pfix=ram.
At what stage did it stop for you? Kernel is same as in previous release, only udev is upgraded.
I don't understand Médors message, it looks like he needs linux-firmware package,
it's explained some posts before.
Back to top
oui

Joined: 20 May 2005
Posts: 2096
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Fri 07 Dec 2012, 10:24    Post subject:  

Hi Simargl

X doesn't start.

it try and try and try to start and it is not possible to break this process.

(I can't start RAM only from CD as I have no working CD drive: I always start from hard disk. so I can't enter some start parameters... But as I don't use some save file at all, it is in my opinion the same as a RAM only start)

king regards
Back to top
View user's profile Send private message 
simargl
Guest


PostPosted: Fri 07 Dec 2012, 12:27    Post subject:  

@oui: Here is solution provided by cinclus_cinclus. You could try that
http://murga-linux.com/puppy/viewtopic.php?p=668963#668963
But, since you dont use save file I think you need to remaster iso, with
unsqashfs arch-1204.sfs
then edit /etc/profle to disable autologin- just comment last 5 lines inside if statement,
and compress it again.
When you boot run X -configure, and see in /var/log/Xorg.log for errors.
Back to top
Keef


Joined: 20 Dec 2007
Posts: 633
Location: Staffordshire

PostPosted: Fri 07 Dec 2012, 18:57    Post subject:  

Up and running with wifi now. Had to edit the sfs though and add b43 firmware, and a script to get it all running - pwireless2 is not showing anything for me. I cheated and put an already configured wpa_supplicant.conf into etc/.
Also added Opera downloaded from Arch repo. (I have Opera-Next that I use with several Puppies, but it segfaults with Archpup).
Not having any joy with savefiles - if they do appear to load, they do not actually contain anything.

Compaq Armada M700 P3 850mhz
2012-12-07-005328_1024x768_scrot.png
Description 
png

 Download 
Filename  2012-12-07-005328_1024x768_scrot.png 
Filesize  183.75 KB 
Downloaded  297 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 8 of 14 [207 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, 11, 12, 13, 14 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0918s ][ Queries: 13 (0.0068s) ][ GZIP on ]