Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 25 Mar 2019, 04:06
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Touchscreen HOWTO
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 6 [83 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6
Author Message

Joined: 04 Apr 2007
Posts: 6815
Location: Chatham, Kent, UK

PostPosted: Thu 05 Jan 2012, 01:49    Post subject:  

There is a retro version of Lucid 525 which uses the same kernel as 431, which you could try, and might be able to upgrade kernel
Also see if a kernel upgrade can be applied to 431?
Polarpup/Icepup and Lupen also use 2.6.38, Slacko 531 has 2.6.39, and I'm using it now
see also

Perhaps MU could help with a German version?
However I thought Internationalisation was now functional in later puppies?

Aitch Smile
Back to top
View user's profile Send private message 

Joined: 04 May 2005
Posts: 274
Location: Northwest Florida, U.S.A.

PostPosted: Mon 06 Aug 2012, 15:06    Post subject:    

Hey, need some help figuring out what driver type to use with a Fujitsu Point 1600. Tried a bunch of the things mentioned in this but no go. Googling this machine doesn't pull up anything for what driver or even connection type it uses (USB, serial, etc.). lspci & lsusb & cat the device input & TTY & events don't seem to show up much. Any commands to definitively try?
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger 

Joined: 04 Apr 2007
Posts: 6815
Location: Chatham, Kent, UK

PostPosted: Thu 09 Aug 2012, 10:36    Post subject:  

Don't know if this is any use?



maybe a driver from a different model?


Info's a bit sparse for that one...

Aitch Smile
Back to top
View user's profile Send private message 

Joined: 01 Dec 2012
Posts: 1

PostPosted: Sat 01 Dec 2012, 19:40    Post subject: compaq tc1000 touchscreen  

Hello guys. I'm an eager but very basic user of puppy and linux, and at the moment I'm trying to bring a Compaq TC1000 back to life.
Puppy (4.3.1) works fine as usual, but the touchscreen doesn't work. I installed the pet from the beginning of this thread, but I can't understand most of what comes after. Could someone please help with some 'idiot-proof' guidelines?
Back to top
View user's profile Send private message 

Joined: 10 Jun 2005
Posts: 5472
Location: Australia

PostPosted: Sun 02 Dec 2012, 01:04    Post subject:  

longobedience, at the outset, you need to do some research to learn exactly what type of touchscreen device is in your laptop, and what interface it's connected to (USB, serial, or PS/2).
Then the instructions I provided on page 1 will make more sense, because you will know which section is relevant.

Fortunately for you, I just did this research for you: your touchscreen device is the Fujitsu Finepoint Stylus, which is connected to an internal serial port.

So the relevant instructions for you are - "HOWTO - serial touchscreens" -
Work your way through that information carefully.
Your kernel module will be "fujitsu_ts"
and your Xorg driver will be "fujitsu" (in more recent versions of Linux this is now "fpit").

Your serial address will probably (?) be /dev/ttyS0

And just in case someone with a Compaq TC1100 stumbles upon this information - don't assume your touchscreen is the same!
It's not.
Back to top
View user's profile Send private message 

Joined: 20 Jul 2010
Posts: 5434
Location: Republic of Novo Zelande

PostPosted: Thu 24 Jul 2014, 20:40    Post subject:  

I have a touchscreen enabled Windows tablet (Acer Iconia W501) which uses a 64 bit AMD cpu. I have been trying various 32 and 64 bit puppies with varying degrees of touchscreen success, but would like a recommendation for which puppy would be considered 'standard' enough for testing the concepts in this thread (which I only just stumbled across today...)

Tempestuous - I don't want to waste your time trying non-standard puppies so can you suggest a 'standard' puppy that I could do some meaningful testing with?

(So far I have good reliable behaviour using Slacko 5.3.3t so I know the eGalax usb touchscreen is functional. With 533t the touchscreen is treated like a touchpad - responding to finger direction, and treating a screen tap like a mouse click. It does not provide positional accuracy, so I cannot generate a click at the exact point where my finger touches the screen, but I can position the cursor at the correct position and tap the screen anywhere to click at the cusror position)

I know there are many drivers, and a variety of kernels which treat the drivers differently, so I am not sking for miracles - I just want to work with a 'standard, official' puppy and see where i get to...
Back to top
View user's profile Send private message 

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Thu 24 Jul 2014, 23:24    Post subject: Lighthouse64 provides some working functionality-past 3yrs  

Hello @Greengeek. This post assumes one would use their finger on the screen to carry out some needs.

Assuming your smartDevice is x86 64bit Touch technology
I think you may have already tried LightHouse64 on your tablet. If not, you will find some good functionality. Touch an open area on the desktop and navigate the PUP menu system. Open ROX or FM and drag/drop or expand/shrink a window. Taps and double-taps working. All of this desktop touching behaves as if one has a single-button mouse on a system which understands it.

BUT, there is no long-pause and there is not touch mouse-button 2 currently.

Just about everything you can do with a single button mouse was thought of in the build. This included the changing around of mouse activity on an open area of a desktop.

Recently, Slacko64 has resolved a tracking issue with finger and mouse accuracy. But the mouse 1 on desktop has not been addressed yet by any PUP where the tap brings the Menu into visibility for navigation and application launch. This now opens the door for other Puppy advancements in finger-touch control of system activity in the X-Window desktop.

One 3 year-old path in the forest has been paved for us in this OOTB full function PUP distro.

Hope this helps

Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 

Joined: 15 Aug 2014
Posts: 1

PostPosted: Fri 15 Aug 2014, 08:49    Post subject: Almost works  

Hi all.

I try to setup a Master Touch MT500USB screen on Puppy Precise 5.7.1
I installed evtouch-0.8.8 driver, but touchscreen doesn't work correctly.
When I tap screen, cursor moves in little area (approx. 1cm x 1cm), which is scaled from whole screen area.

I did steps from 1st post in this topic.

My xorg.conf
#barry Kauler 2011
#pre-constructed xorg.conf, for use by /usr/sbin/xorgwizard-automatic
#110627 working on mageia1 build, this needs fixing.
#111029 Terryphi reported 1cm screen displacement, changed vert freq range from 56-76 to 59-76.
#120329 more placemarkers for xorgwizard-automatic script.
#121013 change depth from 16 to 24. note, some arm boards need 16.

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
Section "Module"
#   Load "synaptics" #loadsynaptics

# This loads the DBE extension module.

    Load        "dbe"     # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension

# This loads the font modules
#    Load        "type1"
#    Load        "freetype"

# This loads xtrap extension, used by xrandr
#    Load       "xtrap"

# This loads the GLX module (if present). xorg 7.4/5, need explicit disable to disable... change "Disable" to "Load" if reqd...
#    Disable       "glx" #LOADGLX

# This loads dri module (if present). 7.4 loads it by default, have to disable... change "Disable" to "Load" if reqd...
#    Disable       "dri" #LOADDRI


# **********************************************************************
# Files section.  This allows default font paths to be set
# **********************************************************************

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

    #FontPath   "/usr/share/fonts/X11/misc/"
    #FontPath   "/usr/share/fonts/liberation/"
    FontPath   "/usr/share/X11/fonts/misc/"
    FontPath   "/usr/share/X11/fonts/Type1/"
    FontPath   "/usr/share/X11/fonts/TTF/"


# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12).  This allows clients to receive these key
# events.

#    Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

    Option "RandR" "on"

# With this, Xorg won't talk to HAL to add evdev devices and you'll be back
# with the old Xorg behavior (pre-7.4)...

    Option "AutoAddDevices" "false"

# For no-Hal, kirk also suggests this...

#    Option "AllowMouseOpenFail" "true"

# Xorg 7.4, Ubuntu Jaunty, CTRL-ALT-BACKSPACE is disabled by default...

    Option "DontZap" "false"


Section "ServerLayout"
#   InputDevice "Synaptics Mouse" "AlwaysCore" #serverlayoutsynaptics
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "touchscreen" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "dummy"

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "XkbRules" "xorg"
   Option      "XkbModel" "pc102" #xkbmodel0
   Option      "XkbLayout" "us,ru" #xkeymap0
   Option      "XkbVariant" ",winkeys"
   Option       "XkbOptions"   "grp:ctrl_shift_toggle,grp_led:scroll"
   #Option      "XkbVariant" "" #xkbvariant0

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "IMPS/2" #mouse0protocol
   Option       "Device" "/dev/mouse"
   #Option      "Emulate3Buttons"
   #Option      "Emulate3Timeout" "50"
   Option      "ZAxisMapping" "4 5" #scrollwheel

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
   HorizSync    35-81
   VertRefresh  59-76
   #UseModes     "Modes0" #monitor0usemodes
   Option      "PreferredMode" "1280x1024" #monitor0prefmode
Section "Modes"
   Identifier "Modes0"

#110627 remove...
##server can find BusID automatically, comment out...
#Section "Device"
#   Identifier  "Card0"
#   Driver      "vesa" #card0driver
#   VendorName  "Unknown Vendor"
#   BoardName   "Unknown Board"
##   BusID       "PCI:0:2:0" #card0busid

Section "Screen"
   Identifier "Screen0"
#   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
   #Option         "metamodes" "1280x800_60 +0+0" #METAMODES_0
   Subsection "Display"
      Depth       24
      Modes       "1280x1024" #screen0modes
Section "InputDevice"
    Identifier "touchscreen"
    Driver "evtouch"
#    Driver "Mastouch"
#    Driver "evdev"
    Option "Device" "/dev/input/event0"
    Option "DeviceName" "touchscreen"
    Option "MinX" "0"
    Option "MinY" "0"
    Option "MaxX" "1280"
    Option "MaxY" "1024"
    Option "ReportingMode" "Raw"
    Option "Emulate3Buttons"
    Option "Emulate3Timeout" "50"
    Option "SendCoreEvents" "On"
#    Option "Calibrate" "1"
#    Option "AlwaysCore"

Section "InputDevice"
    Identifier "dummy"
    Driver "void"
    Option "Device" "/dev/input/mice"

# cat /proc/bus/input/devices
I: Bus=0003 Vendor=0df9 Product=0001 Version=0110
N: Name="MASTouch TouchSystems MASTouch USB Touchscreen"
P: Phys=usb-0000:00:1d.0-1.4/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4:1.0/input/input0
U: Uniq=
H: Handlers=mouse0 event0
B: EV=1b
B: KEY=70000 0 0 0 0 0 0 0 0
B: ABS=100 3
B: MSC=10

One thing I don't like, which is strange are some lines from Xorg.0.log
[  1725.173] (II) LoadModule: "evtouch"
[  1725.173] (II) Loading /usr/lib/xorg/modules/input/evtouch_drv.so
[  1725.173] (EE) Failed to load /usr/lib/xorg/modules/input/evtouch_drv.so: /usr/lib/xorg/modules/input/evtouch_drv.so: undefined symbol: xf86GetMotionEvents
[  1725.173] (II) UnloadModule: "evtouch"
[  1725.173] (II) Unloading evtouch
[  1725.173] (EE) Failed to load module "evtouch" (loader failed, 7)
[  1725.173] (EE) No input driver matching `evtouch'

Does anybody could help me to get touchscreen working?

Thanks in advance.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 6 of 6 [83 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0706s ][ Queries: 13 (0.0235s) ][ GZIP on ]