Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 19:15
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
HP LaserJet 100 colorMFP M175nw
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Krypton

Joined: 27 Nov 2012
Posts: 4

PostPosted: Tue 27 Nov 2012, 09:29    Post_subject:  HP LaserJet 100 colorMFP M175nw  

I can't get this printer to work. It is supposed to be supported by HPlip 3.11.7, but I can't find the driver in the list, when I try to install it.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Tue 27 Nov 2012, 10:20    Post_subject: Re: HP LaserJet 100 colorMFP M175nw  

Krypton wrote:
I can't get this printer to work. It is supposed to be supported by HPlip 3.11.7, but I can't find the driver in the list, when I try to install it.

Please describe how you are trying to install it.
Back to top
View user's profile Send_private_message 
Krypton

Joined: 27 Nov 2012
Posts: 4

PostPosted: Tue 27 Nov 2012, 10:35    Post_subject: Re: HP LaserJet 100 colorMFP M175nw  

rcrsn51 wrote:
Please describe how you are trying to install it.


I click "Find new printers" in the CUPS Admin. It finds my printer and let me pick the driver from a long list. My printer is not in that list even after I have installed hplip_print-3.12.10a.pet .
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Tue 27 Nov 2012, 10:48    Post_subject:  

I can't find it either. But just to be sure, it's not at the very top of the list?

If you look in the CUPS file /usr/share/cups/drv/hp/hpcups.drv, it isn't mentioned. However, it does appear in the file /usr/share/hplip/data/models/models.dat that is used for the scanner component.

[Edit] This printer claims to be PCL6-compatible. Try installing it as a Laserjet 6. Also, if you look in the Generic section (instead of HP) there are some possible choices.

[Edit] I found your PPD file. It is a Postscript version that is not included in the PET. When you install it, your printer will appear in CUPS as a "Laserjet 100 colour MFP M175".
laserjet_100_color_mfp_m175_ps_ppd-1.0.pet
Description 
pet

 Download 
Filename  laserjet_100_color_mfp_m175_ps_ppd-1.0.pet 
Filesize  36.82 KB 
Downloaded  471 Time(s) 
Back to top
View user's profile Send_private_message 
Krypton

Joined: 27 Nov 2012
Posts: 4

PostPosted: Tue 27 Nov 2012, 11:20    Post_subject:  

Great! It works! Many thanks
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Tue 27 Nov 2012, 11:23    Post_subject:  

What works? The Postscript PPD?

What Puppy version are you using?

As a test, try printing from several applications, including your web browser. Is it OK?

Also, can you confirm that you do NOT need the hplip_print package to make this printer work? You would need a clean Puppy setup where you only install the PPD file.
Back to top
View user's profile Send_private_message 
Krypton

Joined: 27 Nov 2012
Posts: 4

PostPosted: Thu 29 Nov 2012, 11:45    Post_subject:  

rcrsn51 wrote:
What works? The Postscript PPD?

What Puppy version are you using?

As a test, try printing from several applications, including your web browser. Is it OK?

Also, can you confirm that you do NOT need the hplip_print package to make this printer work? You would need a clean Puppy setup where you only install the PPD file.


I'm using Precise Puppy 5.4.1 and with a clean install with only the PPD file installed I it works to print from all applications I've tested.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Thu 29 Nov 2012, 12:46    Post_subject:  

Krypton wrote:
I'm using Precise Puppy 5.4.1 and with a clean install with only the PPD file installed I it works to print from all applications I've tested.

Excellent. Thank you for testing this. I've noticed a number of recent HP models that are using this Postscript-only system.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0525s ][ Queries: 13 (0.0054s) ][ GZIP on ]