Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 16:10
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Chromium Policy URLBlacklist/Whitelist not working
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count_1  
Author Message
jasonchild

Joined: 25 Nov 2012
Posts: 1

PostPosted: Sun 25 Nov 2012, 19:17    Post_subject:  Chromium Policy URLBlacklist/Whitelist not working  

Hi all,

I'm hoping someone can answer a quick question. I have recently installed Chromium-18-Lucid.pet and it runs fine. However I am trying to implement policies to work with chromium while running in --kiosk mode.

I have configured the relevant policy as described http://www.chromium.org/administrators/linux-quick-start, and I know the policy is being picked up as when I define the "HomepageLocation" parameter it picks it up just fine.

My problem is that the subsequent URLBlacklist and URLWhitelist parameters are either not being picked up or are being ignored. As when I run the browser and enter any other domain than what has been specified in my whitelist it continues to load regardless of the blacklist rule in place that should prohibit this. The current format of my test_policy.json file (the contents of <My Home Page> relate to a specific host and location:

Code:

{
  "HomepageLocation": "<My Home Page>",
  "URLBlacklist": ["*"],
  "URLWhitelist" : ["<My Home Page>"]
}


Documentation for these parameters would seem to indicate that it should work for chromium v15+ so I don't know what
I've done wrong. Anyone have any ideas what's going on?

Cheers,

Jason.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count_1  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0781s ][ Queries: 12 (0.0453s) ][ GZIP on ]