Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 23 Aug 2014, 03:48
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.6.2.1 with kernel 3.6.2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 10 [142 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 Next
Author Message
charlie6


Joined: 30 Jun 2008
Posts: 1005
Location: South of Belgium

PostPosted: Sat 24 Nov 2012, 08:49    Post subject:  

Hi pemasu,
pemasu wrote:
...to the next release.

hmmm! Cool ....what about dPup-Exprimos next version(s ?) with upgraded version of Xorg to 1.11.3; and xf86-intel driver to 2.17.0 ...?
These are running so nicely in uPup-Precise ... Very Happy
(i maybe could be unaware about how much difficult it could be...sorry if the case Embarassed )
Thanks aniway in advance!
Charlie
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3254
Location: Ontario

PostPosted: Wed 28 Nov 2012, 15:34    Post subject: imagination 3.0  

I wasn't able to get Imagination 3.0 to work in Exprimo.
I was successful in Precise.

Maybe if it was carefully compiled with the right dependencies
it could work. It needs sox and ffmpeg.

http://murga-linux.com/puppy/viewtopic.php?t=82575

___________________________________________________
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1005
Location: South of Belgium

PostPosted: Thu 29 Nov 2012, 13:40    Post subject: gqview-2.04 for gtk+2.20 compiled in Exprimo  

Here it is ...
as the pet i got (i.e. gqview-2.04 from Dejan's dpup45 repo - compiled with gtk+2.24) reported to be compiled with gtk+2.24, and that running on gtk+2.20 could bring risk of fault, i compiled it inside exprimo.
Have fun
Charlie
gqview_NLS-2.04-gtk2.20-i686-dpup.pet
Description 
pet

 Download 
Filename  gqview_NLS-2.04-gtk2.20-i686-dpup.pet 
Filesize  387.57 KB 
Downloaded  349 Time(s) 
gqview-2.04-gtk2.20-i686-dpup.pet
Description 
pet

 Download 
Filename  gqview-2.04-gtk2.20-i686-dpup.pet 
Filesize  1.09 MB 
Downloaded  349 Time(s) 

Last edited by charlie6 on Sun 09 Dec 2012, 03:00; edited 1 time in total
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1005
Location: South of Belgium

PostPosted: Sun 09 Dec 2012, 02:57    Post subject: Portabase database (Qt application)  

Hi,
here is a (imho) nice (Qt) database running on exprimo:
http://www.murga-linux.com/puppy/viewtopic.php?p=669603#669603
enjoy Very Happy !
charlie
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3254
Location: Ontario

PostPosted: Mon 10 Dec 2012, 17:16    Post subject:  

Note to Pemasu : What do you think of this right click option?

A very simple script that just uses rpm2cpio which
is in all puppies.

http://murga-linux.com/puppy/viewtopic.php?t=82865

__________________________________________
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 10 Dec 2012, 18:14    Post subject:  

I have included your new version to the next Upup Precise update. To the rox right clicks included in it.

Yeah. My timetable does not enable to update all my versions at the same time.

But dpup exprimo has not been forgotten.
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3254
Location: Ontario

PostPosted: Tue 11 Dec 2012, 21:14    Post subject: new version of extract_rpm  

A new version of extract_rpm...

I am now using 'exploderpm' rather than 'rpm2cpio'

It gives much better results. I also found that file-roller does a good
job of extracting rpm packages but only Exprimo seems to have it
installed, so I went with exploderpm


http://www.murga-linux.com/puppy/viewtopic.php?p=670614#670614

_____________________________________________
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1005
Location: South of Belgium

PostPosted: Tue 18 Dec 2012, 04:09    Post subject: using puppy personal database v 0.6b  

Hi,
using forum member gposil's puppy personal database v 0.6b on Exprimo 3.6.2.1:
download here:
http://www.murga-linux.com/puppy/viewtopic.php?t=42480
I get the following problem:
- selecting in ppdb v0.6b Menu/Custom Databases/Puppy database creator gives a warning box: «TCustomForm.ShowModal impossible»;
- then xerr.lor reports:

Quote:
(ppdb:20628): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(ppdb:20628): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
TApplication.HandleException Access violation
Stack trace:
$B7403FAE
$081B2618
$0810116B
...
TCustomForm.ShowModal Visible=True Enabled=True fsModal=False MDIChild=False
TApplication.HandleException TCustomForm.ShowModal impossible
Stack trace:
$0805E776
$0805E34A
$082D934F
...

- Googling about that warning, have found this that could fix it, but i don't know how to do it :
here:https://blueprints.launchpad.net/ubuntu/+spec/spinbutton-adjustment-warnings
Quote:
Many GNOME-based applications print the following to the console.
Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
This is generally due to the form being created with an obsolete version of Glade.
The function gtk_adjustment_configure() is called from a glade element looking like "<property name="adjustment">0 0 999 1 10 10</property>"; the fix is to change the last value to zero, like "<property name="adjustment">0 0 999 1 10 0</property>".

Please help about how to change
Quote:
"<property name="adjustment">0 0 999 1 10 10</property>"
...where to find it, to edit it...

Thanks for any advice
Charlie
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1005
Location: South of Belgium

PostPosted: Wed 19 Dec 2012, 13:41    Post subject: using puppy personal database v 0.6b (continue)  

Hi,
in addition to the above post... as ppdb has been created half 2009, i went to install ppdb-0.6b.pet on a "fresh" ...«good old puppy 4.2» (read "pristine" install Smile ):
result: Shocked puppybase creator runs OK on puppy-4.2 without error Very Happy Very Happy

my question: could one hope getting ppdb running on exprimo, the same way it seems running OK on puppy-4.2 ?

thanks for any answer !
charlie
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 19 Dec 2012, 14:19    Post subject:  

Charlie6. I am not sure that the GtkSpinButton error message is the reason of the crash and error message.
If the ppdb would still be developed, I would ask the developer. Next thing. If there is possibility to get source code of ppdb in hands, compiling it in dpup exprimo might help and also there might be possibility to fix the source code.
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1005
Location: South of Belgium

PostPosted: Wed 19 Dec 2012, 15:45    Post subject:  

Hi pemasu,
thanks for replying!
Developer, forum member gposil, is no longer reachable since 2010 Crying or Very sad , and his repo as well ... (hope he is doing well...).
So no hope then (except use on puppy4.2)

Wishes to you and your relatives for a
*~*#*@*&* Merry Christmas *~*#*@*&*,
as also for the Puppy Community !

Charlie
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1005
Location: South of Belgium

PostPosted: Thu 20 Dec 2012, 17:39    Post subject: [SOLVED =-)] running sqlitebrowser_2.0 from debian repo
Subject description: using Qt4-4.8.0
 

Hi Pemasu,
last edited: SOLVED Cool (i have adapted this post from original modifying and/or deleting the obsolete parts)
to get sqlitebrowser-2.0.0.b1 running on dpup-exprimo-3.6.2.1, have to be installed:
- sqlitebrowser_2.0.0~beta1+ds.1-3_i386.deb from debian repo wheezy (squeeze repo has only version 1.3) here:
http://ftp.de.debian.org/debian/pool/main/s/sqlitebrowser/sqlitebrowser_2.0.0~beta1+ds.1-3_i386.deb
+
- libicu42_4.2.1-3_i386.deb from ubuntu repo (not found in debian repo), here: https://launchpad.net/ubuntu/lucid/i386/libicu42/4.2.1-3
(debian repo has only libicu44_4.4.1-8_i386.deb but using version 44, even created a version 42 symlink pointing to version 44 lib, sqlitebrowser reports "undefined symbols" when started from console)
+
- install qt4-4.8.0.pet from pets-dpup-exprimo repo only (only this pet has libQt3support in it !! Qt4-4.8.0.sfs has not...Shocked)
(trick: for those who prefer mounting .sfs files instead of install .pet files, just transform the pet into sfs using the right click option «Extract here» and «dir2sfs» to get the relevant sfs archive)
note: before being aware that other qt4-4.8.0.sfs archives from other pemasu's repo do not have libqt3support.so.4.8.0 in them, i got unsuccessfull trials running other versions of qt4 and libqt3support libs (4.6.3, 4.7.x or 4.8.2, even4.8.3, also coming from polarpup-005 - which version is 4.8.0...but compiled on a different kernel version - all resulted in an error message that might report an incompatibility of libqt3support with other Qt4 libs).
- For information: Sqlitebrowsers website
http://sqlitebrowser.sourceforge.net/
Hope this helps
Charlie

Last edited by charlie6 on Sun 23 Dec 2012, 06:10; edited 5 times in total
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3254
Location: Ontario

PostPosted: Thu 20 Dec 2012, 21:32    Post subject:  

I upgraded pupmd5sum.sh to version 1.0

improvements

1) put in 'Saving to disk' Yaf-splash

2) The text file now will handle spaces in file name
_________________________________________
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1005
Location: South of Belgium

PostPosted: Thu 03 Jan 2013, 06:02    Post subject: SQLiteStudio-2.1.0 not running on dPup-Exprimo-3.6.2.1  

Hi,
please consider the latest SQLiteStudio-2.1.0 here:
http://sqlitestudio.one.pl/
to be downloaded here:
http://sqlitestudio.one.pl/files/free/stable/linux32/sqlitestudio-2.1.0.bin
I have downloaded it in /; and launch just by click on it.
result: on a fresh (=pristine) dPup-Exprimo-3.6.2.1 and doing in a console, i get those error messages:
Quote:
# ./sqlitestudio-2.1.0.bin
couldn't find procedure Itk_Init
while executing
"load [file join {/sqlitestudio-2.1.0.bin/lib/Itk3.4} libitk3.4.so] Itk"
("package ifneeded Itk 3.4" script)
invoked from within
"package require Itk 3.4"
invoked from within
"set ::PKG(Itk) [package require Itk 3.4]"
(file "/sqlitestudio-2.1.0.bin/lib/sqlitestudio/main.tcl" line 210)
invoked from within
"source /sqlitestudio-2.1.0.bin/lib/sqlitestudio/main.tcl"
("package ifneeded sqlitestudio 2.1.0" script)
invoked from within
"package require sqlitestudio"
(file "/sqlitestudio-2.1.0.bin/main.tcl" line 6)
#

I could not find libitk3.4.so on debian repo (only libitk3.3.so) .

Sqlitestudio-2.1.0.bin is said to be 32bit x86 linux compatible.
Also tested:
- on a fresh dPup-Exprimo-5X15: works OOTB !
- on a fresh uPup-Precise-5X45: works OOTB !
Any advice is welcome
Charlie
Back to top
View user's profile Send private message 
mini-jaguar

Joined: 13 Nov 2008
Posts: 462

PostPosted: Wed 09 Jan 2013, 02:04    Post subject:  

I just installed this Exprimo, really nice. Even runs a lot of software for Lucid, but not all.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 6 of 10 [142 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0969s ][ Queries: 13 (0.0093s) ][ GZIP on ]