Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 03 Sep 2014, 01:03
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
iPhone USB internet tethering
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [29 Posts]   Goto page: Previous 1, 2
Author Message
Nirju_u

Joined: 12 Nov 2012
Posts: 3

PostPosted: Mon 12 Nov 2012, 15:21    Post subject: Unable to connect and browse internet
Subject description: Help needed to connect to internet - Network Configration of eth1 is successful
 

Hi

Thank you for your response. I tried the Network Wizard and again it detected the connection. I used Auto DHCP. I got the message "Network Configration of eth1 is successful" . However when i clicked on the browser it gave me an error stating that there is no internet connection. Is there any step i am missing. Please help.

regards
Niranjan
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Mon 12 Nov 2012, 19:24    Post subject:  

First, make sure that tethering is enabled on your phone. I believe it's under:
Settings > General > Network > Internet Tethering
If you don't see the setting, it's possible your provider has disabled the service.
You could call them to see if the tethering function can be enabled on your service plan (which might attract an additional fee)
... or you could consider jailbreaking the phone
... or you could change to a phone provider who is known to allow tethering.
Back to top
View user's profile Send private message 
Nirju_u

Joined: 12 Nov 2012
Posts: 3

PostPosted: Mon 12 Nov 2012, 23:21    Post subject:  

I have enabled the option in my iPhone. I am able to browse using my iPhone in windows but not in puppy Linux. My service provider has enabled the option
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Tue 13 Nov 2012, 10:51    Post subject:  

I've read similar reports on the forum - which are completely unrelated to tethering.
It sounds like Puppy's DHCP client, dhcpcd, is either failing to properly obtain an IP address, or it's failing to configure DNS addresses.
A quick fix might be to install the updated version of dhcpcd for Puppy-Lucid which I posted here -
http://www.murga-linux.com/puppy/viewtopic.php?p=448997#448997
Then reboot, and run the Network Wizard again.

If still no success, I suggest you look up the tech-support section of your phone provider's website to learn what the DNS addresses should be,
then open /etc/resolv.conf in Geany, and manually enter those settings.
For example, let's say your provider's DNS addresses are 100.0.0.1 and 100.0.0.2
Your /etc/resolv.conf should look like this -
Code:
nameserver 100.0.0.1
nameserver 100.0.0.2

Then reboot, and run the Network Wizard again.
Back to top
View user's profile Send private message 
tenochslb

Joined: 10 Jul 2010
Posts: 36
Location: Mexico

PostPosted: Sat 17 Nov 2012, 09:43    Post subject: ipad 3 + puppy wary 5.3  

would this pet work on my wary 5.3?
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Sat 17 Nov 2012, 22:09    Post subject:  

The usbmuxd and libimobiledevice libraries should work OK in Wary, but there's also a kernel module involved; ipheth.
As you should know, kernel modules are kernel-specific, and since Lucid-Puppy 5.2.x and Wary 5.3.x have different kernels, this will be incompatible.

If one of the Wary developers can compile the ipheth kernel module for you, it should work in combination with the libraries in my dotpet.
The source code is here -
https://github.com/dgiagio/ipheth/downloads
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9066
Location: Stratford, Ontario

PostPosted: Sat 17 Nov 2012, 23:40    Post subject:  

tempestuous wrote:
If one of the Wary developers can compile the ipheth kernel module for you, it should work in combination with the libraries in my dotpet.

The module compiles OK in Wary 5.3, but there are a bunch of missing dependencies. I pulled them out of Lupu and stuck them in the PET.

The binaries like ipheth-pair appear to start.

[Edit] Attachment deleted - multiple downloads with no feedback. If anyone else wants this package, they can post another request.
Back to top
View user's profile Send private message 
tenochslb

Joined: 10 Jul 2010
Posts: 36
Location: Mexico

PostPosted: Mon 19 Nov 2012, 17:19    Post subject:  

on wary 5.3,

It broke my rox filer, i had to uninstall them to get it working again.

Is this just for thethering?

When i plug ipad 3 it recognizes the ipad and i can see the pictures.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Tue 20 Nov 2012, 08:34    Post subject:  

Before I answer that ...
does tethering work under Wary 5.3?
Back to top
View user's profile Send private message 
jodel

Joined: 04 Apr 2014
Posts: 3

PostPosted: Fri 04 Apr 2014, 07:52    Post subject:  

I am running Slacko 5.7. Is there a version of ipheth available for it?
Jodel
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Sat 05 Apr 2014, 00:43    Post subject:  

jodel, I need to know exactly which type/model of "i-device" you are intending to connect to?
Back to top
View user's profile Send private message 
jodel

Joined: 04 Apr 2014
Posts: 3

PostPosted: Sat 05 Apr 2014, 08:01    Post subject:  

It is an iPhone 3.(jailbroken). I have tried the version of ipheth mentioned above in 2012 and it does show up as network device but it does not set up properly. It gets an ip address but no routing DNS or gateway. Pinging anything other than the ip of the computer itself give network not found
The phone connects ok to ubuntu on the same computer.
Jodel
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Sat 05 Apr 2014, 09:17    Post subject:  

The ipheth package in this post is more than 2 years old now, and I think its version of libimobiledevice is likely too old for the iPhone 3.
A quick fix might be to install the experimental version of gtkpod I posted here -
http://www.murga-linux.com/puppy/viewtopic.php?p=618228#618228
This package contains the same libraries needed by the ipheth driver.

If still no luck, you will need to wait until I update the gtkpod/libimobile packages again, which should be within a month or two - I'm waiting for the next release of usbmuxd.
Back to top
View user's profile Send private message 
jodel

Joined: 04 Apr 2014
Posts: 3

PostPosted: Sat 05 Apr 2014, 16:24    Post subject:  

Thanks for your reply. I presume the file is gtkpod-2.0.2-April2012.pet ?
I will try that.
Jodel
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [29 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0751s ][ Queries: 13 (0.0123s) ][ GZIP on ]