Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 17 Apr 2014, 07:25
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Openshot 1.4.3 precise
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 3 [32 Posts]   Goto page: 1, 2, 3 Next
Author Message
666philb


Joined: 07 Feb 2010
Posts: 1492
Location: wales

PostPosted: Tue 23 Oct 2012, 18:24    Post subject:  Openshot 1.4.3 precise
Subject description: video editor
 

this is openshot 1.4.3 for precise puppy



OpenShot Video Editor is a free, open-source video editor for Linux licensed under the GPL version 3.0.

OpenShot can take your videos, photos, and music files and help you create the film you have always dreamed of. Easily add sub-titles, transitions, and effects, and then export your film to DVD, YouTube, Vimeo, Xbox 360, and many other common formats.

only tested on precise puppy. (requires the devx)

Note: the help file doesn't work as it requires gnome i think... i'll look into it.

i haven't tested everything, so please let me know if something isn't working and i'll try to fix it.

you can download it here.......

pet: http://www.mediafire.com/file/wh5hjkb56wfldna/openshot-1.4.3_precise.pet 58mb
MD5 75d8f92a0e7f5951def3b6022c40979c

sfs: http://www.mediafire.com/file/1nc8gc8xm45n0g9/openshot-1.4.3_precise_5.4.sfs 57mb
MD5 1e106132c50a40c97a12f8607aaeacae
------------------------------------------------------
other versions....
saluki http://www.murga-linux.com/puppy/viewtopic.php?t=82046
slacko http://www.murga-linux.com/puppy/viewtopic.php?t=75528

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739

Last edited by 666philb on Tue 04 Mar 2014, 11:55; edited 2 times in total
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 430
Location: GERMANY

PostPosted: Wed 24 Oct 2012, 06:50    Post subject:  

HI 666philp !
Thank you so much ....seems working on Precise . But did not test further .

Tried on Dpup Exprimo 3.6.2.1 openshot in terminal
" openshot sh: /usr/bin/openshot: /usr/bin/#python: bad interpreter: No such file or directory "

How could one get it working on DpupExprimo .
But nevertheless thank you .
Is there any chance for Kdenlive on Precise or DpupEXprimo ?
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1492
Location: wales

PostPosted: Wed 24 Oct 2012, 07:43    Post subject:  

hi backi. I'll have a go at getting it working on dpup tonight
_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 430
Location: GERMANY

PostPosted: Sat 27 Oct 2012, 13:08    Post subject:  

HI 666philb!

Trying your openshot pet now with python 2.7.3 .

In terminal i got

" openshot

------------------------- ERROR 1 ------------------------------
Failed to import 'from openshot import main'
Error Message: No module named openshot
----------------------------------------------------------------

------------------------- ERROR 2 ------------------------------
Failed to import 'from openshot.openshot import main'
Error Message: No module named openshot.openshot
----------------------------------------------------------------

OpenShot has failed to import some of the Python files or libraries
required for our application to run. Here are some trouble shooting
tips:

Tip 1) Check if MLT can be successfully imported in Python. Run the
following commands, and see if any errors are displayed. If you get
an error, you need to investigate the correct way to install MLT.
NOTE: Do not type the $ or >> characters in the examples below.

$ python
>> import mlt
>> mlt.Factory().init()

Tip 2) If MLT is working from the first example, then the next tip is
to look at the above error messages very closely, and google for more
help. It's likely the problem is already reported, and maybe there is
a simple work-around. Also, you can search for bugs or report a new
bug at https://bugs.launchpad.net/openshot. Good luck!

# "

Any idea?
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1492
Location: wales

PostPosted: Sat 27 Oct 2012, 14:44    Post subject:  

hi backi, is this in dpup?

if so .. can you follow the instructions at the end.... type python in a terminal, then type .... import mlt and see if there's an error.


( i did have a go at getting it working on dpup and failed, but i do have another idea if i get time)

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 430
Location: GERMANY

PostPosted: Sun 28 Oct 2012, 02:17    Post subject:  

Hi 666philb !
I am using dpup .
In terminal "" python

# python
Python 2.7.3 (default, Jul 3 2012, 21:16:07)
[GCC 4.7.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.

in terminal

>> import mlt
got
>> import mlt

got

>> import mlt
^
SyntaxError: invalid syntax

in terminal
mlt.Factory().init()

got

NameError: name 'mlt' is not defined


Then i put in terminal the whole

python
>> import mlt
>> mlt.Factory().init()

and i got this message

python
Python 2.7.3 (default, Jul 3 2012, 21:16:07)
[GCC 4.7.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> >> import mlt
File "<stdin>", line 1
>> import mlt
^
IndentationError: unexpected indent
>>> >> mlt.Factory().init()
File "<stdin>", line 1
>> mlt.Factory().init()
^
IndentationError: unexpected indent

I am a linux newbee dont know what that mean maybe it gives you some information .
Thanks!
Back to top
View user's profile Send private message 
headfound


Joined: 24 Jun 2006
Posts: 342
Location: England

PostPosted: Sun 28 Oct 2012, 16:13    Post subject:    

tested in clean frugal install of precise to edit together a video for my dad.
Worked flawlessly! (the first time openshot has ever been able to complete a video for me). I used a fair amount of effects/chromakey and cuts and it all worked.
Thanks so much Smile

_________________
Download a better Computer Smile
Puppy Linux Song
altern8life
Back to top
View user's profile Send private message Visit poster's website 
666philb


Joined: 07 Feb 2010
Posts: 1492
Location: wales

PostPosted: Tue 30 Oct 2012, 05:40    Post subject:  

headfound wrote:
tested in clean frugal install of precise to edit together a video for my dad.
Worked flawlessly! (the first time openshot has ever been able to complete a video for me). I used a fair amount of effects/chromakey and cuts and it all worked.
Thanks so much Smile


thanks for testing 'headfound' glad it works for you

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1492
Location: wales

PostPosted: Tue 30 Oct 2012, 05:42    Post subject:  

sorry backi, i've had no luck with getting it to run on dpup. what i need to do is get a blank dvd and burn a debian live dvd, install openshot on that, then look at the differences between that and the dpup install.

i'lll do it when i get some time

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 430
Location: GERMANY

PostPosted: Tue 30 Oct 2012, 16:33    Post subject:  

Hello 666philb

Thanks for your interest !!!
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1492
Location: wales

PostPosted: Thu 01 Nov 2012, 16:37    Post subject:  

hi backi,

i'm having to give up on getting openshot to work properly on dpup. Whilst i could get openshot to start-up it wouldn't import any of the plugins, rendering it useless.

i couldn't figure out the problem sorry

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Thu 01 Nov 2012, 19:49    Post subject:  

666philb - good job Very Happy

Just use the devx (for Python)
and installed your SFS
(no need for xfce or Nvidia drivers for me)
so far so good . . .

. . . however . . .
I of course want to use the animated titles Shocked
. . . for this you need Blender
Downloaded from the Puppy Package Manager with all dependencies
missing dependency libpython3.2mu.so.1.0
could not find it/download from the PPM

. . . OK then tried this blender
http://www.murga-linux.com/puppy/viewtopic.php?p=514221&search_id=1762321933#514221
Seems like it could be working . . .

Remember to add the location of Blender and restart Openshot
. . . 3D rendering is slow of course . . .

Really appreciate this as Openshot gets more stable
and it is an awesome bit of open source

We are Puppy
and we have videos to prove it . . .

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
backi

Joined: 27 Feb 2011
Posts: 430
Location: GERMANY

PostPosted: Sat 03 Nov 2012, 05:41    Post subject:  

Hi Lobster !

Did you do what you did on Dpup or on which puppy ?

Hi 666philb !
Thanks for your goodwill .But if i need openshot i can use my precise puppy installed on Usb stick .
But nevertheless i would like to see it run on Dpup too .

Have a nice day !!
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Mon 05 Nov 2012, 04:12    Post subject:  

Quote:
Did you do what you did on Dpup or on which puppy ?


The last Puppy I used Openshot was Slacko 5.3.
For this micko (I think it was created) created and SFS which included Openshot and Python - so the devx was not required.

Also no longer required is xfce or a similar more powerful windowing system (KDE for example)

The nvidia driver is now built into precise. Another step not required by me.

I still find Openshot crashes and this may because 2GB is not enough ram - remember this is video. Maybe those with more stable results are using 4GB?

Video editing apart from the very basic is not simple and I value Openshot as both simple, evolving and enjoyable to use.

Fatdog64 contains a video package but I could not get to grips with the package even though it was more stable than Openshot on my hardware.

Smile

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
headfound


Joined: 24 Jun 2006
Posts: 342
Location: England

PostPosted: Mon 05 Nov 2012, 06:19    Post subject:  

my first test with this openshot was with my sons p4 system 3ghz single core processor with only 1gb of ram.
I only edited sd quality on this and had to be patient but it worked fine.

My second test was on my wifes dual core 2.7ghz system with 2ghz of ram editing 720i hd footage. Everything was nice and smooth.

The important thing with openshot is to add all your footage to tracks then SAVE! I've read that openshot tends to grab memory with every action taken so I think that is why it crashes. Saving regulary and occasionally restarting (quick cuppa break?) seems good practice.

_________________
Download a better Computer Smile
Puppy Linux Song
altern8life
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 3 [32 Posts]   Goto page: 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0700s ][ Queries: 13 (0.0043s) ][ GZIP on ]