Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 23:47
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
flsynclient won't save settings in 5.2
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 16 Apr 2009
Posts: 50
Location: Cincinnati, OH

PostPosted: Sun 03 Apr 2011, 21:07    Post_subject:  flsynclient won't save settings in 5.2
Sub_title: flsynclient won't save settings in 5.2

Hi: I've installed MacPup 5.2 on a Toshiba Satellite 1805-S204 PIII laptop. It's the only distro I've found that will deal with the hardware on this old beast, and it installs easily, finds and runs the hardware correctly, and generally looks and runs great. I'm particularly pleased with Iron 10; it's much faster than Firefox, and I almost don't notice that I'm on that old of a machine when browsing.

I have found one quirk. I'm addicted to tapping and scrolling with the track pad, but flsynclient won't save my settings. It worked flawlessly on 5.1, so something has changed. I can change the track pad settings with the client, and I carefully both save and exit, but as soon as I reboot, they're gone. I've tried restarting X11, as noted elsewhere on this forum for this problem, but that doesn't help.

My xorg.conf looks like this:

#Special base config file used in Puppy Linux.

# **********************************************************************
# Module section -- this section is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
Section "Module"
Load "synaptics"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension

# This loads the font modules
# Load "type1"
# Load "freetype"

# This loads xtrap extension, used by xrandr
# Load "xtrap"

# This loads the GLX module (if present). xorg 7.4/5 need explicit disable to disable...
Load "glx" #LOADGLX

# This loads dri module (if present). 7.4 loads it by default, have to disable...
Load "dri" #LOADDRI
# Disable "dri"


# **********************************************************************
# Files section. This allows default font paths to be set
# **********************************************************************

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

FontPath "/usr/share/X11/fonts/misc/"
FontPath "/usr/share/X11/fonts/Type1/"
FontPath "/usr/share/X11/fonts/TTF/"


# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12). This allows clients to receive these key
# events.

# Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

Option "RandR" "on"

# With this, Xorg won't talk to HAL to add evdev devices and you'll be back
# with the old Xorg behavior (pre-7.4)...

Option "AutoAddDevices" "false"

# For no-Hal, kirk also suggests this...

# Option "AllowMouseOpenFail" "true"

# Xorg 7.4, Ubuntu Jaunty, CTRL-ALT-BACKSPACE is disabled by default...

Option "DontZap" "false"


#everything past here is auto-generated by Puppy's Xorg Wizard...

Section "ServerLayout"
InputDevice "Synaptics Mouse" "AlwaysCore"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "us" #xkeymap0

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2" #mouse0protocol
Option "Device" "/dev/mouse"
#Option "Emulate3Buttons"
#Option "Emulate3Timeout" "50"
Option "ZAxisMapping" "4 5" #scrollwheel

Section "InputDevice"
Identifier "Synaptics Mouse"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "120"
Option "RightEdge" "930"
Option "TopEdge" "120"
Option "BottomEdge" "650"
Option "FingerLow" "14"
Option "FingerHigh" "15"
Option "MaxTapTime" "0"
Option "MaxTapMove" "110"
Option "VertScrollDelta" "20"
Option "MinSpeed" "0.3"
Option "MaxSpeed" "0.75"
Option "AccelFactor" "0.030"
Option "EdgeMotionMinSpeed" "200"
Option "EdgeMotionMaxSpeed" "200"
Option "UpDownScrolling" "1"
Option "CircularScrolling" "1"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "SHMConfig" "on"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 31.5-48.5
VertRefresh 40-70
#UseModes "Modes0" #monitor0usemodes
Option "PreferredMode" "1024x768"

Section "Modes"
Identifier "Modes0"

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "AccelMethod" # [<str>]
#Option "SWcursor" # [<bool>]
#Option "PciRetry" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "SetMClk" # <freq>
#Option "MUXThreshold" # <i>
#Option "ShadowFB" # [<bool>]
#Option "Rotate" # [<str>]
#Option "VideoKey" # <i>
#Option "NoMMIO" # [<bool>]
#Option "NoPciBurst" # [<bool>]
#Option "MMIOonly" # [<bool>]
#Option "CyberShadow" # [<bool>]
#Option "CyberStretch" # [<bool>]
#Option "XvHsync" # <i>
#Option "XvVsync" # <i>
#Option "XvBskew" # <i>
#Option "XvRskew" # <i>
#Option "FpDelay" # <i>
#Option "Display1400" # [<bool>]
#Option "Display" # [<str>]
#Option "GammaBrightness" # [<str>]
#Option "TVChipset" # [<str>]
#Option "TVSignal" # <i>
Identifier "Card0"
Driver "trident" #card0driver
VendorName "Trident Microsystems"
BoardName "CyberBlade XPAi1"
BusID "PCI:1:0:0"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 16
#Option "metamodes" "1024x768_60 +0+0" #METAMODES_0
Subsection "Display"
Depth 16
Modes "1024x768"


The first thing I did was to edit xorg.conf, and change the maximum tap time to 200:

Option "MaxTapTime" "200"

This gave me tapping at bootup. I then tried adding:

Option "HorizEdgeScroll" "1"

but that didn't give me the horizontal scrolling I would like.

So: two questions.

1.) Is there a way to get flsynclient to properly save its selected settings in 5.2?

2.) If not, how can I edit xorg.conf to give me horizontal scrolling?

Thanks in advance!
Back to top
View user's profile Send_private_message 

Joined: 26 Aug 2008
Posts: 10

PostPosted: Tue 02 Oct 2012, 18:22    Post_subject: flsynclient not saving setting in 5.2
Sub_title: using flsynclient to fine tune touchpad settings only work until reboot

I have the same problem flsynclient will not save settings or if it does they are not being used on reboot I would like corner coasting. Any way to edit the standard xorg.conf file so that certain settings ie touchpad can be its standard default and do not get not get overwritten when running xorg wizard?.
Back to top
View user's profile Send_private_message 

Joined: 28 Dec 2009
Posts: 858

PostPosted: Wed 03 Oct 2012, 10:16    Post_subject:  


What is the output of:
ls -l ~/.flSynclient

If the file exists, and the modification time matches the last time that you saved settings from flsynclient, then they are probably being saved. The problem may be that they are not being reloaded.

flsynclient -s

Does that reload the settings that you last saved?

If so, you may be missing the startup script. What is the output of:
ls -l /root/Startup


If you are still around, your addition of Option "HorizEdgeScroll" "1" was half the solution. You should also add the following in the same section (the synaptics "InputDevice" section):
Option "HorizScrollDelta" "100"

You can change the "100" to something else, to adjust the scroll speed, but "0" will disable it.
Back to top
View user's profile Send_private_message 

Joined: 26 Aug 2008
Posts: 10

PostPosted: Wed 03 Oct 2012, 16:07    Post_subject:
Sub_title: Update to flsynclient wont save settings

Hello npierce, Many thanks for you response below is the output I have now. After I left my post I downloaded 2 pets from http://wwwing .murga-linux.com/puppy/viewtopic.php?t=48011 and installed them. Rebooted My settings are now saved, what it did I do not know just glad its working. Have to say this is the best Puppy for me to date Great work Thank you. I can label my post as fixed - unless you can see something from the results below that needs fixing.

sh-4.1# ls -l ~/.flSynclient
-rw-r--r-- 1 root root 2313 2012-10-03 20:15 /root/.flSynclient
sh-4.1# ls -l /root/Startup
total 84
-rwxr-xr-x 1 root root 150 2011-04-05 16:31 firewallstaterun
-rwxr-xr-x 1 root root 10368 2010-08-21 13:32 freememapplet_tray
-rwxr-xr-x 1 root root 766 2011-05-15 02:51 fullstart
-rwxr-xr-x 1 root root 207 2010-12-29 03:57 gamespatch.sh
-rwxr-xr-x 1 root root 2290 2011-08-07 23:11 install-flashplayer
-rwxr-xr-x 1 root root 27 2009-10-20 15:18 load-touchpad-settings
-rwxr-xr-x 1 root root 13736 2010-12-01 09:00 network_tray
-rwxr-xr-x 1 root root 21 2009-08-23 12:18 nodpms
-rwxr-xr-x 1 root root 12008 2010-10-06 13:58 powerapplet_tray
-rw-r--r-- 1 root root 674 2009-11-19 09:03 README.txt
-rwxr-xr-x 1 root root 65 2012-04-04 15:14 run_fixmenus
-rwxr-xr-x 1 root root 127 2011-08-03 02:20 set-numlock
-rw-r--r-- 1 root root 114 2011-04-01 02:07 stay-connected.sh
-rw-r--r-- 1 root root 627 2011-12-09 16:49 test_if_connected
Back to top
View user's profile Send_private_message 

Joined: 28 Dec 2009
Posts: 858

PostPosted: Wed 03 Oct 2012, 16:45    Post_subject:  

You're welcome. That's good news.

Thanks for posting the results. All looks good now.

As you can guess, the load-touchpad-settings file, which you can now see in your listing of /root/Startup, is the script that loads your saved settings. Probably it was missing, but installing flsynclient-.6.pet restored it.
Back to top
View user's profile Send_private_message 

Joined: 26 Aug 2008
Posts: 10

PostPosted: Wed 03 Oct 2012, 17:35    Post_subject:
Sub_title: Thank you

Thank you npierce for taking the time to post help. Do you have any ideas why system crashes watching you tube?
Back to top
View user's profile Send_private_message 

Joined: 28 Dec 2009
Posts: 858

PostPosted: Thu 04 Oct 2012, 15:15    Post_subject:  

System crashes while watching YouTube are a special feature of Puppy, designed to give users' eyes a rest and give the user time to consider what percent of his life he wants to devote to YouTube.

Yes, I am kidding.

Sorry, I've not run into this problem (maybe because I don't have Flash Player installed), so don't know much about it. All I know is what I've read about it in countless posts in this forum. When the crash happens immediately or soon, it seems to usually be a compatibility problem between a specific version of Flash Player and a specific version of some browser. When the crash happens after watching for a longer time, it seems often to be because your memory is being filled up.

The former problem can be fixed by finding a browser version and a Flash Player version that have a little respect for each other (doing so can be somewhat of a black art). The latter problem can sometimes be alleviated (but not usually eliminated) by freeing up some memory by moving the directory where the YouTube data is cached out of your save file (depending upon how you have installed Puppy), or by increasing the size of your swap partition.

For details, search the forum for posts from folks who have been there and done that.

(Better yet, don't install Flash Player. Life is short.)
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0832s ][ Queries: 12 (0.0038s) ][ GZIP on ]