Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 08:31
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Engineering/Science/Simulation
SagCad: A CAD program
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
muggins

Joined: 20 Jan 2006
Posts: 6683
Location: lisbon

PostPosted: Fri 27 Jul 2007, 10:37    Post subject:  SagCad: A CAD program  

http://sagcad.sourceforge.jp/

Quote:
SagCAD is a CAD/CAM of 2D.
Designed for the X Window System, it uses the GTK+ 1.2 libraries.

Although new features are always under development, currently SagCAD has these
features:

* 2D CAD/CAM
* Opening/Saving/Creating of files
* Undo/Redo
* Font can use Qcad cxf Font
* Cut/Copy/Paste
* SGY/DXF/IGES/NC file output
* SGY/DXF/NC file input
* ps(PostScript) file output
* Outside process (perl,ruby,PHP,C)
* CAM
* Ellipse and polyline


Run via Menu>Graphic>SagCAD
sagcad-0.9.14.pet
Description 
pet

 Download 
Filename  sagcad-0.9.14.pet 
Filesize  624.9 KB 
Downloaded  618 Time(s) 
sagcad.gif
 Description   
 Filesize   9.62 KB
 Viewed   1789 Time(s)

sagcad.gif


Last edited by muggins on Wed 03 Oct 2012, 18:07; edited 2 times in total
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6683
Location: lisbon

PostPosted: Fri 27 Jul 2007, 10:41    Post subject:  

This pet has two Japanese fonts.
sagcad-JpFonts-0.9.14.pet
Description 
pet

 Download 
Filename  sagcad-JpFonts-0.9.14.pet 
Filesize  974.03 KB 
Downloaded  462 Time(s) 

Last edited by muggins on Sun 30 Sep 2012, 20:22; edited 1 time in total
Back to top
View user's profile Send private message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Sun 30 Sep 2012, 00:43    Post subject:  

I tried installing this in Slacko 533 but it doesn't want to run. Is there a more up to date version or any newish cad that uses the dxf file format - which could possibly be opened by Autocad as well?

if there is a newer version, can i just install it on top of what i already installed?

I tried searching the forum (titles only) using only the word 'cad'. All posts were from 2007 so I'm wondering if I should be trying to do cad in Puppy these days.
--------
Hold the fort - after trying the google search, I found a more up-to-date thread here discussing draftsight, an Autocad compatible app.

[urlhttp://www.murga-linux.com/puppy/viewtopic.php?p=503969#503969[/url]

Thanks.

so i won't do any more on this thread.

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN

Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6683
Location: lisbon

PostPosted: Sun 30 Sep 2012, 03:55    Post subject:  

It isn't running because it's a gtk1 based app. If you install these:

glib12-1.2.10.pet
gtk+12-1.2.10.pet

then run, from console, sagcad, then it will start.

Have you tried draftsight?
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6683
Location: lisbon

PostPosted: Sun 30 Sep 2012, 09:50    Post subject:  

Also, if you check the last thread here, charlie6 explains the details of getting gCAD3D working in exprimo.
Back to top
View user's profile Send private message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Sun 30 Sep 2012, 14:39    Post subject:  

Hi Muggins
Yes, I'm trying to get draftsight going but am having some issues (- activation) so I hope someone can help. My problems are at the link you gave on page 3. If it can't be made to work I'll come back here. It seems the Lucid 528.005 is behaving quite differently than Slacko 533, so my dual screen setup went a little out of whack per this link (sept 30 edit)

http://www.murga-linux.com/puppy/viewtopic.php?t=79870&start=32:

I probably won't try the exprimo thing since I don't need 3d and i'd like to stay as close as possible to autocad because of old files, etc.

editSept30 - decided after all to get sagcad running so followed your instructions and it worked as advertised! It actually looks good enough for what I need - simple plot of old map surveys from land registry office. Hopefully the dxf file can be imported to the other apps later on if needed.

Thank you muchly

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN

Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6683
Location: lisbon

PostPosted: Sun 30 Sep 2012, 20:27    Post subject:  

Well, I was surprised to see that there was a package for V0-9-14, for ubuntu, which is gtk2 based. I've uploaded to the first post so, if you want to try it, first use the package manager to delete the previous version.

For some strange reason, even though the ubuntu package says 0.9.14, the gui says 0.9.13?
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Sun 30 Sep 2012, 22:07    Post subject:  

Hi.

SAGCAD 0.9.6 running in LazY Puppy ---> loaded as sfs using LazY Puppy RunScript.

Attached.



SAGCAD 0.9.14(13) running in LazY Puppy --->loaded as sfs using LazY Puppy RunScript.

Attached.



RSH
LP2_SAG_CAD-0.9.6.sfs.gz
Description  SFS ---> remove the .gz
gz

 Download 
Filename  LP2_SAG_CAD-0.9.6.sfs.gz 
Filesize  1.07 MB 
Downloaded  368 Time(s) 
LP2_SAG_CAD-0.9.14.sfs.gz
Description  SFS ---> remove the .gz
gz

 Download 
Filename  LP2_SAG_CAD-0.9.14.sfs.gz 
Filesize  1.56 MB 
Downloaded  384 Time(s) 

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6683
Location: lisbon

PostPosted: Mon 01 Oct 2012, 03:57    Post subject:  

RSH,

glad you looked at this. Currently the pet comes with html files in japanese, german & machine translated english. Under /root/.sagcad the file sagcadrc has:

Code:
Browser command
defaulthtmlviewer %s


So when the Help button is clicked, the Japanese index.html is opened. Do you think it would be better with a script, say called runBrowser, which would parse if default language is german or japanese, open the respective index.html, otherwise default to english?
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Mon 01 Oct 2012, 17:19    Post subject:  

Quote:
So when the Help button is clicked, the Japanese index.html is opened. Do you think it would be better with a script, say called runBrowser, which would parse if default language is german or japanese, open the respective index.html, otherwise default to english?

If I do click the Help Button, the German Documentation is opened (i just changed the settings (command for browser) from netscape to defaultbrowser)



Did work in both versions the same way.

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Mon 01 Oct 2012, 18:09    Post subject:  

I have tested using English Language Settings ---> Japanese Docs are opened. Did made some tests... ...only replacing Japanes Docs with English Docs in /usr/local/share/sagcad/doc gives success. Confused



A small script -like you did suggest- should do the job as well.

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6683
Location: lisbon

PostPosted: Wed 03 Oct 2012, 15:45    Post subject:  

Thanks RSH...it's not a big issue. Seeing that it does load german docs correcty, but not english, maybe I'll look at the sources & see where this is being decided, then recompile.

cheers

Edit I modified the sources & recompiled, and I think it's working OK now, so re-uploaded new .pet.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Engineering/Science/Simulation
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0709s ][ Queries: 13 (0.0053s) ][ GZIP on ]