Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 09:45
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
SeaMonkey 2x: Can't change URL window/toolbar fonts (SOLVED)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Mon 17 Sep 2012, 23:25    Post subject:  SeaMonkey 2x: Can't change URL window/toolbar fonts (SOLVED)  

Back when I started this thread with SeaMonkey 2.5 official build, Import Wizard would launch after installation, allowing migration of data from SeaMonkey 1.x. This included ALL fonts; everything but the new icons appeared as they did in SeaMonkey 1.x.

Apparently, SeaMonkey 2.12.1 official build has no Import Wizard.

Edit / Preferences / Appearance / Fonts will allow changes to webpage fonts, but not URL and toolbar fonts.
Does anyone know how to do this?
The letter spacing is so tight that the URLs are almost unreadable.
SM-2.5-import-wizard-pt1.png
 Description   SeaMonkey 2.5 Import Wizard part 1
 Filesize   31.19 KB
 Viewed   351 Time(s)

SM-2.5-import-wizard-pt1.png

SM-2.5-import-wizard-pt2.png
 Description   SeaMonkey 2.5 Import Wizard part 2
 Filesize   10.91 KB
 Viewed   365 Time(s)

SM-2.5-import-wizard-pt2.png


Last edited by Dewbie on Mon 24 Sep 2012, 22:07; edited 4 times in total
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3982
Location: World_Hub

PostPosted: Tue 18 Sep 2012, 06:02    Post subject:  

Dewbie- if you employ a userChrome.css, then these mods may work.
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1799
Location: Out wandering... maybe.

PostPosted: Wed 19 Sep 2012, 04:19    Post subject:  

You can try the Theme Font & Size Changer extension, which will let you change the GUI's font, size, style, weight and color.
(I should note that for me, the addons.mozilla.org page for the extension (and more or less AMO in general) thinks my Seamonkey 2.12.1 is actually Firefox 2.12.1 Rolling Eyes, so if that happens to you, either try to install it anyway, or save the extension to disk and drag it onto the Add-Ons window/tab.)

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Thu 20 Sep 2012, 04:35    Post subject:  

Thanks to both of you for the suggestions! Smile

Here's what I did:

* Downloaded Theme Font & Size Changer.

* Ignored instructions to install; went to /tmp and moved the .xpi file to a storage partition.
(Then I still have it for future use.)

* Dragged .xpi file to browser window and followed prompts to install, then restarted browser.

Theme Font & Size Changer logo appears at far right of toolbar.
(Note: A warning states that it's not compatible with SeaMonkey 2.12.1, but that's not true; it works just fine. Smile )
before.jpg
 Description   Before: Default font
 Filesize   2.22 KB
 Viewed   443 Time(s)

before.jpg

after.jpg
 Description   After: DejaVu Sans
 Filesize   2.47 KB
 Viewed   449 Time(s)

after.jpg

Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1799
Location: Out wandering... maybe.

PostPosted: Thu 20 Sep 2012, 15:02    Post subject:  

Hmm... that's odd. I haven't had any compatibility warnings with it on my Seamonkey. What happens if you try a check for updates in the Add-ons Manager? (The version of the extension listed in my Manager is 6.1.)
_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Mon 24 Sep 2012, 00:31    Post subject:  

Makoto wrote:
Quote:
What happens if you try a check for updates in the Add-ons Manager? (The version of the extension listed in my Manager is 6.1.)

It shows the same version you have, 6.1.
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1799
Location: Out wandering... maybe.

PostPosted: Mon 24 Sep 2012, 03:02    Post subject:  

Is it giving you the same 'warning' that it shows for the UnPlug extension in this picture?



(I have extension compatibility checks turned off, but it still shows those gripes regardless. Also, I updated UnPlug to a beta version after taking that screencap, so it's actually no longer showing that particular gripe. Very Happy)

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Mon 24 Sep 2012, 03:20    Post subject:  

The incompatibility warning appeared before I installed Theme Font & Size Changer 6.1.
Now everything's fine; no such warnings.
(And I don't have UnPlug installed.)
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1799
Location: Out wandering... maybe.

PostPosted: Mon 24 Sep 2012, 03:43    Post subject:  

Yeah, I was asking if you had a similar warning on Theme Font & Size Changer in the add-ons manager. Smile

I'd figured it had been updated for SM 2.12.1 by the time you installed it (the 'last updated' date for the extension in my manager is 7/30/12, so it shouldn't have complained, in theory, but I can't be sure. Oh, well; it's not really a big deal, as long as it works and the manager isn't griping about it being incompatible now. Mr. Green

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Mon 24 Sep 2012, 04:14    Post subject:  

Quote:
the 'last updated' date for the extension in my manager is 7/30/12

SeaMonkey 2.12.1 was released 9/10/12, so that might be the problem.
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1799
Location: Out wandering... maybe.

PostPosted: Mon 24 Sep 2012, 04:39    Post subject:  

Maybe. I guess I'm too used to extension developers just setting the maxversion to values like 2.* or 2.12.* (or a higher subversion, of course).

Embarassed

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Mon 24 Sep 2012, 06:26    Post subject:  

BarryK just started a SeaMonkey 2.12.1 thread here, so I mentioned the fonts problem.

Edit:
OK, just opened up the toolkit and took a few things for a spin.
(Also, have a look at the first post above; I updated the info...again. Shocked )

Everything I reported above was with Puppy Linux 4.1.2.
(Which, in hindsight, I should've mentioned.)

So I tried 4.3.1; same problem.
(And I'm assuming this applies to 431JP also Question ...Are you there, Makoto? Laughing )

BarryK wrote:
Quote:
I don't have this problem. Running SM 2.12.1 in Wary right now, the URL box is using DejaVu Sans and looks good.

This is because the SM PETs that I create have /root/.mozilla/.../userChrome.css, that specifies DejaVu Sans 12-pixel font for URL-box etc.

Ahhh...but it's not just the .pets! Shocked
Apparently, something inside Wary itself addresses this problem.

When I tried SeaMonkey 2.12.1 official build with Wary 5.1.1 and 5.1.4.1, everything's DejaVu Sans and easy to read. Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0702s ][ Queries: 13 (0.0042s) ][ GZIP on ]