Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Jul 2014, 07:01
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
SolidPup 5.1.1-B Lite and OBXF
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 12 of 21 [301 Posts]   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13, 14, ..., 19, 20, 21 Next
Author Message
Tote


Joined: 19 Jan 2012
Posts: 226
Location: South Wales

PostPosted: Wed 05 Sep 2012, 15:01    Post subject:  

Tried ice wm, works otherwise but same thing, but I also get this flash message;

Unable to extract the file "%f".
Please ensure that "/root/.themes" is writable and that the file is a valid Openbox theme archive.
The following errors were reported:
tar: %f : Cannot open : No such file or directory
tar : Error is not recoverable : exiting now
tar : Child returned status 2
tar : */openbox-3 : Not found in archive
tar : Exiting with failure status due to previous errors

Also, going back to previous Openbox issue, I don't know if this is relevant; if I try to choose Openbox by right clicking Desktop then scrolling down to Openbox Config, that's when it hangs...

but if I right click Desktop and scroll all the way down to Other then select Configure Openbox, it works normally....
Back to top
View user's profile Send private message 
Tote


Joined: 19 Jan 2012
Posts: 226
Location: South Wales

PostPosted: Wed 05 Sep 2012, 15:11    Post subject:  

No go Sad Removed rabbit, still the same error in terminal.
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Wed 05 Sep 2012, 15:32    Post subject:  

Tote wrote:
Tried ice wm, works otherwise but same thing, but I also get this flash message;

Unable to extract the file "%f".
Please ensure that "/root/.themes" is writable and that the file is a valid Openbox theme archive.
The following errors were reported:
tar: %f : Cannot open : No such file or directory
tar : Error is not recoverable : exiting now
tar : Child returned status 2
tar : */openbox-3 : Not found in archive
tar : Exiting with failure status due to previous errors

Also, going back to previous Openbox issue, I don't know if this is relevant; if I try to choose Openbox by right clicking Desktop then scrolling down to Openbox Config, that's when it hangs...

but if I right click Desktop and scroll all the way down to Other then select Configure Openbox, it works normally....


Ooohhhh! Now I get the same problem as you. I was always using "Configure Openbox" way down in the "Other" menu. That fix is an easy one. The obconf.desktop file is faulty...the exec option is supposed to be "obconf", not "obconf %f". Actually, you can just delete "/usr/share/applications/obconf.desktop" and type "fixmenus" in the terminal to remove that menu entry...I didn't intend it to be there, because it will also show in icewm mode, which I don't want.

This issue will be fixed in the next release...thanks Tote! Smile

Anyone wishing for extra wifi drivers, now is the time to request it.
I am not an expert in firmware updates, but, hopefully if I run into trouble, Pemasu, O1micko or someone else with driver expertise can help me out.

Last edited by Tman on Wed 05 Sep 2012, 16:23; edited 1 time in total
Back to top
View user's profile Send private message 
Tote


Joined: 19 Jan 2012
Posts: 226
Location: South Wales

PostPosted: Wed 05 Sep 2012, 15:49    Post subject:  

Ooops! (Sorry)

Is this a good time to tell you I can't get Pwidgets to work either... or shall I not mention it??

(I don't use it, btw, I'm just saying).
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Wed 05 Sep 2012, 15:58    Post subject:  

Tote wrote:
Ooops! (Sorry)

Is this a good time to tell you I can't get Pwidgets to work either... or shall I not mention it??

(I don't use it, btw, I'm just saying).


Oh, you are right! ...I missed that one, cause I don't use it either. I will look into it, thanks Tote. The more bugs that get squashed, the better. I gotta sign off for today. I will have more free time to work on the next release on the weekend, but I will try to keep up to date with this thread.
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2403
Location: New Zealand

PostPosted: Wed 05 Sep 2012, 21:02    Post subject:  

Tman wrote:
Anyone wishing for extra wifi drivers, now is the time to request it.
Thanks Tman. I would like to be able to run SolidPup on my Acer eMachines netbook (NAV51, model 350-21G16i) which has a broadcom wifi. (I haven't tried your latest beta on that machine yet so don't know if it's already happy to run the broadcom - the previous Tint2 version didn't). Anyway, here is my device list if it helps identify:
eMachinesdevices.jpg
 Description   
 Filesize   55.42 KB
 Viewed   665 Time(s)

eMachinesdevices.jpg

Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Thu 06 Sep 2012, 15:19    Post subject:  

Okay, I got pwidgets working again. I don't know how, but fixwidgets got deleted.

Greengeek, I have downloaded the source for the latest Broadcom STA driver.
I will take a crack at building it this weekend.

EDIT: I just found that peebee was working on Broadcom driver pets. I will ask him
advice on building it.
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Mon 10 Sep 2012, 15:07    Post subject:  

It looks like Peebee figured out the right steps necessary to get broadcom wl drivers working properly without conflicting with the opensource b43 drivers. I spent much of yesterday trying to modify Iguleder's bldpkg system which is a fantastic system for compiling apps. I'm trying to alter it so that even noobs can easily compile with. It's not quite ready for me to distribute yet, but hopefully soon. So far I've had partial success and managed to compile a lot of apps yesterday with it..some of which are going to be added to the next beta release.
http://www.smokey01.com/Tman/apps/Wary5-apps/
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Tue 11 Sep 2012, 20:24    Post subject:  

Solidpup511B-Lite-beta-2.0.iso is currently being uploaded.
It will be ready for download in about 25 minutes from now.
There is also a list of changes that I've placed in the same folder.

Quite a few upgrades from Beta1, but it is smaller.

Greengeek, I don't think your wireless is detected automatically OOTB yet,
but try loading it manually.

Greengeek, can you also try the attatched pet, to see if your wifi gets detected?
rerwin_broadcom_experiment-8-Modified.pet
Description  I removed the rc.shutdown file from the original pet
pet

 Download 
Filename  rerwin_broadcom_experiment-8-Modified.pet 
Filesize  9.16 KB 
Downloaded  112 Time(s) 
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2403
Location: New Zealand

PostPosted: Wed 12 Sep 2012, 02:46    Post subject:  

Nice! I'm posting from Dillo on SPLiteB2 now. I didn't need to load the driver manually - the dialogs at the start gave me the choice of allowing wl to be "added to the list", which I accepted, and then straight online. No drama at all.

Haven't tried Rerwins pet yet - just running as is from the live CD and seems good so far. Fresh and clean. I like it.
SolidPupLiteB2.jpg
 Description   
 Filesize   15.62 KB
 Viewed   514 Time(s)

SolidPupLiteB2.jpg

Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Wed 12 Sep 2012, 10:35    Post subject:  

greengeek wrote:
I didn't need to load the driver manually.


Wow! It went better than I expected. I sent Peebee a test version and he needed to add Rerwin's pet to get his Broadcom to detect. Unfortunately, Rerwin's original pet, overides Pupsaveconfig ... the dialog for pupsaveconfig appears, but in the end it didn't actually create a save file.

I modifed the test ISO I sent to Peebee, but I am surprised that your wifi is automatically detected. I will have to wait and see how Solidpup beta2.0 handles on Peebee's broadcom wifi.
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2403
Location: New Zealand

PostPosted: Wed 12 Sep 2012, 14:44    Post subject:  

Tman wrote:
I sent Peebee a test version and he needed to add Rerwin's pet to get his Broadcom to detect.

It may be that he is doing things the right way, and I am doing things the wrong way...

Heres what I did:
1) Start network wizard. This shows the Broadcom as an unknown device (pic1)

2) Activate Wlan0. It asks if I want to add the wl device to the list. (pic2)

3) Accept as required. Wizard confirms that wl is added to list. (pic3)

Then I just continue with the rest of the wizard - selecting WPA and adding the key etc and then straight online. (All of this is live CD, no savefile)

Next I tried loading Rerwin's pet straight after boot, and before running the network wizard, but it appeared to make no change at all.
Network wizard1 unknown.jpg
 Description   
 Filesize   69.06 KB
 Viewed   449 Time(s)

Network wizard1 unknown.jpg

Network wizard add wl to list.jpg
 Description   
 Filesize   40.48 KB
 Viewed   457 Time(s)

Network wizard add wl to list.jpg

Network wizard wl WILL be added.jpg
 Description   
 Filesize   26.61 KB
 Viewed   464 Time(s)

Network wizard wl WILL be added.jpg

Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Wed 12 Sep 2012, 22:08    Post subject:  

greengeek,

It is great that you got it working on your system. Peebee is still having a few problems,
although less this time. He also found a solution for his wifi setup, so I hope everything will be working for the both of you in the next release.

I did find a bug ... the resize personal storage file is not working; sorry folks, it will be fixed in the next version. For now, there is a link to a resize_personal_storage_legacy pet in the first post that you can use. That pet runs does not overwrite the default one, and will be found in the "Utility" menu after it is installed, rather than the "Setup" menu.
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Fri 14 Sep 2012, 02:35    Post subject:  

beta2.2 is now out. It contains various bug fixes and rerwin's new delta-3f patch for broadcom wifi conflicts.
... not anything new in terms of more apps.

Greengeek, when you have time to try this out, please let me know if your wifi is still okay on this one.
Much appreciation goes to Peebee for helping me test the last several releases to get this broadcom driver issue sorted out.
Thanks too to Rerwin and Pemasu for their advice on my questions regarding wifi firmware.
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2403
Location: New Zealand

PostPosted: Fri 14 Sep 2012, 06:41    Post subject:  

Tman wrote:
please let me know if your wifi is okay on this one.

Yes, thanks, I still have connectivity through the wireless adapter. Exactly the same method as my last post. However I did notice that the internet icon in the wbar does not work. Had to use the menu to get Dillo started. I thought it worked ok through wbar on previous version but I will have to double check tomorrow.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 12 of 21 [301 Posts]   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13, 14, ..., 19, 20, 21 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0899s ][ Queries: 13 (0.0090s) ][ GZIP on ]