Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 10:14
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
webcam Trust 16490
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [25 Posts]   Goto page: Previous 1, 2
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Tue 04 Sep 2012, 08:39    Post subject:  

Regarding Skype: there is a discussion here about getting other webcams to work.

It involves making a script that preloads some other code.

The required file is /usr/lib/libv4l/v4l1compat.so which is part of your guvcview install.

From the command line, type:

Code:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 132

PostPosted: Tue 04 Sep 2012, 08:59    Post subject:  

It gave me an error.
Code:
# LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
skype: error while loadind shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Tue 04 Sep 2012, 09:03    Post subject:  

Do you get that error when you run skype on its own?

What skype package are you using?
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 132

PostPosted: Tue 04 Sep 2012, 09:24    Post subject:  

I get the error when the command is executed in the console, Skype is not loaded, it's closed.
I'm using the static package of Skype. Maybe that's the problem.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Tue 04 Sep 2012, 09:31    Post subject:  

I'm confused. I don't think that the error message has anything to do with your webcam.

Have you ever had skype running at all? How did you start it?

Please supply a link to the source of your skype package.
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 132

PostPosted: Tue 04 Sep 2012, 09:37    Post subject:  

rcrsn51 wrote:

Have you ever had skype running at all? How did you start it?

(I have put the files of skype in folder: /root/skype/skype_staticQT)
Yes, it is running.
I started it by clicking the executable file of skype: /root/skype/skype_staticQT-4.0.0.8/skype

rcrsn51 wrote:

Please supply a link to the source of your skype package.

http://www.skype.com/intl/en/get-skype/on-your-computer/linux/downloading.static
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Tue 04 Sep 2012, 10:05    Post subject:  

Quote:
What do you mean here? To open the file /var/log/messages with syslogd? How?

Question
To view use a common editor .
The files might be not existant if syslogd and klogd are not started .
Puppy 4 series started these daemons from /etc/rc.d/rc.sysinit directly ,
newer use a /etc/init.d/ script .
I like them being started before the module loading starts
so when i set UDEV_LOG=7 in rc.sysinit the output gets directed to /var/log/messages and not to the console .
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Tue 04 Sep 2012, 10:20    Post subject:  

Regarding skype: I got the official skype package. I installed it using these instructions:
Quote:
We recommend copying the skype binary to /usr/bin and installing sounds/, lang/ and avatars/ into the /usr/share/skype directory.


Under your setup, I don't understand how running the command "skype" would work at all, unless you have also installed some other skype package.

I ran "skype" and my webcam was auto-detected correctly.

In your case, run the command
Code:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 132

PostPosted: Tue 04 Sep 2012, 10:33    Post subject:  

rcrsn51 wrote:
Regarding skype: I got the official skype package.

You mean ubuntu 10.04 32 bit?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Tue 04 Sep 2012, 10:36    Post subject:  

panoss wrote:
rcrsn51 wrote:
Regarding skype: I got the official skype package.

You mean ubuntu 10.04 32 bit?

No. The one from your link.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [25 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0694s ][ Queries: 13 (0.0127s) ][ GZIP on ]