Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 04:26
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.4.12 with 3.4.2 kernel.
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 71 of 89 Posts_count   Goto page: Previous 1, 2, 3, ..., 69, 70, 71, 72, 73, ..., 87, 88, 89 Next
Author Message
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Tue 21 Aug 2012, 18:25    Post_subject:  

...hassle; compile problems for libmtp with missing PTPParam members and undeclared inconv_t variable.

edit. I'll try the one in the PM.. There's also an mtp-tools in debian, along with deps like libmtp9. When I have some time, maybe I'll hunt for the winning combo.
Back to top
View user's profile Send_private_message 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Wed 22 Aug 2012, 03:33    Post_subject:  

Okay..this worked:

From PPM:

mtpfs_0.9
mtp-tools_1.0.3-1+squeeze1
libmtp8_1.0.3-1+squeeze1

Add line to /etc/udev/rules.d/51-android.rules
SUBSYSTEM=="usb",ATTR{idProduct}=="6860", MODE="0666", OWNER="your-username-in-the-linux"

mkdir /root/Nexus7
chmod a+rwx /root/Nexus7


* Plug in your Nexus 7, then:

mtpfs -o allow_other /root/Nexus7

Files are shown in the /root/Nexus7 directory



* Now You can browse your Android phone contents or add/remove

To unmount:
umount /root/Nexus7
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Wed 22 Aug 2012, 11:33    Post_subject:  

Thanks jpeps. I will save your post for future reference. Thanks.

By the way....my wheezy experiment...with pre...pre...pre...alpha is going fine. Some problems with gcc stuff though. And a lot missing core packages....which I hunt...and I have started to compile my own needed pets.
Ffmpeg, mplayer, gnome-mplayer have been compiled. To get rid of libpulse dependencies. Also latest dhcpcd. Next will be some other stuff. But I wont update the whole application league...only those which are dependent of gtk-3.0 so that I can include them with gtk-2.0 puppy. But the 3.5.2 kernel compiled fine. Posting from Dpup Wheezy 3.5.2 using firefox. Next I start my evening project with compiling and debugging missing packages. X, jwm, net, works.
Main problem is to get udev working correctly so that devices are autoloaded. That is still buggy.

Experience with Precise Puppy and Upup Precise have helped a lot. The package structure, need for schemas support and fixes for them are all the same. Wheezy is basically Ubuntu Quantal version what comes to library version numbers...it seems. I have even used some Quantal packages for quick fix before I found the real Wheezy ones...lol. Wheezy package database still changes, that is the reason for difficulties sometimes.
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1022
Location: South of Belgium

PostPosted: Wed 22 Aug 2012, 12:23    Post_subject: failed to build of 96.43.20 nvidia driiver on 5X.3.4.2.9  

Hi,
failed to build of 96.43.20 nvidia driiver on 5X.3.4.2.9; using the sh-installer method given on www.nvidia.com;
Now trying to get the 96.43.20 nvidia driiver built here on my Compag Evo with Nvidia GeForce2 MX200:
on a fresh squeezesave 512MB size
+ devx_squeeze_5.X.3.4.2.9.sfs (1)
+ kernel_sources-3.4.2-dpup.sfs (2)
+ linux_kernel-3.4.2-dpup.pet (3)
md5sums checked OK;

I got the attached nvidia-installer.log report which tells something about the kernel ...could be kernel version...? (above my knowlledges ...!);
first attempt after (1) and (2) installed;
second attempt after added (3);

All went well using the same method on Dpup-Exprimo 5X15.
Maybe the nvidia archive is not yet compatible with kernel 3.4.2 (cannot check this)?
Any advice would be welcome !
cheers, charlie
nvidia-installer.txt.tar.gz
Description  drop the tar.gz extension to get the txt file
gz

 Download 
Filename  nvidia-installer.txt.tar.gz 
Filesize  4.19 KB 
Downloaded  173 Time(s) 
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Wed 22 Aug 2012, 12:37    Post_subject:  

Charlie6. Post the content of debug file:
Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details.

And no...dont install the kernel pet. It is for woof or for kernel switching only. Not for compiling the kernel modules.
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1022
Location: South of Belgium

PostPosted: Wed 22 Aug 2012, 16:15    Post_subject:  

Hi Pemasu,
pemasu wrote:
Charlie6. Post the content of debug file:
Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details.

i'm sorry ...but kernel matter is outside my knowledge... do you want me whether, to upload the /var/log/nvidia-installer.log file? if yes, it is the already attached file to my post renamed with «.txt.tar.gz» instead of «.log»; or to read into that file...?

pemasu wrote:
And no...dont install the kernel pet. It is for woof or for kernel switching only. Not for compiling the kernel modules.

Please tell me if I've good understood: i should not have installed (1), (2) and (3). So I could build the nvidia driver without installing (1), (2) and (3).
I did so because i could get the nvidia-driver that same way on Dpup-Exprimo 5X15 ( installed : (1) + (2) relevant for k 2.6.39.4).
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Wed 22 Aug 2012, 16:45    Post_subject:  

Charlie6. Sorry I read your attached file content too quickly. You had attached right file. It looks like that the 96.43.20 nvidia driver package is not compatible with 3.X kernels. It does not show spesific error...just shows that it does not find the needed kernel source, so I am guessing because it refers to 2.4 and 2.6 kernel versions.

Generally, when you compile drivers...which have kernel module drivers included....you need devx sfs and kernel source sfs.

Unfortunately that older nvidia driver package is not compatible. It might be that there is workaround in the net if you are stubborn enough and find guide how to patch the package content. I am not aware of them though. I dont have nvidia graphics so...I cant test much with nvidia.
Back to top
View user's profile Send_private_message 
SouthPaws

Joined: 16 Sep 2006
Posts: 87

PostPosted: Wed 22 Aug 2012, 17:52    Post_subject: sfs request
Sub_title: morituri (ripper program)
 

Hey pemasu, would you consider this request for a 'morituri' sfs?

It's in the debian repo... but has a number of dependencies...

Here's a link... I hope it's helpful.
http://thomas.apestaart.org/morituri/trac/wiki/WikiStart

_________________
http://www.ebiblefellowship.com/sunday_bible_study/2005.10.09_McOwen.htm
Back to top
View user's profile Send_private_message 
ssanubis

Joined: 10 Aug 2012
Posts: 9

PostPosted: Wed 22 Aug 2012, 22:26    Post_subject:  

Just wanted to let you know, testing on a Samsung 300v (series 3 laptop) with, per lspci,
Code:
01:00.0 Network controller [0280]: Intel Corporation WiFi 100 Series [8086:08ae]


This wireless device does not have the necessary module to detect a wireless interface in this version of Exprimo. I am posting from Exprimo 3.1.1.0.3 which has the module needed. The module is iwlagn. Not sure how helpful that is to you.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Thu 23 Aug 2012, 00:52    Post_subject:  

There isnt iwlagn anymore. It is iwlwifi now. You should run in console: dmesg > dmesg.gz
Post the created fiel as attachment here. I believe some needed firmware could be missing.
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1022
Location: South of Belgium

PostPosted: Thu 23 Aug 2012, 01:02    Post_subject: nvidia 96.43.xx driver for GeForce2 MX200 for k3.4.2  

Hi Pemasu,
pemasu wrote:
Charlie6. ...It looks like that the 96.43.20 nvidia driver package is not compatible with 3.X kernels...
Unfortunately that older nvidia driver package is not compatible. .

thnks for your reply....
I then browsed the nvidia forum ans found this post written by 16 augustus 2012 ( i surely ought to browse there first ... Embarassed ):

Nvidia Linux forum member wrote:
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers don’t work in Ubuntu 12.04
I emailed support about a week ago and they replied very quickly that they have no intentions to update the 96xx driver. We are just out of luck.


so no hope - i will use this pc with 5X15
see results here Very Happy ==> http://www.murga-linux.com/puppy/viewtopic.php?t=70399&start=2129
Cheers, Charlie
Back to top
View user's profile Send_private_message 
ssanubis

Joined: 10 Aug 2012
Posts: 9

PostPosted: Thu 23 Aug 2012, 12:22    Post_subject:  

Here's my dmesg output. If there is anything else I can do let me know, I have plenty of time on my hands at the moment, lol.
dmesg.gz
Description 
gz

 Download 
Filename  dmesg.gz 
Filesize  44.43 KB 
Downloaded  147 Time(s) 
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Thu 23 Aug 2012, 13:16    Post_subject:  

ssanubis. It seems I have screwed the folder structure of the firmwares when I meddled with changing their location. I seem to have lost my mind.
Okay...I need to create new build of dpup exprimo with 3.4.2 kernel.
But...here is quick fix. The firmwares are all there. They just need folder reconstruction.
Install this pet. It has only the pinstall.sh script inside which runs the needed commands to move the firmwares to the right location.
Thank you of the feedback. It was valuable information. I wonder how many has had problems with firmwares, but havent posted about the problems.
iwlwifi-fix.0.0.1.pet
Description 
pet

 Download 
Filename  iwlwifi-fix.0.0.1.pet 
Filesize  382 Bytes 
Downloaded  138 Time(s) 
Back to top
View user's profile Send_private_message 
linuph


Joined: 03 Jun 2012
Posts: 128
Location: Philippines

PostPosted: Thu 23 Aug 2012, 14:09    Post_subject:  

@pemasu
I earlier reported that Frisbee wlan was working in the latest Exprimo. Because of some other unrelated problems I deleted the squeezesave file and started all over. To my surprise, Frisbee wlan did not work, again.

I use a USB WiFi dongle with Ralink rt5370sta chip/driver. Having similar experiences with other Puppies I downloaded and installed tempestuous' rt5370 pet from http://www.murga-linux.com/puppy/viewtopic.php?t=59000&search_id=952197223&start=15.

Now it works and even better than before since it now finds other WiFi stations in my neighborhood too.

Just to let you know.

Edited_time_total
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Thu 23 Aug 2012, 14:45    Post_subject:  

Linuph. Yes. That goes to the same firmware folder stucture misconfiguration. That pet has the right firmware and folder structure included. So your wireless finds the right driver (dpup one) and the right firmware (from the pet). Now it is clear to me. It is just...that when you copy firmware folder with different folder structure need from one place to the other place and then again back...the right folder structure just didnt came clearly to mind at the time. Now...I see my mistake clearly.
I will create new build quite soon. I will use latest woof though and update some apps also.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 71 of 89 Posts_count   Goto page: Previous 1, 2, 3, ..., 69, 70, 71, 72, 73, ..., 87, 88, 89 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1079s ][ Queries: 13 (0.0243s) ][ GZIP on ]