Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 17:42
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to print pictures with Gimp in Slacko? [Solved]
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Thu 16 Aug 2012, 23:37    Post_subject:  

You need to run the command from INSIDE /usr/lib.
Back to top
View user's profile Send_private_message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Thu 16 Aug 2012, 23:51    Post_subject:  

Is this right?
Code:
# cd /usr/lib
# gimp

(gimp:2819): GLib-WARNING **: goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
** Message: Module '/usr/lib/gegl-0.1/ff-load.so' load error: libavformat.so.52: cannot open shared object file: No such file or directory
This is a development version of GIMP.  Debug messages may appear here.

#


See the edit to the previous that there is a broken link at
Code:
/root/libavformat.so.52
Back to top
View user's profile Send_private_message Visit_website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Fri 17 Aug 2012, 00:33    Post_subject:  

The link needs to be in the folder /usr/lib NOT in /root.

You need to open a console INSIDE /usr/lib and type the ln command again.
Back to top
View user's profile Send_private_message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Fri 17 Aug 2012, 01:18    Post_subject:  

Sorry I'm a bit thick-headed. I deleted the broken link in /root and hopefully put the link in correctly this time.
Problem still the same.

This is what I see in /usr/lib.
Thanks very much for your patience. It's getting late - more so for you!
usr-lib.png
 Description   
 Filesize   25.3 KB
 Viewed   372 Time(s)

usr-lib.png

Back to top
View user's profile Send_private_message Visit_website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Fri 17 Aug 2012, 01:28    Post_subject:  

The only other thing I can suggest is that you go into another Puppy like Lupu and get the real libavformat.so.52.
Back to top
View user's profile Send_private_message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Fri 17 Aug 2012, 09:06    Post_subject:  

rcrsn51 wrote:
The only other thing I can suggest is that you go into another Puppy like Lupu and get the real libavformat.so.52.


I took it from the lupu iso and that got me a step farther, but the terminal kept asking for more new files until I decided to adjourn for now.
Back to top
View user's profile Send_private_message Visit_website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Fri 17 Aug 2012, 11:26    Post_subject:  

Just as a shot in the dark I tried
Gimp_2.7.3_Lucid_5.pet
I get:
Code:
# gimp
gimp: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /usr/lib/libgimpwidgets-2.0.so.0)
gimp: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /usr/lib/libgimpbase-2.0.so.0)
gimp: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /usr/lib/libgegl-0.1.so.0)
gimp: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /usr/lib/libbabl-0.1.so.0)
#


Any idea where to find this?
Back to top
View user's profile Send_private_message Visit_website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Fri 17 Aug 2012, 11:36    Post_subject:  

This is heading towards a dead end and may have nothing to do with the printing problem. I think that there are two possible solutions.

1. Have gray make you a Gimp 2.7.2 for Racy NOP because that's the one that printed for chekrout .

2. Use some other printing tool.
Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Fri 17 Aug 2012, 11:48    Post_subject:  

Henry wrote:
Just as a shot in the dark I tried
Gimp_2.7.3_Lucid_5.pet
I get:
Code:
# gimp
gimp: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /usr/lib/libgimpwidgets-2.0.so.0)
gimp: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /usr/lib/libgimpbase-2.0.so.0)
gimp: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /usr/lib/libgegl-0.1.so.0)
gimp: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /usr/lib/libbabl-0.1.so.0)
#


Any idea where to find this?


Just want to remind that Lupu Puppy has Glibc-2.11.x while Wary/Racy has got 2.10.x .

It is possible to disable glibc version checks for libraries and binaries , i think i have seen such in one configuration option of a package . Probably unsafe to to such though .

Puppy 4 series should have glibc-2.6.1 and Lighthouse Puppy-4x series glibc-2.9.x .

Slacko has glibc-2.13 and Precise seems to have 2.15 as i look it up @
http://packages.ubuntu.com/search?suite=default&section=all&arch=any&searchon=names&keywords=glibc

Older glibc bins/libs compiles are very likely to work in newer glibc environments, but newer will almost everytime abort with the error message
version `GLIBC_NEWER-MAJOR.NEWER-Minor' not found .
Back to top
View user's profile Send_private_message Visit_website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Fri 17 Aug 2012, 13:44    Post_subject:  

Thanks, Karl,

I'm begining to get the picture . . .
Back to top
View user's profile Send_private_message Visit_website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Fri 17 Aug 2012, 14:39    Post_subject: Re: Can't print from Gimp-2.7.1-w5 (and others)  

Henry wrote:
I know - this is an "unstable" release, but it came with my package manager for RacyNop-5.2.2, and it does everyting I want except print.

I installed this in RacyNOP along with libgegl and libbabl. I made a test drawing and tried to save it. The program segfaulted. It looks to me like this version has more serious problems than printing.
Back to top
View user's profile Send_private_message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Fri 17 Aug 2012, 15:09    Post_subject:
Sub_title: see edit
 

You are correct, of course. I am not able to save new drawings. Well, I did not exhaustively test the Gimp features - I never create drawings - I only work with existing photos. And then try to print them.

Exactly where these problems lie, I don't know. The 2.6.8 version also runs in RacyNop but doesn't print. I'll check to see if saves new drawings. It certainly worked and printed in the previous QuirkyNop.

EDIT: This one saves drawings but does not print in RacyNop.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0679s ][ Queries: 13 (0.0045s) ][ GZIP on ]