Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 09:42
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Ov-Precise updated iso starts on page 8 No longer AVAILABLE
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 7 of 11 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 Next
Author Message
oldyeller


Joined: 15 Nov 2011
Posts: 812
Location: Mishawaka IN

PostPosted: Thu 16 Aug 2012, 12:14    Post_subject:  

scabz wrote:
oldyeller wrote:
My thoughts on pets is it wrong to put pets that work on precise from other distros into the one the I have done?


I was just wondering that myself.
I think pets should be compiled in puppy percise or created from ubuntu percise debs, just my opinion i dont know what is right.

but there are some apps and libs that just will not compile for me.
QT, umplayer, smplayer and smtube all compiled fine for me.
xine-lib, xine-ui, vcdimager and a few other that are needed for goggles music manager will not compile for the life of me.

stuff i compiled in lucid works in percise like googlesmm and needed dep..
so i dont know where to go from here.


I like that fact that you have done some and shared it with us. I think that I will do what playdayz does and undeb and make into pets ones that will not compile.

I really have no idea on how to compile anything myself, but is a good time to learn
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5864
Location: Kentucky

PostPosted: Thu 16 Aug 2012, 12:56    Post_subject:  

Quick update.......

-Version-
Kernel : Linux 3.2.27_5.2.60 (i686)
Compiled : #1 SMP Thu Aug 16 11:18:05 CDT 2012
C Library : GNU C Library version 2.15 (stable)
Default C Compiler : Unknown
Distribution : Unknown distribution
-Current Session-
Computer Name : puppypc21949
User Name : root (root)
Home Directory : /root
Desktop Environment : Unknown (Window Manager: JWM)

Now for some sanity testing ......... Smile
Back to top
View user's profile Send_private_message 
scabz


Joined: 30 Apr 2009
Posts: 306
Location: Tallahassee FL US

PostPosted: Thu 16 Aug 2012, 13:32    Post_subject:  

here is SMPlayer and SMTube Compiled in Percise



Needs Qt
smplayer-0.8.0-i486.pet Download
smplayer_DOC-0.8.0-i486.pet Download

smtube-1.1-i486.pet Download
smtube_DOC-1.1-i486.pet Download

here is my Qt stripped and made as small as i can make it, do not use to compile only use to run apps. to compile use my sfs's from page 5
qt-4.8.2-i486-stripped.sfs Download
Back to top
View user's profile Send_private_message AIM YIM 
oldyeller


Joined: 15 Nov 2011
Posts: 812
Location: Mishawaka IN

PostPosted: Thu 16 Aug 2012, 13:38    Post_subject:  

I have just uploaded and posted about the Final build.

I will continue to update and fix things as needed like geany and help for abiword.

I have put in desksetup-7.0 and getflash-1.1

Now I am getting started to do pets so if anyone wants to help go for it and I will put them in the repo.

I would like to thank:
BarryK
pemasu
Mick
playdayz
roadkill13
James C
Lobster
Sylvander
peebee
majorfoo
Billtoo
splot
LateAdopter
scabz
Eyes-Only
gcmartin
Back to top
View user's profile Send_private_message 
oldyeller


Joined: 15 Nov 2011
Posts: 812
Location: Mishawaka IN

PostPosted: Thu 16 Aug 2012, 14:00    Post_subject:  

scabz wrote:
here is SMPlayer and SMTube Compiled in Percise



Needs Qt
smplayer-0.8.0-i486.pet Download
smplayer_DOC-0.8.0-i486.pet Download

smtube-1.1-i486.pet Download
smtube_DOC-1.1-i486.pet Download

here is my Qt stripped and made as small as i can make it, do not use to compile only use to run apps. to compile use my sfs's from page 5
qt-4.8.2-i486-stripped.sfs Download


I just add the pets to the repo

thanks
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2127
Location: Ontario Canada

PostPosted: Thu 16 Aug 2012, 14:16    Post_subject:  

scabz wrote:
oldyeller wrote:
My thoughts on pets is it wrong to put pets that work on precise from other distros into the one the I have done?


I was just wondering that myself.
I think pets should be compiled in puppy percise or created from ubuntu percise debs, just my opinion i dont know what is right.

but there are some apps and libs that just will not compile for me.
QT, umplayer, smplayer and smtube all compiled fine for me.
xine-lib, xine-ui, vcdimager and a few other that are needed for goggles music manager will not compile for the life of me.

stuff i compiled in lucid works in percise like googlesmm and needed dep..
so i dont know where to go from here.


Gogglesmm is available in ppm, it's an older version but it's working okay.
gogglesmm.jpg
 Description   
 Filesize   44.07 KB
 Viewed   767 Time(s)

gogglesmm.jpg

Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 16 Aug 2012, 14:51    Post_subject:  

Billtoo. Quick comment. Not much time in this evening:
Quote:
I updated my slackware 14 install this morning and it updated the
kernel to 3.2.27-smp, it downloads more than one version of the kernel
and the version used on this pc sees all of the ram.
I see no mention of PAE, it shows this in the grub4dos menu.lst file:

Only possibility as far as I know is that it is pae kernel. What I know it is the only way in kernel how you can make 32 bit kernel to see more than 4 Gb ( shows 3 Gb ) of RAM. I havent seen any other kernel configure options than pae for more than 4 Gb RAM. And surely 3.2.27 kernel does not have any new options.

You had 4 Gb of RAM. It might be that slackware shows the 4 Gb as 4 Gb, kernel has the limit for non pae as 4 Gb. So...you would need more than 4 Gb RAM to see does it see those excessive Gb`s.
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2127
Location: Ontario Canada

PostPosted: Thu 16 Aug 2012, 15:04    Post_subject:  

pemasu wrote:
Billtoo. Quick comment. Not much time in this evening:
Quote:
I updated my slackware 14 install this morning and it updated the
kernel to 3.2.27-smp, it downloads more than one version of the kernel
and the version used on this pc sees all of the ram.
I see no mention of PAE, it shows this in the grub4dos menu.lst file:

Only possibility as far as I know is that it is pae kernel. What I know it is the only way in kernel how you can make 32 bit kernel to see more than 4 Gb ( shows 3 Gb ) of RAM. I havent seen any other kernel configure options than pae for more than 4 Gb RAM. And surely 3.2.27 kernel does not have any new options.

You had 4 Gb of RAM. It might be that slackware shows the 4 Gb as 4 Gb, kernel has the limit for non pae as 4 Gb. So...you would need more than 4 Gb RAM to see does it see those excessive Gb`s.


I haven't updated this install yet but hardinfo shows:

Computer
Processor 4x Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
Memory 8188MB (423MB used)
Operating System Slackware 14.0

Operating System
Version
Kernel Linux 3.2.26-smp (i686)
Compiled #2 SMP Tue Aug 7 15:22:26 CDT 2012
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 16 Aug 2012, 15:06    Post_subject:  

Definitively pae kernel.
Back to top
View user's profile Send_private_message 
scabz


Joined: 30 Apr 2009
Posts: 306
Location: Tallahassee FL US

PostPosted: Thu 16 Aug 2012, 15:17    Post_subject:  

Billtoo how did you make gogglesmm?
Was everything compiled from source or created from precise debs?
was the libs included in the pet or are they separate pets?
Back to top
View user's profile Send_private_message AIM YIM 
Billtoo


Joined: 07 Apr 2009
Posts: 2127
Location: Ontario Canada

PostPosted: Thu 16 Aug 2012, 15:20    Post_subject:  

scabz wrote:
Billtoo how did you make gogglesmm?
Was everything compiled from source or created from precise debs?
was the libs included in the pet or are they separate pets?


I installed it in Puppy Package Manager, it supplied all the dependencies.
Back to top
View user's profile Send_private_message 
gcmartin

Joined: 14 Oct 2005
Posts: 4368
Location: Earth

PostPosted: Thu 16 Aug 2012, 16:40    Post_subject:  

I had the same results as BillToo. Hardinfo reports that my systems see all of the RAM as he reports.

And, Billtoo shows a GoogleMM that I would like to test. I have a large collection of songs over the years and wonder how it might handle them. Wonder if he might generate a PET or maybe its in the PPM already and I hadn't noticed.

@Oldyeller, thank you for your contribution(s). Really a GEM.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 16 Aug 2012, 16:52    Post_subject:  

Yeah...Precise Puppy has pae kernel and it should show all the RAM. I suppose we are speaking of Precise Puppy kernel if it is not mentioned in the post differently.

And yes...PPM has gogglesmm in repo.
I just copied this from Packages-ubuntu-precise-universe:
gogglesmm_0.12.3-1|gogglesmm|0.12.3-1||BuildingBlock|1437K|pool/universe/g/gogglesmm|gogglesmm_0.12.3-1_i386.deb|+libc6,+libcurl3,+libdbus-1-3,+libexpat1,+libfox-1.6-0,+libgcc1,+libgcrypt11,+libgl1-mesa-glx,+libglu1-mesa,+libsqlite3-0,+libstdc++6,+libtag1c2a,+libx11-6,+libxine1|Goggles Music Manager|ubuntu|precise||

Maybe the precise-universe repo needs to be enabled to see it. Use config manager.
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3345
Location: Ontario

PostPosted: Thu 16 Aug 2012, 20:31    Post_subject:  

I've just downloaded Precise and I'll make a right click package for it
on Saturday.

By the way Slacko saves space by not including gtkhash or
ghasher. The function could be replaced with a right click package
likehttp://www.murga-linux.com/puppy/viewtopic.php?t=78276

or my

http://www.murga-linux.com/puppy/viewtopic.php?t=79207

___________________________________
Back to top
View user's profile Send_private_message 
oldyeller


Joined: 15 Nov 2011
Posts: 812
Location: Mishawaka IN

PostPosted: Thu 16 Aug 2012, 20:35    Post_subject:  

don570 wrote:
I've just downloaded Precise and I'll make a right click package for it
on Saturday.

By the way Slacko saves space by not including gtkhash or
ghasher. The function could be replaced with a right click package
likehttp://www.murga-linux.com/puppy/viewtopic.php?t=78276

or my

http://www.murga-linux.com/puppy/viewtopic.php?t=79207

___________________________________


I would like the full range of the right click all functions if possible

Cheers
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 7 of 11 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0967s ][ Queries: 13 (0.0061s) ][ GZIP on ]