Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 13:04
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
How to use eGalaxTouch USB controller in Slacko?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 14 Aug 2012
Posts: 2

PostPosted: Tue 14 Aug 2012, 18:23    Post_subject:  How to use eGalaxTouch USB controller in Slacko?  

Please for the love of god, I beg for help.

I have a USB eGalaxTouch Controller (USB) and I am unable to get it working correctly in Slacko.

This is the driver:

I tried THAT and I got the error:

(E) No /etc/rc.local file found
(E) The driver archive has been removed already.

So..... I then tried this driver (X Window Only)

This one sorta works, I do get a touch response but the Calibration Utility 4 Point test does NOT work, it just sits there and won't take a response.

I assume I need evtouch .so drivers but what ones for this version of linux?
Back to top
View user's profile Send_private_message 

Joined: 29 Jan 2006
Posts: 3629
Location: Sydney Australia

PostPosted: Tue 14 Aug 2012, 23:28    Post_subject:  


Welcome to Puppy mate.

You need to give us the exact Puppy Slacko version.
We have a mammoth collection now....OK!


Slacko - next cycle -alpha...maybe link your post there.

Slacko updated here by 01micko.


A bit hard to see your product.


QNX Neutrino RTOS V6.3 >> different to what you describe.




Ubuntu....read on


" Re: eGalaxTouch touchscreen clicks on second tap
Solved with ubuntu 10.04
[not sure, but it might work with earlier versions.]

Without installing the eGalaxTouch support I got everything working great with default evdev setup in ubuntu 10.04 adding these commands to fix the old problems with rotation / swapped axes. Correct tap behaviour was present out-of-the-box. "


" Are you affected by this issue?

Let’s start by saying that the eGalax Touch Screens made by EETI

uses a Touch Resistive Panel Controller

(it can be capacitive but most UMPC and Tablet PC use the

Resistive one) that can be connected using 3 different interfaces:

USB (Hardware ID: USB\VID_0EEF&PID_0001 or

USB\VID_0EEF&PID_0002), RS232 (Hardware ID: SERNUM\EGX5800,


SERNUM\EGX5803) and PS/2 (Hardware ID: *PNP0F13). "



Back to top
View user's profile Send_private_message 

Joined: 14 Aug 2012
Posts: 2

PostPosted: Wed 15 Aug 2012, 02:12    Post_subject: Slacko and eGalaxTouch  

It works fine in Ubuntu, so it's not a controller problem itself.

The Slacko version I have is 5.3.3
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0439s ][ Queries: 12 (0.0044s) ][ GZIP on ]