Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 20 Aug 2014, 16:28
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.4.12 with 3.4.2 kernel.
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 69 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 67, 68, 69, 70, 71, ..., 87, 88, 89 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 10 Aug 2012, 01:31    Post subject:  

Thanks Jim1911. I will look into bibletime problem. I suspect that /etc/profile.d qt location definition has something to do with it. I remember removing it because the previous definition file interfered with aclocal when compiling with automake. I am afraid I didnt remember to fix it. It might be missing.

Just hunch. Little busy next days...lets see what I can do.

About mplayer - mplayer2. I think I switch to mplayer. I tested now...inspired by 01micko compiling mplayer using external ffmpeg which is in dpup 1.11 version from git. I have recent x264 and libvpx compiled from source. So....I want to see if my 1.2 - 1.3 Mb mplayer pet with external ffmpeg is good.
I havent compiled mplayer for a year now...so it will take some time before I have done my learning in ./configure and cpu tuning.

Last edited by pemasu on Fri 10 Aug 2012, 09:58; edited 1 time in total
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5708
Location: Kentucky

PostPosted: Fri 10 Aug 2012, 01:56    Post subject:  

Downloaded and installed the latest Mplayer build (mplayer-svn09082012.pet) to the frugal install on my Athlon XP box.Plays everything in my video/audio comparison directory........ mp4,wmv,avi,mov,mpg,rm,flv and mkv as well as mp3 and ogg audio.So, looks good here. Smile
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 10 Aug 2012, 10:01    Post subject:  

Thanks James C. I have noticed that if your athlon XP box digests mplayer, then all the rest cpu`s is no problem. Lol.
So your report is encouraging. Also...it seems that media format coverage is good. My tests has been as good.
Back to top
View user's profile Send private message 
ssanubis

Joined: 10 Aug 2012
Posts: 9

PostPosted: Fri 10 Aug 2012, 17:18    Post subject:  

pemasu, I was wondering if there were any plans on adding a catalyst sfs files to your repo? You already have the "xorg high" and nvidia drivers is your repo, but not ati/amd. I ask because, for portability sake, having these as mountable/unmountable sfs is absolutely amazing. If not I would certainly appreciate some help in making one myself. I keep a verbatim 16 GB on my keychain and take it EVERYWHERE since I travel alot for work and I have recently started testing out dpup exprimo and so far I'm really diggin' it, but the lack have having all my video drivers as mountable sfs files is a bit of a turn off, lol.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 10 Aug 2012, 17:42    Post subject:  

Ati driver with its needed extra patching is a bit pain to compile. I have compiled ati/amd driver...but since my ati dual graphics does not work quite well, I dont use it. In fact I get often total freezing of my laptop when I try to load the fglrx.ko kernel module...I am bit reluctant to compile it. I need to do hard shutdown with power button and I fear my ext4 file system will suffer. I have so much important stuff that I try to avoid hard shutdown as much as I can.

So...I am afraid someone with better working ati graphics should do the job. But probably the need for manual patching gets the compiling more difficult for average user.

So...I could compile it....manually gather the installed stuff...make a pet of the result...but cant know if the result is good because I dont want to load it.

When and if ati makes the source 3.4.2 kernel compliant...it would be easier for people to compile it themself. That would be the recommended way. There is no ati driver automatic compile pet for puppies like there is Shinobar`s getnvidia pet which creates nvidia driver pet automatically.
If and when ati fglrx.ko kernel module can be compiled straight without manual patching process...there is hope that someone like Shinobar could create samekind ati driver automatic creation pet. I will follow if ati announces kernel 3.4.2 compliant driver and I will post the guide how to compile it yourself.
Back to top
View user's profile Send private message 
ssanubis

Joined: 10 Aug 2012
Posts: 9

PostPosted: Fri 10 Aug 2012, 20:59    Post subject:  

Alright, I guess it's something I'll just have to deal with for the time being. I do understand that ATI drivers have never been the easiest to deal with at times, and most systems I encounter are Intel, so the ones I come across that are ATI I will just have to endure the limitations. Most applications work fine with the open source drivers anyway, it's just when I feel like goofing off with games that they fall short, LOL. I appreciate the reply.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 11 Aug 2012, 06:46    Post subject:  

My trial with mplayer-svn using external ffmpeg. The size is so small I can attach it here.
As previous...if you test it and it works...you could post feedback.
mplayer-svn11082012.pet
Description 
pet

 Download 
Filename  mplayer-svn11082012.pet 
Filesize  1.06 MB 
Downloaded  138 Time(s) 
Back to top
View user's profile Send private message 
irishrm


Joined: 14 Mar 2009
Posts: 210

PostPosted: Sat 11 Aug 2012, 11:18    Post subject:  

pemasu:

Sorry to always having,as we say here "the bad word" but your latest mplayer didn't work for me. Again I had sound and a black screen. x11 works for me in vlc.

Could something like that be a factor in my case?

irishrm.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 11 Aug 2012, 12:05    Post subject:  

Irishrm. Sure you can change the default video output from xv to x11 in mplayer. Install this pet. It adds /etc/mplayer/mplayer.conf file which has vo=x11 (video output changed to x11 instead of default xv) as default video output. You can change it also as xv,x11,sdl in that file or whatever you want to test...I havent though enabled all possible video outputs. Just open the file and edit it...
mplayer.conf accepts tons of options
mplayer-conf-for-x11.pet
Description 
pet

 Download 
Filename  mplayer-conf-for-x11.pet 
Filesize  1.74 KB 
Downloaded  117 Time(s) 
Back to top
View user's profile Send private message 
irishrm


Joined: 14 Mar 2009
Posts: 210

PostPosted: Sat 11 Aug 2012, 13:33    Post subject:  

pemasu:

Glad to report success.

Your mplayer x11.pet worked. Sopcast and streamplay tv are now working.

Thanks for your Resistance.

If there is anything you want me to test please let me know.

irishrm.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 11 Aug 2012, 13:46    Post subject:  

Thank your Irishrm of your stubborn testing. I would like to know if you edit the mplayer.conf file to have vo=xv,x11
would it automatically find that xv output is not good for you and switch to x11
If it would switch and work that way...I could include mplayer.conf file to distro and one mplayer problem would have been fixed.
Back to top
View user's profile Send private message 
irishrm


Joined: 14 Mar 2009
Posts: 210

PostPosted: Sat 11 Aug 2012, 15:41    Post subject:  

pemasu:

When I added xv mplayer reverted to the black screen. It also crashed the computer and I had to use ctrl/alt/backspace to re-start.

Just one other problem:

Mplayer opens in a small window. When I try to go to full screen I still get the small screen with a wide black surround.

Could I change the config file to get a proper full screen.

irishrm.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 11 Aug 2012, 15:46    Post subject:  

Irishrm. That is the problem with x11. Using xv is the solution I know. I think you have problem with your graphics in dpup exprimo. I suppose you use intel driver....I remember when i checked your sys-info report. That is the right driver for you, vesa driver could have created problems also, but you dont use it. So...I dont have more solutions atm.
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4365
Location: Southeast Georgia, USA

PostPosted: Sat 11 Aug 2012, 15:46    Post subject:  

Moved to 5x14 thread ...
_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602

Last edited by edoc on Sat 11 Aug 2012, 16:47; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
irishrm


Joined: 14 Mar 2009
Posts: 210

PostPosted: Sat 11 Aug 2012, 16:44    Post subject:  

pemasu:

I,m more than happy with the result. Mplayer is working and I learned a little along the way.

I am looking forward to trying out your next puppy project which I,m sure is already under way.

Thanks again for your help.
irishrm.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 69 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 67, 68, 69, 70, 71, ..., 87, 88, 89 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1028s ][ Queries: 13 (0.0305s) ][ GZIP on ]