Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 28 Jul 2014, 23:04
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Nvidia drivers
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 5 [68 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
shinobar


Joined: 28 May 2009
Posts: 2598
Location: Japan

PostPosted: Fri 13 Apr 2012, 00:50    Post subject: nvidia-glx-sdl-295.40  

nvidia-glx-sdl-295.40.sfs (UPDATE: 2012-04-13)
http://shino.pos.to/party/bridge.cgi?puppy/opt/
For major Puppies 4.3 and later except Slacko (nvidia-glx + libGLU and SDL)
  • Puppy-431 with kernel 2.6.30.5
  • All Wary up to 5.3 with kernel 2.6.31.14, 2.6.32.28, 2.6.32-smp, or 2.6.32-uni, 2.6.32.59
  • Racy 5.2.2/5.3 with kernel 3.0.7 or 3.0.25
  • All Lucid Puppy with kernel 2.6.33.2
  • Dpup Exprimo with kernel 2.6.39, 3.1.10-dpup, or 3.2.14-dpup
  • Saluki-15 and later with kernel 2.3.8-ski

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 1369
Location: Malvern, Worcs, UK

PostPosted: Mon 23 Apr 2012, 02:26    Post subject: Re: nvidia-glx-sdl-295.40  

shinobar wrote:
nvidia-glx-sdl-295.40.sfs (UPDATE: 2012-04-13)
For major Puppies 4.3 and later except Slacko (nvidia-glx + libGLU and SDL)


Hi Shinobar

Do you have any plans to update your slacko sfs to 295.40 on k3.1.10 please? I seem to need it for my new desktop to make the display correct.

If not, could you say how to make it and I'll gladly try to do it for you.

I have downloaded the Nvidia source and compiled and installed it OK on Slacko 5.3.2.8 but it uses up lots of savefile that way and i'd much prefer to have an sfs.

Many thanks
peebee

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2598
Location: Japan

PostPosted: Mon 23 Apr 2012, 19:55    Post subject: nvidia-glx-sdl-295.40-slacko.sfs  

OK, try nvidia-glx-sdl-295.40-slacko.sfs
for slacko with kernel 2.6.37.6, 2.6.39.4, 3.1.10-slacko_4gA, or 3.1.10-slacko_paeA.
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/

Load, but do not run the nVidia Settings at this point of time, just exit the sfs_load, and run xorgwizard or reboot PC following the coming message.
Slacko 5.3.1 may need not reboot PC, go straight to the xorgwizard.
Slacko 5.3.3 beta may need to reboot PC before the xorgwizard.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Last edited by shinobar on Tue 24 Apr 2012, 23:49; edited 3 times in total
Back to top
View user's profile Send private message Visit poster's website 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Mon 23 Apr 2012, 20:11    Post subject:  

Shinobar,

Great work on the Nvidia drivers, but I just wanted to inform you that according to Phoronix, there have been a lot of issues with the 295.40 Nvidia driver.

http://www.phoronix.com/scan.php?page=news_item&px=MTA4ODQ

Hopefully Nvidia will get it sorted out soon.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1369
Location: Malvern, Worcs, UK

PostPosted: Tue 24 Apr 2012, 02:32    Post subject: Re: nvidia-glx-sdl-295.40-slacko.sfs  

shinobar wrote:
OK, try nvidia-glx-sdl-295.40-slacko.sfs
for slacko with kernel 2.6.37.6, 2.6.39.4, 3.1.10-slacko_4gA, or 3.1.10-slacko_paeA.


Thank you Shinobar - much appreciated - have downloaded and installed.

It seems to be working OK, but I think I'm a bit surprised at how low glxgears is reporting the frame rate - although I've nothing to compare it against for this new pc with nVidia Corporation C61 [GeForce 7025 / nForce 630a].

Thanks again.
peebee
glxgears.png
 Description   
 Filesize   81.12 KB
 Viewed   2836 Time(s)

glxgears.png


_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
elcurita

Joined: 09 Jun 2009
Posts: 25

PostPosted: Thu 26 Apr 2012, 20:02    Post subject: humble request
Subject description: nvidia geforce fx5200
 

Shino: Looks like saluki is keeping the 3.2.8 kernel.Would you consider building a sfs for the Nvidia GeForce FX 5200? .I try to compile it myself but I failed misserabily. Thank you for all you do for the puppy comunity.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2598
Location: Japan

PostPosted: Thu 26 Apr 2012, 21:16    Post subject: Re: humble request
Subject description: nvidia geforce fx5200
 

elcurita wrote:
Would you consider building a sfs for the Nvidia GeForce FX 5200?

No.
GeForce FX 5200 is said to be supported by 173.14.xx driver, but I have not old cards to confirm.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
greengeek

Joined: 20 Jul 2010
Posts: 2407
Location: New Zealand

PostPosted: Thu 26 Apr 2012, 21:56    Post subject:  

Just adding a comment so I can get this important topic on my list (don't know of any other way to click "follow this topic").
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1369
Location: Malvern, Worcs, UK

PostPosted: Mon 07 May 2012, 07:01    Post subject:  

glxgears gives a much "better" result on my system using the new 295.49 sfs that shinobar has posted on page 1....

thanks shinobar
glxgears.png
 Description   
 Filesize   67.34 KB
 Viewed   2700 Time(s)

glxgears.png


_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2598
Location: Japan

PostPosted: Mon 28 May 2012, 04:01    Post subject: nvidia-glx-sdl-295.53  

[list][*]For some Puppies 4.3.x, Lupu, Wary-5.1.1, Wary/Racy-5.3 (nvidia-glx + libGLU and SDL)
  • Puppy-431 with kernel 2.6.30.5
  • Wary 5.1.1/5.3 with kernel 2.6.32.28, 2.6.32.59
  • Racy 5.3 with kernel 3.0.25
  • All Lucid Puppy with kernel 2.6.33.2

nvidia-glx-sdl-295.53.sfs (UPDATE: 2012-05-28)
http://shino.pos.to/party/bridge.cgi?puppy/opt/

Load and run the xorgwizard.
This package does not have glxgears. Install 'mesa-utils' or proper package if you want.

[*]For Slacko 5.3.3 with kernel 3.1.10-slacko_4gA, or 3.1.10-slacko_paeA. . (contains glx, OpenGL and SDL)
nvidia-glx-sdl-295.53-slacko.sfs (Update: 2012-05-28)
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2598
Location: Japan

PostPosted: Fri 22 Jun 2012, 01:53    Post subject: ]nvidia-glx-295.59.sfs / getnvidia-0.2  

Updated nvidia-glx-295.59.sfs
New getnvidia-0.2.pet, SFS/PET builder.
http://shino.pos.to/party/bridge.cgi?puppy/opt/
See the top post for the deatail.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
rob_0126

Joined: 10 Jul 2012
Posts: 16

PostPosted: Tue 10 Jul 2012, 12:10    Post subject:  

Hey folks. Im new to posting but have used puppy on and off for a few years.

I am having a problem with loading nvidia drivers for a geforce fx 5900 xt.
I am using puppy lucid 5.2.8 and tried the 174. drivers and, using an Acer 173 lcd monitor @1280x1024 res.

the generic drivers have the screen offset to the rt a bit.

If i install the nvidid 174. pup in the lucid repository, and after, i restart x server, it drops to prompt i have to use xorgwizard to unld driver because it wont load.


i also have this problem when i switch wm from openbox to xfce(installed wm). in that scenario, xorgwizard wont even run and have to hard reboot. Scrren centers correctly in xfce if I change refresh from 60 to 75(top edge is off a hair)

Is that the right driver for my vid card?
Does the xfce 4.6 wm in lucid repository trouble nvidia driver?

This is the only problem im having in puppy 5.2.8, getting the nvidia driver to take.
(I do get the error in the nvidia server settings that the driver isn't being used)
Thanks

Btw, precise puppy beta generic driver loads screen correctly.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2598
Location: Japan

PostPosted: Sat 14 Jul 2012, 18:27    Post subject: getnvidia-0.6  

UPDATE: getnvidia-0.6.pet See the top post.
# 14jul2012: remove old nvidia driver in the backup, fix flash install

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Scooby

Joined: 03 Mar 2012
Posts: 288

PostPosted: Tue 31 Jul 2012, 13:03    Post subject: Nvidia Optimus  

I want to ask you shinobar since you seem to be something of an expert
on Nvidia drivers.

I want to run Bumblebee on puppy linux!

Bumblebee is a program that enables nvidia optimus technology to be used in Linux. There is compiled versions for ArchLinux, Ubuntu and Mandriva.
see
http://bumblebee-project.org/


Is there a puppy linux distro that you think could run any of these?

Could it be compiled for any puppy linux distros? For me it is not so important what puplet Im runnin. Have been running Lucid, Slacko,DPUP Exprimo and Fatdog


Please help, I'm a noob in Linux but has knowledge with windows programming(And I'm very tired of anything from M$ )

PS If it doesnt work with puppy linux which of ArchLinux, Ubuntu and Mandriva is easiest to get on a usb flash drive?
Back to top
View user's profile Send private message 
charlie6

Joined: 30 Jun 2008
Posts: 992
Location: South of Belgium

PostPosted: Tue 21 Aug 2012, 10:52    Post subject: nvidia driver built on 2.6.39.4 dpupu 5X15  

Hi shinobar,
many thanks for the getnvidia-0.6.pet;
here got a try on a compaq evo 510 PIV + Nvidia GeForce2 NV11DDR (personal save file was 768MB) MX200 graphic pci card:
I managed to built a nvidia driver in dpup-exprimo 5X15 (all seemed to go well as i got "OK check" for all prerequisites, and finally got .pet and .sfs nvidia driver archives.
results:
see my 2 posts on page 142 here
http://www.murga-linux.com/puppy/viewtopic.php?t=70399&start=2115

other tets:
installed the nvidia-glx-sdl-295.40.sfs , and got the same warnings as above.

So i'm wondering what should be missing
Thanks in advance for any help
Charlie
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 5 [68 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1205s ][ Queries: 13 (0.0400s) ][ GZIP on ]