Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 23:07
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Desura - Linux games portal
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
666philb


Joined: 07 Feb 2010
Posts: 1883
Location: wales

PostPosted: Sat 03 Mar 2012, 11:07    Post_subject:  Desura - Linux games portal
Sub_title: linux equivalent to steam
 

desura is kind of like the linux equivalent to steam. a games portal where you can download and install linux games. some games are free and some are paid for.

the clever thing is that it downloads the games and it dependencies to the desura folder and runs the game from there, using the library path inside the folder.

you can download desura here http://www.desura.com/

you'll get a root warning but just ignore it

make sure that the desura folder is on the harddrive and not in /root/

In slacko you'll also need thishttp://repository.slacky.eu/slackware-13.37/libraries/ORBit2/2.14.19/ORBit2-2.14.19-i486-1.txz

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642

Edited_time_total
Back to top
View user's profile Send_private_message 
wsamh

Joined: 16 Apr 2010
Posts: 79

PostPosted: Tue 24 Jul 2012, 14:54    Post_subject:  

I installed it in puppy linux 5.3.3. But only one game that I have installed works. Like when I try to start urbanterror, I get this in the terminal:

ioQ3 1.35urt linux-i386 Dec 20 2007
----- FS_Startup -----
Going through search path...

----------------------
10593 files in pk3 files
execing default.cfg
couldn't exec q3config.cfg
execing autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
QGL_Init: Can't load libGL.so.1 from /etc/ld.so.conf or current dir: No dynamic GL support in video driver
failed
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem
Back to top
View user's profile Send_private_message Visit_website 
hollywood

Joined: 21 Jul 2012
Posts: 13

PostPosted: Tue 24 Jul 2012, 17:06    Post_subject:  

You probably need this:

http://code.google.com/p/mywolfe/downloads/detail?name=libGL.so.1.pet&can=2&q=

Of course there is a good chance that once you install that, it will want something else. Such is the nature of gaming I have found. I will just keep searching for whatever libs it tells me it needs until the program finally works. So far Puppy handles it just fine, and you can install .deb files, so things that are only meant for Ubuntu or Debian will work on Puppy.
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1883
Location: wales

PostPosted: Wed 25 Jul 2012, 04:48    Post_subject:  

you'll need to install your graphic drivers, in slacko 'slickpet'>>'drivers'>>>'test' and install what it suggests.
_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
Eldon

Joined: 09 Sep 2010
Posts: 110

PostPosted: Thu 26 Jul 2012, 13:36    Post_subject:  

This looks neat but...
Any idea what's up with this?

The console in desura said:
12:26 Failed to load cef library: 11
12:26 CEF_CreateCookie is NULL. Failed to set cookies. Sad
12:26 DS: Version: 0.0.3.38
12:26 Failed to load cef library: 0
12:26 Failed to load cef library: 0
12:39 Failed to load cef library: 11
12:39 Failed to load cef library: 11

And the main page is blank, presumably as a result of the above.

[/img]

Seemed to install just fine.
Running the latest version of Slacko.
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1883
Location: wales

PostPosted: Sun 29 Jul 2012, 04:39    Post_subject:  

hi Eldon,
in slacko you'll need this http://repository.slacky.eu/slackware-13.37/libraries/ORBit2/2.14.19/ORBit2-2.14.19-i486-1.txz
it should work then

i'll amend the first post

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
wsamh

Joined: 16 Apr 2010
Posts: 79

PostPosted: Sun 29 Jul 2012, 14:00    Post_subject:  

all it says that it recommends mesa to be installed. But I have mesa installed with my nvidia driver. And it still not working.
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1883
Location: wales

PostPosted: Sun 29 Jul 2012, 14:59    Post_subject:  

hi wsamh

what puppy are you using?

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
wsamh

Joined: 16 Apr 2010
Posts: 79

PostPosted: Sun 29 Jul 2012, 23:17    Post_subject:  

slacko 5.3.3
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1883
Location: wales

PostPosted: Mon 30 Jul 2012, 08:15    Post_subject:  

in slacko you also need this http://repository.slacky.eu/slackware-13.37/libraries/ORBit2/2.14.19/ORBit2-2.14.19-i486-1.txz
_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
Eldon

Joined: 09 Sep 2010
Posts: 110

PostPosted: Mon 30 Jul 2012, 21:36    Post_subject:  

Thanks, but unfortunately it's still blank. Maybe it will work once I restart.
On installing it also says I'm missing the following dependencies:

SDL_gfx

SDL_mixer-Smpeg

Could that be the problem?

I have SDL installed, including the LibSDL1.2-forDoom package, as well as the SDL image, ttf, mixer, net, mixerDEV along with the SDL-1.2.14-i486 library.

I've no idea where to find those two.

Thanks!
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1883
Location: wales

PostPosted: Tue 31 Jul 2012, 03:55    Post_subject:  

hi eldon

i just tested on a completely fresh slacko,
1. clicked on http://repository.slacky.eu/slackware-13.37/libraries/ORBit2/2.14.19/ORBit2-2.14.19-i486-1.txz and saved it. then opened the folder where it's saved and clicked on it to install

2. installed desura

3. working fine, nothing else installed

are you sure the ORBit package is installed and not just saved?
and how are you starting desura? use the script in the desura folder.

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
Eldon

Joined: 09 Sep 2010
Posts: 110

PostPosted: Wed 01 Aug 2012, 12:36    Post_subject:  

666philb wrote:
hi eldon

i just tested on a completely fresh slacko,
1. clicked on http://repository.slacky.eu/slackware-13.37/libraries/ORBit2/2.14.19/ORBit2-2.14.19-i486-1.txz and saved it. then opened the folder where it's saved and clicked on it to install

2. installed desura

3. working fine, nothing else installed

are you sure the ORBit package is installed and not just saved?
and how are you starting desura? use the script in the desura folder.


That doesn't make sense- you loaded slacko with no save file etc. and it worked with orbit and nothing else?

Yes, I have Orbit is installed, and yes, I'm using the script in the folder to start it.



And this is a shot of the console:



Obviously I need to find the cef library whatever that is and see if that fixes it.

Does it have this message on yours?
Back to top
View user's profile Send_private_message Visit_website 
Eldon

Joined: 09 Sep 2010
Posts: 110

PostPosted: Wed 01 Aug 2012, 12:43    Post_subject:  

Did you install chromium?

The CEF library- CEF stands for "Chromium Embedded Framework".
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1883
Location: wales

PostPosted: Wed 01 Aug 2012, 12:59    Post_subject:  

i'm at a loss.....

works for me on a slacko with no save, and nothing but orbit installed. (no chromium or anything else)
I think that the desure interface maybe chrome based

i have an nvidia card so the open source drivers get loaded automatically. so it's possibly something to do with graphics drivers. That or your internet connecton.

i do get a few warnings in the terminal, but not like yours. just about not being able to find a libs version number. but still works.

can you try it on lucid puppy and see if you get the same result

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0755s ][ Queries: 13 (0.0049s) ][ GZIP on ]