Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 18:14
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.4.12 with 3.4.2 kernel.
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 47 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 45, 46, 47, 48, 49, ..., 87, 88, 89 Next
Author Message
James C


Joined: 26 Mar 2009
Posts: 5939
Location: Kentucky

PostPosted: Sun 08 Jul 2012, 17:54    Post subject:  

Fresh manual frugal install of 5.X.3.4.2.4 on the old Athlon XP box. Everything looking good as expected. And no problem creating an ext4 savefile on an ext3 hdd partition.

Code:
# free
             total         used         free       shared      buffers
Mem:       1033808       479852       553956            0        56468
-/+ buffers:             423384       610424
Swap:      1228936            0      1228936
#
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Sun 08 Jul 2012, 17:58    Post subject:    

Your new 5.X.3.4.2.4 is working great on my hardware with my usual software. No problem with savefile on first shutdown although I installed Shinobars latest Pupsaveconfig pet first. Very Happy

Please link your fine Bibletime 2.9.1.pet with dependencies to the puppy-dpup repository in the Puppy Package Manager to make your program easier to find and install.

Thanks for your continuing updates to Exprimo. Very Happy

Cheers,
Jim
image-1.jpg
 Description   
 Filesize   45.84 KB
 Viewed   835 Time(s)

image-1.jpg

Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 08 Jul 2012, 18:13    Post subject:  

Bibletime is already in exprimo repo. You just need to hit configure manager in PPM and restart it so that exprimo repo shows. Exprimo is already ticked and is untickable state, but I dont know what I should do with scripts so that it shows at the first launch.
bibletime-is-in-exprimo-repo-just-activate-it.jpg
 Description   
 Filesize   61.62 KB
 Viewed   833 Time(s)

bibletime-is-in-exprimo-repo-just-activate-it.jpg

Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 08 Jul 2012, 18:23    Post subject:  

People might wonder what is that dpup-official repo. Well...it is my personal backup of Iguleders work at Guy dog time. From previous experience....I had suspicion that the repo might disappear so I had backed up the whole repo. When the repo vanished...some users asked in guy dog thread where is it and so...I uploaded my backup to the smokey01.com. I created the Packages-puppy-dpup-official database file by extracting every damn pet ( 433 pets !!! ) and copied the pet.specs content to the file which became the database file. Why that...Igulders builds came without database files. You had to update the PPM by downloading them from the net repo....which didnt exist anymore....Then I added the repo also to my dpup exprimo....because most pets are straight usable...if you install possible dependent pets. I use that repo also when I download stuff to the new woof. You could call it useful repo when building. It has a lot core system stuff which Iguleder compiled in his dpups. Straight from source.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Sun 08 Jul 2012, 18:43    Post subject:  

pemasu wrote:
Bibletime is already in exprimo repo. You just need to hit configure manager in PPM and restart it so that exprimo repo shows. Exprimo is already ticked and is untickable state, but I dont know what I should do with scripts so that it shows at the first launch.
I should have checked that. Embarassed
image-3.jpg
 Description   
 Filesize   31.12 KB
 Viewed   802 Time(s)

image-3.jpg

Back to top
View user's profile Send private message 
Terry H

Joined: 29 Mar 2009
Posts: 87
Location: Pickering, ON Canada

PostPosted: Sun 08 Jul 2012, 19:51    Post subject:  

Sorry, but no joy when using the pupsave pet.

I removed the save file and downloaded shinobar's pupsave config 2.2.4 pet.
I then rebooted into exprimo, installed the pet and executed it to create a savefile.

On shutdown save file created, then when the process was attempting to save it, it crashed. The following is some of the error output:

[549.689948] Pid:27353 comm. mount-FULL Tainted


[549.689948] Call Trace....
.
.
.

I then had to hard shutdown.


Edit: I checked and found that the save file was in fact created. I logged in successfully and it was read. I still could not get wifi working.
I am now stopping for the night.
Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 466

PostPosted: Sun 08 Jul 2012, 23:10    Post subject:  

pemasu wrote:
Bibletime is already in exprimo repo. You just need to hit configure manager in PPM and restart it so that exprimo repo shows. Exprimo is already ticked and is untickable state, but I dont know what I should do with scripts so that it shows at the first launch.

Hi pemasu,

The exprimo-official repository does not appear in the Puppy Package Manager on first run because of a small initial error in /root/.packages/PKGS_MANAGEMENT (Details in your PM).

Thanks
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Mon 09 Jul 2012, 00:08    Post subject:  

Ummm...can someone please tell me why dropbox keeps crashing?
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Mon 09 Jul 2012, 00:33    Post subject:  

....Dropbox aside, this version of Dpup is awesome!!!!

Though I did notice that gecko-mediaplayer wasn't installed. That doesn't matter cause I installed VLC and it's plugin and both work awesome.

Pemasu, I had to install the pet from this forum thread because something is wrong with the vlc plugin in PPM. It gives errors downloading.

I'm uninstalling gnome-mplayer.

It's true that vlc uses up more ram the gnome-mplayer but the features are worth it for me and my old box can take it.

Anyway, I compiled the newest Dooble web browser in Dpup and it runs great. I think I did a better job stripping the pet and reorganizing it.

Though it's a browser so you can't do much to it.

I couldn't get it uploaded to the site so I just dropboxed it. You need qt 4.8.0 to run it. Enjoy.
http://db.tt/tIjnEiHM
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5939
Location: Kentucky

PostPosted: Mon 09 Jul 2012, 01:55    Post subject:  

Not too shabby resource usage.
5.X.3.4.2.4.png
 Description   
 Filesize   16.11 KB
 Viewed   700 Time(s)

5.X.3.4.2.4.png

Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 09 Jul 2012, 03:10    Post subject:  

Dpup 5.X.3.4.2.4 reuploaded as fixed version.

Just download it....no need to read the below...if you just want the fixed version. Lol.

Download link: http://smokey01.com/pemasu/DpupSqueeze5X/DpupExprimo5X3424/

Radky. You nailed it !!! Thank you. Now I know how to control what there is enabled at initial PPM launch. Thanks. I have searched several scripts...and hacked .3builddistro script...but that file was the crucial one. Manually editing it gives you control what there will be in the first launch. Really great. I dont know how those typos does appear there...but who cares, lol. Now I know how to fix them.

About savefile non-creation problem. I would like to get more information of the error texts. For example pic of the screen and upload the error text pic here. Also what type of filesystem is the target and to what media has the save file creation been targeted: hdd, usb-hdd, usb-stick, sd card.....It might be that the certain type of filesystem ie ntfs or certain media gives the problem. I need to pinpoint the main problem. I cant try to fix the problem without knowing which causes it. Because for me it works. I will start to inspect the problem myself also.

Mount-full has these straight dependencies. I need to check if one of them has changed compared to my old builds:
Quote:
Information to Application: mount-FULL
linux-gate.so.1 => (0xffffe000)
libblkid.so.1 => /lib/libblkid.so.1 (0xb7747000)
libuuid.so.1 => /lib/libuuid.so.1 (0xb7743000)
libselinux.so.1 => /lib/libselinux.so.1 (0xb7727000)
libsepol.so.1 => /lib/libsepol.so.1 (0xb76f2000)
libc.so.6 => /lib/libc.so.6 (0xb75ad000)
/lib/ld-linux.so.2 (0xb7765000)
libdl.so.2 => /lib/libdl.so.2 (0xb75a9000)

Gnuxo. Thank you of important bug report. There was gecko-mediaplayer....but it was the incompatible older one. I havent removed the older version from woof database and so it was selected instead of the newer one. Fixed. Now there is the right one.

About vlc-mozilla-plugin. It is now included in the vlc-2.0.1 which has been uploaded to the exprimo repo. The new recompiled version replaced the older one. The vlc-mozilla-plugin which is in repo might also work, but I havent tested. It was compiled against the older vlc devel files. I will remove it soon and update the database file, but I didnt remember to do that for this fixed release.

I have woofed, built and I have reuploaded the fixed 5.X.3.4.2.4 .

It has the fixed guvcview, fixed gecko-mediaplayer and the PPM repos are what I liked them to be.

Download link: http://smokey01.com/pemasu/DpupSqueeze5X/DpupExprimo5X3424/
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 09 Jul 2012, 03:16    Post subject:  

Terry H. What kind of wifi you have. If you type in console: lspci -nn > lspci.text.gz and upload it to the forum, I get the specs or your wifi.
Back to top
View user's profile Send private message 
feelsub

Joined: 20 Jun 2012
Posts: 39

PostPosted: Mon 09 Jul 2012, 05:40    Post subject:  

Tested 5.X.3.4.2.4 with 3.4.2 kernel.

Excellent work: upto date : ntfs, ffmpeg, VLC.

Now: with puppy exprimo, lost links with
* abiword286-gnumeric
* skype 4.0

For Mplayer same issue as with previous version:
Code:
# mplayer "/mnt/sda2/Documents and Settings/Angel/Mes documents/test/bachata.flv"
MPlayer2 f63dbad (C) 2000-2012 MPlayer Team

Playing /mnt/sda2/Documents and Settings/Angel/Mes documents/test/bachata.flv.
Detected file format: FLV format (libavformat)


MPlayer interrupted by signal 4 in module: demux_open
- MPlayer crashed by an 'Illegal Instruction'.
  It usually happens when you run it on a CPU different than the one it was
  compiled/optimized for.
  Verify this!
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
#


Not problem with the newly build VLC.

FYI:
LibreOffice 3.5 installs correctly, but for once under the graphics menu.
LibreOffice 3.6 should at last (I haven't tested yet) bring some major speed improvements.

Abiword 2.9.0 successfully install.
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Mon 09 Jul 2012, 07:10    Post subject:  

Hi Pemasu,
Unfortunately the save file problem still persists for me - installed the pusaveconfig-2.2.4-dpup.pet and used the desktop save GUI to create a 256mb .4fs save file - during the shut down process it creates a save file then hangs requiring a hard shut down - during this a screen full of messages appear - i will do a fresh install later today and take a picture on my phone of these messages.

Saving to sda1 - which is ext4 partition.
Grub2 install code:
Code:
menuentry "Exprimo squeeze-5.X.3.4.2.4-SCSI" {
        set root='(hd0,1)'
        linux /squeeze-5.X.3.4.2.4-SCSI/vmlinuz pmedia=atahd psubdir=squeeze-5.X.3.4.2.4-SCSI
        initrd /squeeze-5.X.3.4.2.4-SCSI/initrd.gz
}
 


Creating an empty .3fs save file with SimpleSave then booting with that works ok - wifi is detected and works on second boot.

cheers.

EDIT:
Please see attached images of messages during save file creation - sorry for the not very good quality as the were taken with my shaky hands on a camera phone :

First get image 1 - then it creates a save file - then image 2 where it hangs and i have to hard shut down.
A save file is created but i do not know however if this is perhaps corrupted?


http://i.imgur.com/4iSaw.jpg


http://i.imgur.com/Zxrel.jpg
Back to top
View user's profile Send private message 
Terry H

Joined: 29 Mar 2009
Posts: 87
Location: Pickering, ON Canada

PostPosted: Mon 09 Jul 2012, 15:43    Post subject:  

pemasu wrote:
Terry H. What kind of wifi you have. If you type in console: lspci -nn > lspci.text.gz and upload it to the forum, I get the specs or your wifi.


pemasu,

With all the discussion about bcm43 I didn't include that information. Sorry, I should have said I have Broadcom 4311 Wifi 802.11a/b/g.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 47 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 45, 46, 47, 48, 49, ..., 87, 88, 89 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1191s ][ Queries: 13 (0.0233s) ][ GZIP on ]