Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 01:23
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to turn off DMA when booting Puppy? (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
wolle

Joined: 13 May 2005
Posts: 1
Location: Germany

PostPosted: Fri 13 May 2005, 16:03    Post subject:  How to turn off DMA when booting Puppy? (Solved)  

I got a problem booting PUPPY on an old DELL Notebook (Latitude CPi);
it seems, the harddisk is not accessible via DMA. Is there a means to give a cheatcode like "nodma" in KNOPPIX ?
Back to top
View user's profile Send private message 
Guest
Guest


PostPosted: Fri 13 May 2005, 18:29    Post subject:  

I've got a Dell Latitude CPi D300XT and have no probs with DMA, the biggest prob is the Evil NeoMagic graphics chip
Back to top
nrormanw
Guest


PostPosted: Sat 14 May 2005, 14:07    Post subject: Neomagic Problem  

Have you fixed the problem ? I have those graphic problems on another pc working with neographic chip ! Will these problems been solved with the final release 1.0.2 we are expecting in the near future ?
Back to top
guest
Guest


PostPosted: Thu 24 Nov 2005, 14:32    Post subject: dma issue  

Has anyone solved this issue? Is there any way of turning off dma while booting from the Puppy CD(V1.06)?

Mark
Back to top
gnomen


Joined: 11 Jul 2005
Posts: 65
Location: NORWAY

PostPosted: Thu 24 Nov 2005, 19:45    Post subject:  

You can probably turn off dma in the bios

Another solution that might work is kernel parameters at the boot promt. At the promt where you choose between boot options you can pass any parameters to the kernel as what you normally do there is choose between different strings of parameters from a file

I am not sure, but if you start passing parameters at the boot promt I think you override everything that is in the syslinux.cfg file. So in order for it to work it is possible that you have to pass not only the parameters necessary for your particular system, but also all parameters that are necessary in order to boot Puppy on any system. A pretty long string of parameters in other words

I guess the only way to find out is to try. I checked this in vmware and it works there.. At the boot promt try:
Code:
vmlinuz ide=nodma root=/dev/ram0 initrd=image.gz

If you want to turn off acpi then add "acpi=off" to the string. If you want the pup-file you might have to add "PFILE=pup101-none-262144"

_________________
fake it until you make it
Back to top
View user's profile Send private message 
mark_l
Guest


PostPosted: Sun 27 Nov 2005, 02:00    Post subject: Turning off DMA solved the problem  

gnomen:

Thanks for your suggestion!! It worked!

I was able to work around a troublesome CDROM drive by turning off DMA. This allowed me to load Puppy up, then install it onto my hard drive. I even managed to install GRUB! All on an old Pentium MMX with 128 mb of RAM. I am using the system now to type out this reply (yes, even the old Rockwell modem still works).

Now I want to figure out how to replace the window manager with ICEWM.....

Again, thanks for your very helpful advice. Others with a CDROM that won't boot (I/O errors) should try this solution.

Mark L.
Back to top
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11157
Location: Arizona USA

PostPosted: Sun 27 Nov 2005, 10:02    Post subject:  

Mark, would you tell us exactly what you entered and where? Thanks. Smile
Back to top
View user's profile Send private message 
Mark_L
Guest


PostPosted: Sun 27 Nov 2005, 22:51    Post subject:  

Flash:

Sorry about that! I should have been a bit more precise in what I did to solve the issue.

I typed in the code

Quote:
Code:
vmlinuz ide=nodma root=/dev/ram0 initrd=image.gz


as suggested by gnomen at the boot prompt that appears at the Puppy splash screen (v 1.06). This allowed my cdrom drive to copy user_cram into /. It seems that my cdrom is not compatible with DMA. Without the "noDMA" option, I was getting i/o errors and the system could not copy any files from the cdrom drive.
Back to top
lickthefrog

Joined: 05 Apr 2006
Posts: 8

PostPosted: Wed 05 Apr 2006, 19:15    Post subject: ide=nodma  

took me quite a while to find how to alter the startup so that it is "ide=nodma".

finally, i got puppy on this weird computer.

thanks.

now it'll take me forever again to figure out how to burn the command into a livecd, if possible, so that i can have puppy on every computer in the lab i oversee. (though i'm looking into LTSP).

wish me luck.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0559s ][ Queries: 12 (0.0047s) ][ GZIP on ]