Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 15:30
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.4.12 with 3.4.2 kernel.
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 41 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 39, 40, 41, 42, 43, ..., 87, 88, 89 Next
Author Message
feelsub

Joined: 20 Jun 2012
Posts: 39

PostPosted: Tue 03 Jul 2012, 12:26    Post subject:  

Quote:
Quote:
Could install either AbiWord 2.8 or 2.9, but don't work.
Open PPM and click configure button and then ok without touching the choiced repos. Then close it and reopen PPM. Now exprimo repo has been enabled. Type abiword.

OK from PPM, but it's version 2.8.2. I 1st tried abiword-common, but that's the one which is not working.

Gnumeric 1.10.8 OK but starts with error "/root/%u no such file or directory"

Quote:
* ntfs-3g from a 2010.3.6 version to 2012.1
-----> why ? what benefits there is to upgrade it compared to squeeze default one. Just upgrading something is not my priority.

Lots of fixes see http://www.tuxera.com/community/release-history/
But this pet works http://www.datafilehost.com/download-b2aa69a5.html

Quote:
Gparted from 0.7 to 0.12
----> see above question. What benefits there is. You will need to compile all lib*mm files as static and then compile latest Gparted as static against them. Or install those big libpangomm etc lib*mm files as shared and then compile Gparted as shared. I have managed without those big lib*mm libs all this time.
Several times new Gparted has broken something with Puppy installer scripts like Puppy Universal Installer. Again...I would need to know how does newer Gparted benefit Puppy users.

See changelog: http://gparted.sourceforge.net/news.php?entries=all
such as

Unable to grow and shrink FAT16 and FAT32 file systems
Unable to shrink HFS and HFS+ file systems
Unable to determine used and unused sectors in HFS and HFS+ file systems
Unable to erase file system signatures on partition create and format
FAT16 and FAT32 file system moves performed internally by GParted instead of by libparted

Other key changes include:

Fix size off by one sector with unrecognized disk label
Fix GParted crashes with assertion (head_size <= 63)
Requires libparted-2.4 or higher

Quote:
I will use Ffmpeg 0.91 whence there is something which is missing from it. Upgrading ffmpeg will mean large depending multimedia applications recompile, for example VLC depends on the version it has been compiled against. Not very delicious choice just to upgrade it and all other apps which needs it.


Well since version 0.11 there is WMA lossless support, 0.10 also provides new codecs -> ffplay
But there still muxing bugs esp. with aac, which I hope to see fixed in next release.

Quote:
Quote:
Replace Viewnor by Gthumb, which is way faster and more complete.
.... I will keep Viewnior as default viewer because it is familiar to Puppy users and fast enough.

Indeed, it's on other Puppies, now try with large Mpix images (>12Mpix) and you'll readily see the advantage.

Quote:
GIMP 2.8 is out. It needs newer libs than squeeze provide.

hope to see it than.

Thanks
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Tue 03 Jul 2012, 13:54    Post subject:  

pemasu wrote:
Quote:
Hope your arm is on the mend after the operation?
Unfortunately for me Exprimo version 5.X.3.4.2.2 is unable to create a save file - it goes through the cli save file set up but then hangs during the save file creation.

Shoulder is still painful, but it hasnt stopped me for fishing. We got yesterday together 12 kg of pikeperch from the lake. After jigging 2 hours per day two days...My shoulder is in flames now....but it has been fun.

About failure to create savefile. This was now the second report of that problem. Also pnethood mysteriously does not work as it should ?

I dont have clear answer to these problems. The woof is newer than in previous build but nothing I have updated since previous build should otherwise affect. I think I need to download latest woof and try new build. With the latest updates, ie pnethood update and maybe some other puppy apps updates, if there has been them. But I need to wait since I get to the home back. I dont dare to download woof with this slow 3g connection.


Sound like you are having a good time sans the shoulder - what do you do with all the fish, eat them?

I have now got Dpup Exprimo 5.X.3.4.2.2 running with a savefile - i made a blank 3.fs save file beforehand then booted into Exprimo 5.X.3.4.2.2 and used that - saves and reboots seem to be working correctly this way with no hanging at shutdown. Smile
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 03 Jul 2012, 15:12    Post subject:  

Stu90. We have 6 ppl eating them and we put the rest to the freezes as files. We are going to night jigging this night. Had to go to the town and by more jigs. The place where we jig is old log dropping place. And there is a lot binding wires in the bottom. Somehow it is also place where the pikeperches reside.

Quote:
OK from PPM, but it's version 2.8.2. I 1st tried abiword-common, but that's the one which is not working.

You are still not using exprimo repo. I believe you have installed debs from squeeze repos not from exprimo repo. Just downloaded again, it works and I had abiword 2.9.0. Just to confirm.
Quote:
Unable to erase file system signatures on partition create and format

That sounds significant. I suppose there isnt many volunteers to static compile the lib*mm libs and compile statically gparted.
Anyway...here is the link to the Barry`s instructions: http://bkhome.org/blog/?viewDetailed=00693
If someone compiles newer gparted, I will upgrade it. Just download latest lib*mm libs sources and latest gparted source and then install those statically compiled libs and then compile statically gparted and package for example with new2dir.
Quote:
Well since version 0.11 there is WMA lossless support
Sounds good. I will put ffmpeg to the todo list. But not very soon.
Quote:
Indeed, it's on other Puppies, now try with large Mpix images (>12Mpix) and you'll readily see the advantage.
Have you tried Geeqie from the exprimo repo. Gthump is out. It needs polluted gnome-common and other stuff which has been cleaned out in dpup exprimo. In fact...I dont know any Puppy with gnome-common package.
Quote:
ntfs-3g from a 2010.3.6 version to 2012.1

Fixes list was redundant in your posted link. Okay....I gave it a go. I used internal fuse, because I would have to had update fuse libs to use external libs and that would have meant to compile latest util-linux before latest fuse libs would have been compiled. So...I took the shorter road. Might not work as it should but....here is the ./configure:
Code:
./configure CFLAGS="-mtune=generic -O2 -pipe -fomit-frame-pointer" CXXFLAGS="${CFLAGS}" --prefix=/ --sysconfdir=/etc --localstatedir=/var --with-fuse=internal

I consider the attached pets as alpha compile. They mounted ntfs for me and unmounted also, Puppy Universal Installer showed the partitions right, but I am not sure if the ntfs stuff has been used in partition recognition stage, probably not.
Install the pet with dedicated pfix=ram situation, if you want to explore the usability of the pet and give feedback. I am not sure if all puppy scripts are happy with this compile. You have been warned.
ntfs-3g_ntfsprogs-2012.1.15-dpup.pet
Description 
pet

 Download 
Filename  ntfs-3g_ntfsprogs-2012.1.15-dpup.pet 
Filesize  461.13 KB 
Downloaded  115 Time(s) 
ntfs_DEV-3g_ntfsprogs-2012.1.15-dpup.pet
Description 
pet

 Download 
Filename  ntfs_DEV-3g_ntfsprogs-2012.1.15-dpup.pet 
Filesize  226.67 KB 
Downloaded  113 Time(s) 
ntfs_DOC-3g_ntfsprogs-2012.1.15-dpup.pet
Description 
pet

 Download 
Filename  ntfs_DOC-3g_ntfsprogs-2012.1.15-dpup.pet 
Filesize  29.02 KB 
Downloaded  116 Time(s) 

Last edited by pemasu on Tue 03 Jul 2012, 16:42; edited 1 time in total
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Tue 03 Jul 2012, 15:28    Post subject:  

I found an IM client for linux called Qnext.

I was going to download it to see if I could compile it, however it doesn't list dependencies and the file is a .tgz file and when I click, pupget keeps trying to install it.

I let pupget install it a few times but everytime, I can't find what was installed.

...It would be nice to get some assistance with this.

Homepage: www.qnext.com
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 03 Jul 2012, 15:35    Post subject:  

Gnuxo. Just right click the 61.6 Mb ! qnextsetup.tgz package and choose filer-roller or open archive choice. Both of them extracts the .tgz without probs to your selected folder. Default extraction happens where to compressed package is...ie to the same folder. There is Pidgin in the repo by the way.
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Tue 03 Jul 2012, 16:00    Post subject:  

I like pidgin, but I also like variety. I also want to download as few libraries as possible.

I've tried what you said and it extracted nicely. It's a .jar executable and uses java.
It also requires a qnext account to connect to any other protocols. Which I'm not happy with.

I have installed centerim and I'm very happy with it. I've tried finch but I found it's learning curve a bit much.
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Tue 03 Jul 2012, 18:30    Post subject:  

A quick thing I want to ask.

Most Raspberry Pi come either preinstalled with Debian or you can install Debian.
Since Dpup Exprimo is based on Debian, can it run on Raspberry Pi?

Also, how do you even install an OS on Raspberry Pi? It doesn't even have a BIOS.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 03 Jul 2012, 18:43    Post subject:  

Nah. The distro needs to be based on arm processor targeted packages and apps needs to be compiled to support arm architecture.
This is the Puppy for Rasp Pi: http://bkhome.org/blog/?viewDetailed=02879
Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 464

PostPosted: Tue 03 Jul 2012, 19:29    Post subject:  

Picker, ptmtimer and PeasyPdf error messages in 5.X.3.4.2.2

Code:
picker:
/usr/bin/picker: line 2: /usr/local/picker/picker: No such file or directory

ptmtimer:
/usr/local/bin/ptmtimer: line 2: /usr/local/ptmtimer/ptmtimer: No such file or directory

PeasyPDF:
can't find the file at /usr/share/doc/PeasyPDF.html.

_________________
PupMates

Last edited by radky on Tue 03 Jul 2012, 20:10; edited 1 time in total
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 03 Jul 2012, 19:54    Post subject:  

Thanks Radky. It seems that picker and ptmtimer has been eaten away from the pets in the packages_pet folder in woof. I mean some scripts were missing inside the pets. Picker pet in woof was 14 kb and in zigberts repo...it was 19 kb. I just cant understand how that has happened. It might be that there is something else also missing. Interesting. Peasypdf.html was missing from my 3builddistro file. Added now. Thanks. I do keep doc folder really reduced. And I do add there only useful docs.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 04 Jul 2012, 00:16    Post subject: Re: pnethood-0.6.9  

peebee wrote:
/var/log/messages shows:
Code:
Jul  4 11:37:55 puppypc30980 user.err kernel: [  114.802296] CIFS: Unknown mount option "servernetbiosname=ATHOME"
Jul  4 11:39:23 puppypc30980 user.err kernel: [  203.224572] CIFS: Unknown mount option "servernetbiosname=ATHOME"

Comment out the line around 41 in /usr/local/apps/pnethood/func_mount:
Quote:
#check to see whether the machine name is really a name or just an ip
#[ "$(echo $MACHINE | grep '^[0-9]\{1,3\}\.[0-9]\{1,3\}\.[0-9]\{1,3\}\.[0-9]\{1,3\}$')" ] || SERVERNETBIOSNAME="servernetbiosname=${MACHINE},"

An issue of the mount.cifs version?
# mount.cifs -V
mount.cifs version: 1.5
EDIT: No. Slacko-5.3.3 shows the same version number.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
linuph


Joined: 03 Jun 2012
Posts: 128
Location: Philippines

PostPosted: Wed 04 Jul 2012, 03:50    Post subject: Puppy Package Manager (PPM) doesn't show up anymore
Subject description: A common Puppy hickup?
 

I could not add packages from other distro's or maybe I was impatient.... So I cleared all packages to make a fresh start and clicked OK. Since then, no more PPM. Cannot install, nor uninstall. Is there a config file I can initialize to make PPM work again?
I think this is a common Puppy hickup but I didn't try other versions.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1463
Location: Malvern, Worcs, UK

PostPosted: Wed 04 Jul 2012, 03:53    Post subject: Re: pnethood-0.6.9  

shinobar wrote:
Comment out the line around 41 in /usr/local/apps/pnethood/func_mount:
Quote:
#check to see whether the machine name is really a name or just an ip
#[ "$(echo $MACHINE | grep '^[0-9]\{1,3\}\.[0-9]\{1,3\}\.[0-9]\{1,3\}\.[0-9]\{1,3\}$')" ] || SERVERNETBIOSNAME="servernetbiosname=${MACHINE},"

An issue of the mount.cifs version?
# mount.cifs -V
mount.cifs version: 1.5
EDIT: No. Slacko-5.3.3 shows the same version number.


Hi Shinobar

Confirmed - that small change fixes the problem - connection to share now successfully achieved. Applied to version 0.6.9

I notice by the way that the menu entry for pnethood has changed to suggest that it is only for windows shares.................

Cheers & thanks for all your help
peebee
image-1.png
 Description   
 Filesize   120.44 KB
 Viewed   499 Time(s)

image-1.png


_________________
LxPup-14.10 = Puppy + LXDE

Last edited by peebee on Wed 04 Jul 2012, 05:26; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 04 Jul 2012, 04:09    Post subject:  

Thanks Shinobar - Peebee of the bug hunting. Can I do the modification to the 0.6.9 version and include it to the bug fix release using latest woof ?

linuph. You need to give more spesific explanation what did you clear of. Did you remove some text files from ./root/packages ? What is the exact method trying to install other distro packages. If you type in console: ppm ....what do you get. There are several text files and scripts behind the PPM. Sometimes just clearing /tmp ( I do it by deleting everything there helps and reboot do the same) helps when PPM hickups.
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Wed 04 Jul 2012, 05:42    Post subject:  

pemasu wrote:
Great !
I included to the pet those other Hauppage firmwares also. So...the pet should work with other versions.

Thank you of the feedback !


Wow much appreciated. My Hauppauge is a USB thing named WinTV-HVR 900
so hopefully that one work too? I need to test this. I have downloaded all the pets
you gave us. Hope it works. Latest iso and devx and the VLC and hapupauge firmware
you provided

Is this wrong thread to ask about how to get the TV dongle to work?

I did try to activate all the pets and such. devx is loaded on the fly
and QT should one activate that using the menu maybe???
and Vlc and the dependecies and Hauppauge USB connected

I have no idea how to activate that when I start VLC? What am I supposed to do.
Set the frequency to some mhz what? Damn I feel stupid

Last edited by nooby on Wed 04 Jul 2012, 06:57; edited 3 times in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 41 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 39, 40, 41, 42, 43, ..., 87, 88, 89 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1294s ][ Queries: 13 (0.0196s) ][ GZIP on ]