Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 12:29
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Portable Gimp for Precise Puppy
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
shinobar


Joined: 28 May 2009
Posts: 2385
Location: Japan

PostPosted: Sat 06 Nov 2010, 06:22    Post subject:  Portable Gimp for Precise Puppy  

gimp-portable-2.8.10-0.3-precise.tar.gz (2014-02-16)
http://shino.pos.to/party/bridge.cgi?puppy/test/

Portable Gimp places the Gimp(GNU Image Manipulating Program) with its configuration files in a folder to utilize it without installation in the Puppy space(pupsave).

The Gimp is a large application. The Gimp makes large cash and saves new brushes and patterns consuming your pupsave.

The Portable Gimp has the Gimp code as a sfs, and mounts the sfs and launch. The sfs is unmounted at the application finished so that the loop back devices to be free. The Portable Gimp also holds the Gimp settings, cache and additionals in the same 'gimp-portable' folder, not to consume your pupsave.

Tested on Precise-571JP. Works with Precise Puppy.

The Portable Gimp is provided only for Precise Puppy at this point of time.
Other SFS's available:
SFS with NLS, DEV and DOC:
gimp-2.8.4-1-precise_xz.sfs
http://shino.pos.to/party/bridge.cgi?puppy/precise/opt/
Compiled on Precise Puppy and works only on Precise Puppy.

There is another sfs by scabz, Gimp-2.8.6-i686 compiled in Precise 5.6.1:
http://www.murga-linux.com/puppy/viewtopic.php?t=87046

gimp-2.7.1-1-w5.sfs
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/
Based on the PET Barry compiled.
Works on Wary/Racy and most of Puppy-5.x.

gimp-2.6.12-Lucid-1.sfs
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/
Based on the packages from Ubuntu Lucid. Does not contain DEV.
Works on Lupu/LupQ/Slaco/Dpup. Does not work on Wary/Racy.

gimp-2.6.11-squeeze-3.sfs
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/
Based on the PET Iguleder compiled.(PETs available here.)
Works on Lupu/LupQ/Slaco/Dpup. Does not work on Wary/Racy.

gimp-2.6.11-w5c.sfs
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/
Compiled on Wary Puppy 5.2.1.90 against the gtk+-2.24.8-w5c
May NOT work on older Wary/Racy.
./configure --prefix=/usr --host=i486-t2-linux-gnu --sysconfdir=/etc --with-x --without-dbus --without-webkit --disable-python

gimp 2.7.3.sfs for Lupu 520 by alfisti and by ttuuxxx
http://www.murga-linux.com/puppy/viewtopic.php?t=65175

For Puppy-4.x:
gimp-2.6.8-1.sfs
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup4/

UPDATE: 16 May 2012 gimp-2.6.11-squeeze-2.sfs add weblink to the online manual
UDPATE: 14 Oct 2011 gimp-2.7.1-1-w5.sfs supports varaiety of Puppy-5.x.
UPDATE: 9 Nov 2010, gimp-2.6.11-squeeze-2.sfs
Add plugins: davids_batch_processor, xscanimage

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Last edited by shinobar on Sun 16 Feb 2014, 00:41; edited 15 times in total
Back to top
View user's profile Send private message Visit poster's website 
dejan555


Joined: 30 Nov 2008
Posts: 2588
Location: Montenegro

PostPosted: Sun 07 Nov 2010, 09:09    Post subject:  

Hey shinobar, great that you made sfs and opened new topic, 2.6.11 works stable and ok I guess? I added kaleidoscope plugin and vignette script to package too, and just now found this batch processor in this thread http://murga-linux.com/puppy/viewtopic.php?t=31416 and compiled against 2.6.11, here's the pet

davids_batch_processor-1.1.9.pet

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
rcrsn51


Joined: 05 Sep 2006
Posts: 8555
Location: Stratford, Ontario

PostPosted: Sun 07 Nov 2010, 10:21    Post subject:  

When building GIMP packages, you might want to include this attachment. It's the plugin for SANE scanners.
sane_1.0.14-7_i386.deb.gz
Description 
gz

 Download 
Filename  sane_1.0.14-7_i386.deb.gz 
Filesize  105 KB 
Downloaded  578 Time(s) 
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2385
Location: Japan

PostPosted: Tue 09 Nov 2010, 09:47    Post subject: gimp-2.6.11-squeeze-2.sfs  

Thanks, dejan and rcrsn.

Updated gimp-2.6.11-squeeze-2.sfs,
Add plugins: davids_batch_processor, xscanimage (both function not yet tested)

Upload gimp-2.6.8-1.sfs for Puppy-4.x.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2385
Location: Japan

PostPosted: Fri 14 Oct 2011, 09:38    Post subject: gimp-2.7.1-1-w5.sfs  

gimp-2.7.1-1-w5.sfs
Works on Wary/Racy and most of Puppy-5.x.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2385
Location: Japan

PostPosted: Tue 15 May 2012, 12:37    Post subject: UPDATE: gimp-2.6.11-squeeze-3.sfs  

Now uploaded:
gimp-2.6.11-squeeze-3.sfs
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/
Based on the PET Iguleder compiled.
Works on Luci/Lupu/LupQ/Slaco/Dpup. Does not work on Wary/Racy.

Add link to online manuals for available 12 languages.
English, German, Spanish, French, Italian, Japanese, Korean, Dutch, Norwegian, Polish, Russian and Swedish.

You need to Edit >> Preferences >> Help System
User manual set to 'Use a locally installed copy',
Help browser to use: 'Web browser', and
Web browser to use: 'defaultbrowser %s'.
gimp_help_setting.png
 Description   
 Filesize   16.64 KB
 Viewed   2511 Time(s)

gimp_help_setting.png


_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Mon 04 Jun 2012, 17:03    Post subject:  

I would love to try the new Gimp 2.8

I read some reviews about it and some actually think it's as good as photoshop now.

I don't know if that's true but it's definitely worth a look.

I hope an sfs or pet is made soon so that puppy doesn't lag too far behind.

It would especially good to have a very light OS for my old pc with Gimp 2.8 so that I don't overuse my resources.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2385
Location: Japan

PostPosted: Wed 13 Jun 2012, 22:23    Post subject: gimp-2.8-precise  

gimp-2.8-precise.sfs
http://shino.pos.to/party/bridge.cgi?puppy/precise/
Compiled on Precise Puppy beta2 and works only on Precise Puppy.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Thu 14 Jun 2012, 13:36    Post subject:  

Awwww....

Us in the 528 wanna use gimp 2.8 too. Crying or Very sad

This just makes me wanna never turn my computer back on.
Back to top
View user's profile Send private message 
amj

Joined: 28 Jan 2011
Posts: 27

PostPosted: Wed 20 Jun 2012, 05:14    Post subject:  

ありがとう shinobarさん。

I now have GIMP installed on lupu 525. But it took several attempts.

First I tried the official gimp-2.6.12-Lucid.pet package on a lupu 525 full install system. It gave me no menu entry. I was able to launch the program from a console, but since there was probably a good reason for the lack of a menu entry I uninstalled.

Next I tried the official gimp-2.6.10-Lucid.pet package on a lupu 525 frugal install system. It gave me two menu entries, neither of which worked. The package checker told me libpopler.so.7 was missing but I'm not enough of an otaku to know what I need to install to resolve the dependency.

Next I tried your gimp-2.6.12-Lucid-1.sfs file on the lupu 525 frugal install system and got the same result I had previously using the equivelent package on the full install system.

I tried your gimp-2.6.11-squeeze-3.sfs on the lupu 525 frugal install system and that worked.

So I have now installed the gimp_full-2.6.11-i486-squeeze.pet package on my full install system and finally have GIMP on a system that has a large screen suited to image manipulation.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2385
Location: Japan

PostPosted: Sun 16 Feb 2014, 00:42    Post subject: gimp-portable-2.8.10-0.3-precise  

gimp-portable-2.8.10-0.3-precise.tar.gz
http://shino.pos.to/party/bridge.cgi?puppy/test/

Portable Gimp places the Gimp(GNU Image Manipulating Program) with its configuration files in a folder to utilize it without installation in the Puppy space(pupsave).

The Gimp is a large application. The Gimp makes large cash and saves new brushes and patterns consuming your pupsave.

The Portable Gimp has the Gimp code as a sfs, and mounts the sfs and launch. The sfs is unmounted at the application finished so that the loop back devices to be free. The Portable Gimp also holds the Gimp settings, cache and additionals in the same 'gimp-portable' folder, not to consume your pupsave.

Tested on Precise-571JP. Works with Precise Puppy.

The Portable Gimp is provided only for Precise Puppy at this point of time.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0635s ][ Queries: 13 (0.0042s) ][ GZIP on ]