Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 04:48
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
wxWidgets, QT4, for Puppy 4.3.1?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Makoto


Joined: 03 Sep 2009
Posts: 1797
Location: Out wandering... maybe.

PostPosted: Mon 21 May 2012, 06:38    Post_subject:  wxWidgets, QT4, for Puppy 4.3.1?  

Are there any existing packages for either wxWidgets or QT4 (probably 4.5 or better) that work with Puppy 4.3.1 and include the dev headers?
_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Mon 21 May 2012, 07:42    Post_subject:  

Not sure about qt4, but I think this wxGTK-2.8.8.pet should work.
Back to top
View user's profile Send_private_message 
Makoto


Joined: 03 Sep 2009
Posts: 1797
Location: Out wandering... maybe.

PostPosted: Tue 22 May 2012, 20:12    Post_subject:  

I don't know... I've tried compiling one program, [url=http://comical.sourceforge.net/]Comical[/u], but didn't get very far. Of course, it probably doesn't help that Comical's supposedly a pain to try to compile. Smile

I think it was supposedly picky about the version of wxWidgets it's compiled against, for starters. Do most wxWidgets programs generally want a specific version of wxWidgets? (Other than just "vX.X.X or higher," I mean.)

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Wed 23 May 2012, 09:29    Post_subject:  

I just dowloaded comical v0.8 source, extracted it, installed the wxGtk package I mentioned above, then , after first changing line 5 of the Makefile from:

Code:
prefix = /usr/local


to:

Code:
prefix = /usr


received this error, after running make:

Code:
ComicalApp.cpp:63: error: invalid use of undefined type `struct wxIcon


Opening that file, & checking line 63, there is, for a mac:

Code:
#if !defined(__WXMAC__) && !defined(__WXCOCOA__)
   frame->SetIcon(wxICON(comical));
#endif


Then, just by deleting those 3 lines, 62-64, it then compiled fine.
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Wed 23 May 2012, 09:35    Post_subject:  

Makoto,

I just re-read & saw you were asking specifically for p431. While I compiled comical on p525, I'm pretty sure the wxGtk package, above, was originally compiled on p412, so should work fine with p431. Let us know if you have problems getting it to work.
Back to top
View user's profile Send_private_message 
Makoto


Joined: 03 Sep 2009
Posts: 1797
Location: Out wandering... maybe.

PostPosted: Wed 23 May 2012, 17:19    Post_subject:  

It does seem to work, though it does still throw a large number of warnings. Smile
(Actually, there's supposed to be some far more recent work done on Comical since the 0.8 version, in the SVN... but I haven't looked at it.) I haven't had time to test my build beyond the usual 'does it open when I click on it' test, however. Very Happy

I'm wondering if Qt 4.6 can be built on 4.3.1, for programs like this, among others. Of course, if there's any other way to quickly view OBJ models than loading them into a full-fledged renderer like Blender, and spend time trying to make it look right...
I'd been told once that Qt 4.5 and higher wouldn't work with the kernels in the 4.3.1 Puppies, but even then, they weren't sure. Neutral
(then again, I'd probably still have to update qmake on this system (I'd done that with my previous Puppy setup, but not this one...)

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0614s ][ Queries: 12 (0.0152s) ][ GZIP on ]