Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 23:16
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to use Purebasic in Puppy?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Topic_locked View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
t57042

Joined: 19 May 2012
Posts: 3

PostPosted: Sat 19 May 2012, 11:58    Post_subject:  How to use Purebasic in Puppy?  

Hello,

My name is Richard - I am from Belgium and new to Linux.I am trying to install Purebasic under puppyLinux. I use this a lot under windows.

I got this to install (from ubuntu?):
---------------------------------------------------------------------------------------------------
sudo apt-get install build-essential libgtk2.0-dev libgnome2-dev libgnomeprintui2.2-dev libxine-dev libsdl1.2-dev libiodbc2-dev libxxf86vm-dev libwebkitgtk-dev
---------------------------------------------------------------------------------------------------

As I understand Puppy doesn't use or recognize sudo?

What must be changed in above code to use under puppy?

Thanks
Richard
Back to top
View user's profile Send_private_message 
Rattlehead


Joined: 11 Sep 2008
Posts: 215
Location: Madrid, Spain

PostPosted: Sat 19 May 2012, 13:38    Post_subject:  

Hi Richard, welcome to the kennels. My level of 'noobieness' is ideal to answer your question.

Yeah, you're right. In Puppy you are always the Superuser, so you don't need the sudo command. Just suppress it from your line and it'll work.

However, apt-get picks the programs from a different distro's repository, (Debian I think?), so maybe you'll run into dependencies issues (you'll have to chase missing libraries, etc). Unless, of course, you are running Puppy 5, which has a completely different package manager, and it supports other distros too, I believe.

In any case, I think your best bet is searching for a precompiled purebasic package for puppy in the package manager (the 'install' icon in the desktop).

Another great resource is the search engine via google of this forum:

http://www.wellminded.com/puppy/pupsearch.html

Type "Pure basic pet" there (.pet are the precompiled packages for puppy), in addition to your puppy version, and maybe you'll have it there, too. Good luck. Smile
Back to top
View user's profile Send_private_message 
t57042

Joined: 19 May 2012
Posts: 3

PostPosted: Sun 20 May 2012, 08:45    Post_subject:  

Sorry, but this doesn't get me anywhere.
What I need are detailed instructions to install Purebasic.

I am new to Linux, and Purebasic is essential for me.
If I do not succeed to make it run under Puppy, I will have to go back to Windows, or use Wine

Richard
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Sun 20 May 2012, 09:46    Post_subject:  

Quote:
What I need are detailed instructions to install Purebasic.

I downloaded the test version of Purebasic and extracted it. I went into the compilers folder and clicked on the "purebasic" icon. The IDE started. I did a few tests that worked fine.

However, as was suggested by musher0, you also need to install the devx package. It contains the compiler required by Purebasic.
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11121
Location: Arizona USA

PostPosted: Sun 20 May 2012, 11:07    Post_subject:  

t57042, please don't ask the same question several times in the forum. Now you have two threads working the same question. I"m going to lock this one. Please continue the first one. Thanks. Smile
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Topic_locked View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0489s ][ Queries: 12 (0.0057s) ][ GZIP on ]