Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 22:02
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Slacko Puppy 5.3.1
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 36 of 37 Posts_count   Goto page: Previous 1, 2, 3, ..., 34, 35, 36, 37 Next
Author Message

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Sat 11 Feb 2012, 09:42    Post_subject:  

Installed the xscreensaver-512 from the Slacko 5.3.1 repository, it said missing dependency gtkdialog. Then downloaded the gtkdialog- from PPM, yet checking dependencies still showed gtkdialog is missing.

Same for lha-114i and zoo-2.10_22 archiving utilities. I'm trying to unzip .gz file which XArchive doesn't seem to recognize, eg firstrun-1.9.6.gz

Any help appreciated.
Back to top
View user's profile Send_private_message 

Joined: 10 Mar 2010
Posts: 3778
Location: Ontario

PostPosted: Tue 14 Feb 2012, 13:34    Post_subject: Audacity(1.3.14)  

The latest version of Audacity(1.3.14) worked nicely for me.
This version only works in slacko.


Back to top
View user's profile Send_private_message 

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Fri 24 Feb 2012, 11:58    Post_subject:  

Installed Slacko 5.3.1 for my friend's PC with Geforce FX5200 graphics card,then upgraded the nv driver to Nvidia-173 recommended by Slickpet>drivers, and glxgears was running superfast.

After that installed the xscreensavers-5.12 from PPM which also required dependencies glew-1.5.7 and mesa-7.9.2 (which i later upgraded to mesa-7.10.2-s from Slacko repo). However,this seems to break glxgears which returned "Error: couldn't get an RGB, Double-buffered visual" and glxinfo also reported "Error:couldn't find RGB GLX visual or fbconfig".

Need help resolving this issue. TIA.

Added: Also noticed running Pupclockset manager and/or JWM configuration cause the clock_analog widget (in ver 2.4.0) to disappear from the desktop

Solved: Glxgears problem resolved by reinstalling the Nvidia173 pet.

Disappearing clock_analog widget still there. Anybody has any idea why or how to fix it?
Back to top
View user's profile Send_private_message 

Joined: 26 Feb 2012
Posts: 8

PostPosted: Sun 26 Feb 2012, 16:47    Post_subject:  

I just installed Slacko Puppy 5.3.1 onto an Asus Eee PC

All good so far except that after the first shutdown any further attempt at shutdown results in the window manager restarting. I was able to shut down by exiting the window manager to the command shell & using ctrl-alt-delete.

Edit: I saved changes to /dev/sda1 while shutting down.

The problem appears to be in the rc.shutdown script when it kills processes that use /initrd/pup_rw

I'm going to try racy 5.2.2 instead...
Back to top
View user's profile Send_private_message 

Joined: 25 Oct 2010
Posts: 132
Location: Allentown, PA

PostPosted: Mon 27 Feb 2012, 22:08    Post_subject: Need help getting Trinity to run  

I have the trinity sfs loading but when I follow steps to link libraries, I get
bash: ldconfig:command not found

when I drop out of X, If I run
# startkde

I get a bunch of text referring to libGL.1.so not being found.

Aside from this, I have this running on an oddball handtop and everything works which is an amazing feat.

OQO model 02

The biggest issue is to blacklist via_agp so that wireless and usb work. To the bootloader options add


Start with vesa and 640x480 (fix later down)

Important trick is to have a usb mouse handy b/c the trackstick is nuts. Easy to fix with creating a script in startup to load the ps2 device as basic

sleep 0.5
modprobe -r psmouse
sleep 0.5
modprobe psmouse proto=bare

Once you restart X, you will be good to go.

The sleep times are important: without it, the erratic trackstick stays. If it is longer, the keyboard becomes random.

I tried adding this to /etc/modules.conf like in ubuntu in /etc/modules but it did not resolve the issue. options psmouse proto=bare has no effect

X will still look weird with the screen too small.

Add a modeline under the monitor section and change sync values

HorizSync   30-92
VertRefresh   50-85
Modeline   "800x480" 40 800 864 928 1088 480 481 484 509 +HSync

Then make every reference of 640x480 into 800x480. Restart X. You should have working trackstick along with the screen looking nice.

EDIT: I changed driver to openchrome and went to thw quickpet and installed mesa. I put

Load   "dri"

at the "modules section of xorg.conf


Section "DRI"
   Group 0
   Mode   0666

Section "Extensions"
       Option       "Composite" "Enable"

Will try to start kde again[/code]
Back to top
View user's profile Send_private_message 

Joined: 15 Dec 2011
Posts: 8
Location: Germany

PostPosted: Tue 28 Feb 2012, 11:16    Post_subject: wifi bug  

Gave slacko 5.3.1 a try on my eee pc 901. Unlike other puppys it won't open a wifi connection (neither "sophisticated" wizard which never failed before nor frisbee). After the first boot frisbee showed the first log, after the second boot the wifi device was there but it didn't launch either (see 2nd log). Hope this issue.

Hope that this issue will be fixed when my beloved Lucid Puppy runs out.
Back to top
View user's profile Send_private_message 

Joined: 08 Jul 2009
Posts: 5467
Location: Finland

PostPosted: Tue 28 Feb 2012, 12:09    Post_subject:  

Seems to be rt2800pci. It needs rt2860.bin firmware. What does dmesg tells concerning rt2800pci and according firmware loading.

You could first rmmod rt2800pci and then modprobe rt2800pci and then check the content of command dmesg.
Is there problem with firmware loading.
Back to top
View user's profile Send_private_message 

Joined: 26 Feb 2012
Posts: 8

PostPosted: Thu 01 Mar 2012, 00:35    Post_subject:  


Wifi works on an Asus EeePC 901 using Racy puppy 5.2.2, but you've got to install the firmware and mess about with wpa_supplicant.

Back to top
View user's profile Send_private_message 

Joined: 15 Dec 2011
Posts: 8
Location: Germany

PostPosted: Sun 04 Mar 2012, 07:19    Post_subject: rt2860pci  

Hi pemasu and mark

thanks a lot for your hints!

First of all: I'm no linux expert, just a more or less experienced user. I downloaded the
file from

I expected that in contains a .bin file or something similar but I xarchive failed to unpack it. My default Linux Mint archiver reported an error in the tar child.

So I tried to launch wpa_supplicant manualy from usr/sbin hoping that it can somehow deal with the tar.bz2 file. But that failed too.

If there is a solution please tell me as I was a schoolchild.
Back to top
View user's profile Send_private_message 

Joined: 28 May 2009
Posts: 2634
Location: Japan

PostPosted: Sun 04 Mar 2012, 08:20    Post_subject: Re: rt2860pci  

jodother wrote:

Maybe it is not bzipped but gipped. Rename the file name *.bz2 to *.gz.

You need to compile the source with the kernel sources.
Also you need to edit the file 'os/linux/config.mk' before make:

EDIT: There is a tarball the config.mk is already modified to support WPA.
You can compile it with your kernel sources.

Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 

Joined: 14 Mar 2012
Posts: 3

PostPosted: Sat 17 Mar 2012, 04:25    Post_subject: mksquashfs/unsquashfs version  

I tried searching the forum (and this topic in particular), but didn't find anything related.
I am wondering, if there is any reason why Slacko 5.3.1 has version 4.0 instead of 4.2 for mksquashfs/unsquashfs (while i.e. Racy does have 4.2).
I was trying to "unsfs" my puppy_racy_5.2.2.sfs from withing Slacko, but that was (naturally) impossible.
No big deal, just curious why. Are there any other issues with version 4.2 on Slacko 5.3.1 ?
Back to top
View user's profile Send_private_message 

Joined: 28 Nov 2011
Posts: 18

PostPosted: Tue 20 Mar 2012, 06:51    Post_subject: no webcam -- broken /dev/video0  

slacko working well on an hp mini 210 netbook except that /dev/video0 is broken.

built in webcam works on 5.2.8 but something is wrong when on slacko.

Back to top
View user's profile Send_private_message 

Joined: 12 Apr 2012
Posts: 1

PostPosted: Fri 13 Apr 2012, 00:06    Post_subject:  

This may have been mentioned already, but when I get on AbiWord in Slacko 5.3.1 and go to Format -> Paragraph and make the line spacing double spaced, nothing happens. I've never experienced this before with AbiWord. The other puppies don't have this issue. I'm a student and have to write papers so I never would have noticed this otherwise.
Back to top
View user's profile Send_private_message 

Joined: 23 May 2010
Posts: 2502
Location: near here

PostPosted: Sun 22 Apr 2012, 12:12    Post_subject:  

it may be due to the version of AbiWord, also there is a missing library

which can be added by using libaspell15-0.60.6-10.pet
see http://puppylinux.org/wikka/AbiWord

btw, I would recommend LibreOffice if your doing a lot of wordprocessing.


I have notice a minor bug in the PPM for Slacko - it displays slackware binaries on startup even though Puppy-Slacko is selected as the repository - even searches are within the slackware repositories. This can be fixed by click on slackware-repository selector then back on to the Puppy-Slacko option - but could lead to confusion and selection of wrong packages. Twisted Evil

helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 

Joined: 10 Sep 2011
Posts: 4732
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 24 Apr 2012, 13:05    Post_subject: slacko
Sub_title: I vote Slacko ( french president is still Sarko(zy)

Bonjour messieurs. This distro works well, and nowadays, its rare.
Eth0 and wlan 0, both are available
Sessions are save correctly
No desktop icons which disappear
Fast connection
All that is normal. Yes. And that is what the customer wants.

Back to top
View user's profile Send_private_message YIM 
Display_posts:   Sort by:   
Page 36 of 37 Posts_count   Goto page: Previous 1, 2, 3, ..., 34, 35, 36, 37 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1114s ][ Queries: 13 (0.0199s) ][ GZIP on ]