Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 19:29
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
slacko 5.3.3, final
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 19 of 42 Posts_count   Goto page: Previous 1, 2, 3, ..., 17, 18, 19, 20, 21, ..., 40, 41, 42 Next
Author Message
Jasper


Joined: 25 Apr 2010
Posts: 1144
Location: England

PostPosted: Sun 22 Apr 2012, 07:16    Post_subject: 5.3.2.8  

Hi 01micko,

I tried a fresh install of 5.3.2.8 and would comment:
-----------------------------------------------------------------------

In the first set up box under Country settings both the second and fourth items were listed as "en English", however I tested both of them and they both work.

Below is my opening screenshot after setting my screen resolution. The mainly black wallpaper is fine, but dark text on a dark background as in the menu and the time is bad - though I have no idea if this lack of contrast is almost unique to my computer.

The PPM is automatically set to "ziggy" style. So I assume whatever was broken is fixed. I never did discover or read what the problem actually was and as I'm still using 5.3.1 (which continues to be stable, fast and a pleasure) it might be nice to know what it was.

Somewhere, someone reported that, unusually, the Abiword paragraph setting would not accept double spacing - it seems that was and remains correct (though I have not yet personally needed that feature).
-----------------------------------------------------------------------

I also tried an upgrade from 5.3.1 which went well but did not automatically reproduce my extra System Tray icons - so whilst I expect to fix that with ease I'm short of time now so I stopped there and will have a detailed look in the next few days.

My regards and thanks
newinstall.png
 Description   
 Filesize   151.26 KB
 Viewed   1053 Time(s)

newinstall.png

Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Sun 22 Apr 2012, 07:32    Post_subject:  

cthisbear wrote:

Gone to the dark side and forgotten the basics...
Laughing

Yep, even got some dark side sneaking in.. (AD support? .. can actually take over the server if need be Laughing )

-

I did have an oversight, Shino's sfs load is NOT updated as advertised (windows trick?).. just download his latest 1.9.4 and apply this patch to stop jwm restarting..
Quote:
--- sfs_load.orig 2012-04-22 21:27:11.200042732 +1000
+++ sfs_load 2012-04-22 21:24:23.120034317 +1000
@@ -378,7 +378,7 @@
if [ "$HAS_DESKTOPS" -a -z "$SKIP_FIXMENUS" ]; then
waitsplash $(gettext "Updating menu...")
fixmenus
- [ "$DISPLAY" ] && pidof jwm &>/dev/null && jwm -restart
+ [ "$DISPLAY" ] && pidof jwm &>/dev/null && jwm -reload||jwm -restart
waitsplash --stop
fi
fi

Wink

____________________________

- Jasper,

Ok, I see the lack of contrast.. no problem to me but I do see that it may be for some. Try another JWM theme, I suggest puppeee_blue (thanks to trapster for that one), let me know if it's better, or else I can lighten the background of the default theme.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Jasper


Joined: 25 Apr 2010
Posts: 1144
Location: England

PostPosted: Sun 22 Apr 2012, 08:13    Post_subject:  

Hi again 01micko,

The lack of contrast is not a problem for me, but very probably for someone new to Puppy and Slacko. I'm pro Puppy and pro Slacko and I just want all who try it to be impressed.

My regards
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5754
Location: Valåmoen, Norway

PostPosted: Sun 22 Apr 2012, 08:18    Post_subject:  

Made an install to a brand new Samsung-NF310 laptop 10".
No issues at all..... yet Very Happy


What is the reason for not including more repos in ppm by default?


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Billtoo


Joined: 07 Apr 2009
Posts: 2128
Location: Ontario Canada

PostPosted: Sun 22 Apr 2012, 09:01    Post_subject: slacko 5.3.3, beta3  

Manual frugal install to flash drive.
Installed mesa,devx,kernel source sfs,amd-driver-installer-12-3-x86.x86_64.run

Slacko Puppy, version 5.3.2.8p on Sun 22 Apr 2012

Chip description:
0.0 VGA compatible controller
ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series]
oem: ATI ATOMBIOS
product: PARK 01.00

X Server: Xorg
Driver used: fglrx

X.Org version: 1.9.5
dimensions: 1600x900 pixels (423x238 millimeters)
depth of root window: 24 planes

# glxgears
26411 frames in 5.0 seconds = 5282.061 FPS
26587 frames in 5.0 seconds = 5317.214 FPS
26655 frames in 5.0 seconds = 5330.912 FPS

05:00.0 Network controller: Atheros Communications Inc. AR928X
Wireless Network Adapter (PCI-Express) (rev 01)

That's it so far, no problems.

I made a pet of the newest emelfm2 file manager.
screenshot.jpg
 Description   
 Filesize   14.8 KB
 Viewed   946 Time(s)

screenshot.jpg

emelfm2_DOC-0.8.1-i686.pet
Description 
pet

 Download 
Filename  emelfm2_DOC-0.8.1-i686.pet 
Filesize  57.2 KB 
Downloaded  152 Time(s) 
emelfm2-0.8.1-i686.pet
Description 
pet

 Download 
Filename  emelfm2-0.8.1-i686.pet 
Filesize  547.24 KB 
Downloaded  172 Time(s) 
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4797
Location: GB

PostPosted: Sun 22 Apr 2012, 09:48    Post_subject:  

Quote:
My SIS boots to a perfect desktop

Could be my 1440x900(native) monitor. These newer widescreens can be troublesome. DaveS has also reported missing correct res. on similar screens. Added to the less commonly encountered SiS Mirage I chipset probably doesn't help?
Back to top
View user's profile Send_private_message 
zekebaby


Joined: 17 Nov 2010
Posts: 49

PostPosted: Sun 22 Apr 2012, 11:24    Post_subject: Save file ends up in wrong dir  

Fresh frugal install on a Dell D430.

The only real problem I found was that the save file ended up in the wrong directory. I boot with
Code:
kernel /boot/slacko/vmlinuz psubdir=/boot/slacko pmedia=atahd

and the save file ended up in a newly created directory "/bootslacko' instead of '/boot/slacko'. I just moved the save file over so it's not a big problem for me, but it could throw off new users who will constantly be asked to set up from scratch every time they boot up. Let me know if you need help tracking down the bug.

Also, as someone else reported, I had to manually install FlashPlayer; the automatic prompt did not come up once my network was established.

Aside from that, amazing job so far!
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Sun 22 Apr 2012, 15:50    Post_subject: Re: Save file ends up in wrong dir  

zekebaby wrote:
Fresh frugal install on a Dell D430.

The only real problem I found was that the save file ended up in the wrong directory. I boot with
Code:
kernel /boot/slacko/vmlinuz psubdir=/boot/slacko pmedia=atahd

and the save file ended up in a newly created directory "/bootslacko' instead of '/boot/slacko'. I just moved the save file over so it's not a big problem for me, but it could throw off new users who will constantly be asked to set up from scratch every time they boot up. Let me know if you need help tracking down the bug.

Also, as someone else reported, I had to manually install FlashPlayer; the automatic prompt did not come up once my network was established.

Aside from that, amazing job so far!

I can confirm save file bug, I think it has to do with >10 numbered partitions, will inform shinobar.

As for flashplayer, I disabled the auto download, there is a menu entry. Do folks want the auto download back?

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
James C


Joined: 26 Mar 2009
Posts: 5866
Location: Kentucky

PostPosted: Sun 22 Apr 2012, 16:14    Post_subject: Re: Save file ends up in wrong dir  

01micko wrote:

As for flashplayer, I disabled the auto download, there is a menu entry. Do folks want the auto download back?


Just another thing to consder. The latest and greatest Flashplayer does not work on some older cpu's such as my Athlon XP and P3 boxes.See the Wary thread http://www.murga-linux.com/puppy/viewtopic.php?p=616645#616645
Terryphi did make a pet of an older security patched version intended for older hardware which will not run version 11.2.202.228
http://www.murga-linux.com/puppy/viewtopic.php?p=616867#616867
Back to top
View user's profile Send_private_message 
drongo


Joined: 10 Dec 2005
Posts: 353
Location: UK

PostPosted: Sun 22 Apr 2012, 16:15    Post_subject: Alphasort error
Sub_title: 1, 10, 11, 12 etc
 

The numbering problem may be nothing to do with having more than 9 partitions. It might just be the classic ascii alphasort problem. If you sort strings from the leftmost character 10 appears to be lower than 2 because 0x3130 looks "lower" than 0x32.

You can fix this in strings by putting in leading zeroes, i.e. 0x3031 is less than 0x3032 is less than 0x3130 which will sort as 01, 02, 10.

I don't think you can do that with partition numbers so you have to modify your alphasort/ordering routine to look at the whole number rather than just the most significant digit.

HTH
Back to top
View user's profile Send_private_message 
B.K. Johnson

Joined: 12 Oct 2009
Posts: 141

PostPosted: Sun 22 Apr 2012, 17:30    Post_subject: A few nitpicks about Slacko  

In the interest of updating anyone following,
No scripts to update seamonkey found. Googled, tried smokey01 pets_n_stuff (last update July 2, 2011) . But hope that from seamonkey, Edit>Preferences>Advanced>Software installation>Automatically download and install updates will work for next update. I'm unable to check now as the latest version 2.8 ) is already installed from a pet I got elsewhere.
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Sun 22 Apr 2012, 18:57    Post_subject:  

B.K. Johnson

This scripts works to get the latest official seamonkey and firefox in your default language (can be overridden)

http://www.murga-linux.com/puppy/viewtopic.php?p=585860#585860

When I compile seamonkey auto update is turned off, and I don't think it has ever worked properly with a compiled version in puppy anyway.

HTH

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
gcmartin

Joined: 14 Oct 2005
Posts: 4368
Location: Earth

PostPosted: Sun 22 Apr 2012, 19:21    Post_subject:  

01Micko wrote:
As for flashplayer, I disabled the auto download, there is a menu entry. Do folks want the auto download back?
I thought this a good feature when it was present.

Here to help

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send_private_message 
gcmartin

Joined: 14 Oct 2005
Posts: 4368
Location: Earth

PostPosted: Sun 22 Apr 2012, 19:47    Post_subject: Full SAMBA and SLACKO!!!  

This implementation and its PETs is really moving Puppy as a full LAN based Puppy. This includes all the correct services, and subsystem support for the best fully featured 32bit desktop in Puppyland.

This PUP can do everything on a LAN that any Apple and Microsoft has been doing for a decade. WOW!

Keep us moving appropriately @01Micko...."keep us moving appropriately."

Thanks for this heads-up approach.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Mon 23 Apr 2012, 00:28    Post_subject: psaveconfig-2.2.1  

Released pupsaveconfig-2.2.1.pet http://shino.pos.to/linux/puppy/
# v2.2.1 23apr12: fix was failed partition number >= 10, dialog shows all options, no choice under MINIMB
Thanks to zekebaby and jemimah.

Detail:
http://www.murga-linux.com/puppy/viewtopic.php?t=60678

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 19 of 42 Posts_count   Goto page: Previous 1, 2, 3, ..., 17, 18, 19, 20, 21, ..., 40, 41, 42 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1034s ][ Queries: 13 (0.0119s) ][ GZIP on ]