Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 19 Apr 2014, 22:52
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Upup Precise 5.3.3.3 with kernel 3.3.2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 25 [373 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 23, 24, 25 Next
Author Message
James C


Joined: 26 Mar 2009
Posts: 5444
Location: Kentucky

PostPosted: Sat 21 Apr 2012, 22:29    Post subject:  

Replacing missing lib allows Gparted to work....
Gparted.png
 Description   
 Filesize   125.85 KB
 Viewed   1063 Time(s)

Gparted.png

Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 3799
Location: Gatineau (Qc), Canada

PostPosted: Sat 21 Apr 2012, 23:06    Post subject:  

Problem saving straight 5.3.3 version to DVD. Said it requires a new or updated DVD! UpupPrecise 5.3.3.x has divination capacity since, at approx. the same time I was trying to save, pemasu was presenting version 5.3.3.1... Smile (hehe)

Back to serious: Will check if it is my DVD disk itself or some function in shutdown routine of PrecisePup that's involved.

BFN.

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)

Last edited by musher0 on Sun 22 Apr 2012, 09:45; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
linux28

Joined: 05 Apr 2009
Posts: 179

PostPosted: Sun 22 Apr 2012, 01:03    Post subject:  

flash ok Laughing
print ok Laughing




# cmake ..
CMake Error: Could not find CMAKE_ROOT !!!
CMake has most likely not been installed correctly.
Modules directory not found in
/usr/bin
CMake Error: Error executing cmake::LoadCache(). Aborting.
Sad


# evince

(evince:3083): EggSMClient-WARNING **: Desktop file '/usr/share/applications/evince.desktop' has malformed Icon key 'evince.xpm'(should not include extension)

(evince:3083): GLib-GIO-ERROR **: Settings schema 'org.gnome.Evince.Default' is not installed

Trace/breakpoint trap
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5458
Location: Finland

PostPosted: Sun 22 Apr 2012, 04:13    Post subject:  

Thank you all of the reports. These helps me a lot, as you know.

Okay...I will add slacko snmp backend.
Is is just /usr/lib/cups/backend/snmp which needs to be replaced.

libatkmm. Yeah. I added it under gparted, but woof would have needed gparted template to be fixed. So I add it as libatkmm. It should be in next version and now I check that it is there.

Quote:
EDIT: Cannot check printing, I cannot connect to the wifi network with my laptop. Booted fine but no network connection. Info below is from Exprimo.
=== NETWORK ===

Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller
VENDOR: 10ec DEVICE: 8136 KERNEL MODULE: r8169

JJim1911. Could you dmesg and check is it asking firmware which is missing. r8169 kernel module is there so it could be missing firmware. There is now 4 new firmwares in firmware git repository, so....it might be fixable by adding missing firmware.
dmesg tells you if it complains about spesific firmware.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5458
Location: Finland

PostPosted: Sun 22 Apr 2012, 05:41    Post subject:  

Quote:
# cmake ..
CMake Error: Could not find CMAKE_ROOT !!!
CMake has most likely not been installed correctly.
Modules directory not found in
/usr/bin
CMake Error: Error executing cmake::LoadCache(). Aborting.


Install cmake-data with PPM.

Added to pkgs specs. Thanks !!!
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 1385

PostPosted: Sun 22 Apr 2012, 06:24    Post subject:  

5.3.3 runs nice and stable on my VM.

Trying to compile some drivers noticed that xorg_dev_7.6 is not in the devx. No big deal. The one from the ubuntu repo solved it Smile

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
tronkel


Joined: 30 Sep 2005
Posts: 1097
Location: Vienna Austria

PostPosted: Sun 22 Apr 2012, 07:18    Post subject:  

Nice Version!

Having trouble with the ATI Radeon 6450 driver.

This has been the case with recent Puppys, but have so far managed to work around the problem by compiling the proprietary driver from the ATI website.

I can't however seem to be able to get an error-free compile using this Upup. I'm using the kernel sources as provided by the sfs and the amd-driver-installer-12-3-x86.x86_64.run downloaded ATI driver.

The open source Radeon driver seems to be kaput in the latest kernels. This is the one I actually prefer.

Would any of the Slacko ATI FGLRX pets be of any use? Has anyone had any joy using any of these?

In the meantime the VESA driver allows me to have a GUI desktop.

It's enough to show the potential that this version has. Yes, I think this would make a great official Puppy.
It's got the necessary look and feel as well.

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send private message Visit poster's website AIM Address 
tubeguy


Joined: 28 Aug 2009
Posts: 1320
Location: Park Ridge IL USA

PostPosted: Sun 22 Apr 2012, 07:36    Post subject: failed compile Gkrellweather plugin  

Code:
# make
gcc  -O2 -Wall -fPIC `gtk-config --cflags` `imlib-config --cflags-gdk`    -c -o gkrellweather.o gkrellweather.c
/bin/sh: gtk-config: command not found
/bin/sh: imlib-config: command not found
gkrellweather.c:7:29: fatal error: gkrellm/gkrellm.h: No such file or directory
compilation terminated.
make: *** [gkrellweather.o] Error 1
#

I normally compile GKrellM but this time I used a deb I found. When I went to compile the weather plugin I got this result. No biggie for me but wanted to put my report in.

_________________
Toshiba M115-S1061: PupServer |HP/Compaq D330ST: Dpup 486
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5458
Location: Finland

PostPosted: Sun 22 Apr 2012, 08:24    Post subject:  

Quote:
I can't however seem to be able to get an error-free compile using this Upup. I'm using the kernel sources as provided by the sfs and the amd-driver-installer-12-3-x86.x86_64.run downloaded ATI driver.


kernel module source has needed patching with recent ATI versions and 3.2.X and over kernels. The patching has been posted recently in howto section.
Back to top
View user's profile Send private message 
tronkel


Joined: 30 Sep 2005
Posts: 1097
Location: Vienna Austria

PostPosted: Sun 22 Apr 2012, 09:16    Post subject:  

Yep, got it - thanks Pemasu. FGLRX compiles OK now.

Simple patch here for anyone who needs it:

http://www.murga-linux.com/puppy/viewtopic.php?t=77735

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send private message Visit poster's website AIM Address 
pemasu


Joined: 08 Jul 2009
Posts: 5458
Location: Finland

PostPosted: Sun 22 Apr 2012, 09:53    Post subject:  

Maxerro posted this in Barry`s blog:

Quote:
Posted on 22 Apr 2012, 17:30 by maxerro barrys blog
I've just seen pemasu has uploaded a new version of Upup Precise, so MAYBE this is still relevant, like it has been just yesterday.
There still seems to be some library-backfiring in the crypto/ssl area, and before pemasu goes on, this needs to clear up:
backup /lib/libssl.so.0.9.8 to whatever (for now)
link /lib/libssl.so.1.0.0 to /lib/libssl.so.0.9.8
add libevent-openssl-2.0-5_2.0.16
link:
/usr/lib/libevent_openssl.so
/usr/lib/libevent_openssl-2.0.so.5
to the new /usr/lib/libevent_openssl-2.0.so.5.1.4 instead of 5.1.3
Test again, cry for help.
Although, by the final release the whole ssl-pack will need to be replaced.


This is bigger thing than first seems. Doing so...means that apps needing older 0.9.7-0.9.8 are not fooled with just symlinking. It means compiling them against libssl 1.0

Well...lefting 0.9.8 out surely soon shows what apps needs recompiling. I did compile Transmission-2.51 against libssl.so.1.0.

What else needs recompiling...someone could tell....

Libevent was the older version due to Transmision. Already updated it to use Precise Pangolin version and I did create symlinks to the older version. Will be in next uploaded Upup Precise.
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 758
Location: West Wales, Britain.

PostPosted: Sun 22 Apr 2012, 11:02    Post subject:  

I simply installed the latest Precise debs for libsll.0.9.8, libsll.1.0.0 and opensll on Barry's Precise Pup. Everything I have tested works.
_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5458
Location: Finland

PostPosted: Sun 22 Apr 2012, 11:13    Post subject:  

Yes...but that means that you have both of them libssl 0.9.8 and 1.0 on your system. If there is concensus that only libssl 1.0, updated later to security updated version is the safe way....apps depending the libsll 0.9.8 is not fooled with just symlink. You will get version symbol error.

I had already 0.9.8 and 1.0 versions included, both of them...question is...is just 1.0 safer and better solution and how many apps relies on 0.9.8. I think this was discussed and updated in Lucid Puppy. Playdayz et al could answer this.

Yeah...I would need Playdayz as "silent" advicer in this...I suppose he will check this thread at some time...
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5458
Location: Finland

PostPosted: Sun 22 Apr 2012, 11:22    Post subject:  

Here is another guide to compile latest ATI proprietary driver. It seems to have the patch I have posted.

http://www.murga-linux.com/puppy/viewtopic.php?p=621970#621970
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2445
Location: Texas, USA

PostPosted: Sun 22 Apr 2012, 12:15    Post subject:  

pemasu wrote:
Quote:
EDIT: Cannot check printing, I cannot connect to the wifi network with my laptop. Booted fine but no network connection. Info below is from Exprimo.
=== NETWORK ===

Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller
VENDOR: 10ec DEVICE: 8136 KERNEL MODULE: r8169

JJim1911. Could you dmesg and check is it asking firmware which is missing. r8169 kernel module is there so it could be missing firmware. There is now 4 new firmwares in firmware git repository, so....it might be fixable by adding missing firmware.
dmesg tells you if it complains about spesific firmware.
[ 18.422795] Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[ 18.422798] Copyright(c) 2003-2011 Intel Corporation
[ 18.422918] iwlwifi 0000:01:00.0: pci_resource_len = 0x00002000
[ 18.422920] iwlwifi 0000:01:00.0: pci_resource_base = f82fc000
[ 18.422923] iwlwifi 0000:01:00.0: HW Revision ID = 0x34
[ 18.423407] iwlwifi 0000:01:00.0: irq 50 for MSI/MSI-X
[ 18.423603] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUG disabled
[ 18.423606] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[ 18.423608] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[ 18.423611] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
[ 18.423613] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_P2P disabled
[ 18.423643] iwlwifi 0000:01:00.0: Detected Intel(R) Centrino(R) Wireless-N 1030 BGN, REV=0xB0
[ 18.423892] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
[ 18.441023] iwlwifi 0000:01:00.0: device EEPROM VER=0x71a, CALIB=0x6
[ 18.441027] iwlwifi 0000:01:00.0: Device SKU: 0x150
[ 18.441031] iwlwifi 0000:01:00.0: Valid Tx ant: 0x1, Valid Rx ant: 0x3
[ 18.441055] iwlwifi 0000:01:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[ 18.452511] iwlwifi 0000:01:00.0: request for firmware file ‘iwlwifi-6000g2b-5.ucode’ failed.
[ 18.455739] iwlwifi 0000:01:00.0: request for firmware file ‘iwlwifi-6000g2b-4.ucode’ failed.
[ 18.455744] iwlwifi 0000:01:00.0: no suitable firmware found!
[ 18.471599] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[ 18.471719] r8169 0000:03:00.0: irq 50 for MSI/MSI-X
[ 18.471881] r8169 0000:03:00.0: eth0: RTL8105e at 0xf81ac000, 84:8f:69:b0:d7:4a, XID 00a00000 IRQ 50

Hope that I've included what you need.
Jim
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 25 [373 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 23, 24, 25 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1228s ][ Queries: 13 (0.0447s) ][ GZIP on ]