Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Sep 2014, 08:21
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Upup Precise 5.3.3.3 with kernel 3.3.2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 25 [373 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 23, 24, 25 Next
Author Message
James C


Joined: 26 Mar 2009
Posts: 5760
Location: Kentucky

PostPosted: Fri 20 Apr 2012, 12:16    Post subject:  

# report-video
lspci: error while loading shared libraries: libpci.so.3: cannot open shared object file: No such file or directory
Upup Precise, version 5.3.3 on Fri 20 Apr 2012

Chip description:

oem: NVidia
product: NV18 () Board Chip Rev A2

X Server: Xorg
Driver used: nouveau

X.Org version: 1.11.4
dimensions: 1440x900 pixels (380x238 millimeters)
depth of root window: 24 planes

...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz
#
-Computer-
Processor : AMD Athlon(tm) XP 2400+
Memory : 1033MB (187MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Fri 20 Apr 2012 11:18:57 AM GMT-8
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : Mesa DRI nv18 x86/MMX+/3DNow!+/SSE
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : VIA8233 - VIA 8235

-Version-
Kernel : Linux 3.3.2-upup (i686)
Compiled : #1 SMP Wed Apr 18 20:00:55 EEST 2012
C Library : GNU C Library version 2.15 (stable)
Default C Compiler : Unknown
Distribution : Unknown distribution
Precise 5.3.3.png
 Description   
 Filesize   167.37 KB
 Viewed   1480 Time(s)

Precise 5.3.3.png

Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 20 Apr 2012, 12:33    Post subject:  

libpci3 added to the distro pkgs specs. Thanks James C.
Back to top
View user's profile Send private message 
oldyeller


Joined: 15 Nov 2011
Posts: 803
Location: Mishawaka IN

PostPosted: Fri 20 Apr 2012, 12:49    Post subject:  

Hi pemasu

Looks real good. I am running on a Dell D430 and it recognizes my hadware, but there is only one thing so far. That is I can not change screen resolution on it.

I have a ASUS 24" external screen and it stays at 1280x800 no matter how I try to change it. Well check others things soon.

oem: Intel(r) 82945GM Chipset Family Graphics Chip Accelerated VGA BIOS
product: Intel(r) 82945GM Chipset Family Graphics Controller Hardware Version 0.0

X Server: Xorg
Driver used: # vesa

X.Org version: 1.11.4
dimensions: 1920x1080 pixels (507x285 millimeters)
depth of root window: 24 planes
[ 1803.600]
X.Org X Server 1.11.4
Release Date: 2012-01-27
[ 1803.600] X Protocol Version 11, Revision 0

thanks

oldyeller

Last edited by oldyeller on Fri 20 Apr 2012, 13:04; edited 1 time in total
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2102
Location: Ontario Canada

PostPosted: Fri 20 Apr 2012, 12:54    Post subject: Upup Precise 5.3.3 with kernel 3.3.2  

I did a manual frugal install to a flash drive.
I had some problems loading the kernel source sfs but managed to get
it done using the bootmanager.
Between ppm and some pets that I have I got vlc and smplayer working.

Fri 20 Apr 2012 Operating System: Upup Precise-5.3.3 Linux 3.3.2-upup

oem: NVIDIA product: GF110 Board - 12630002 Chip Rev

X Server: Xorg Driver: nvidia
X.Org version: 1.11.4
dimensions: 1920x1080 pixels (513x292 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 560 Ti/PCIe/SSE2
OpenGL version string: 4.2.0 NVIDIA 295.40

edit: I installed kdegames in ppm it works.
kdegames.jpg
 Description   
 Filesize   22.79 KB
 Viewed   1396 Time(s)

kdegames.jpg

smplayscrn.jpg
 Description   
 Filesize   16.96 KB
 Viewed   1432 Time(s)

smplayscrn.jpg

vlcscrn.jpg
 Description   
 Filesize   15.67 KB
 Viewed   1431 Time(s)

vlcscrn.jpg


Last edited by Billtoo on Fri 20 Apr 2012, 13:44; edited 1 time in total
Back to top
View user's profile Send private message 
oldyeller


Joined: 15 Nov 2011
Posts: 803
Location: Mishawaka IN

PostPosted: Fri 20 Apr 2012, 13:16    Post subject:  

Also GParted is not working.


Upup Precise 5.3.3

84 Tasks, 3 Running. Uptime: 1:17, load average: 0.00, 0.04, 0.04

Current window manager: JWM (starts from C.L. with: 'xwin jwm')

JWM vsvn-574
ROX-Filer 2.11

Network Interface wlan0 connected

=== report-video ===

Upup Precise, version 5.3.3 on Fri 20 Apr 2012

Chip description:

oem: Intel(r) 82945GM Chipset Family Graphics Chip Accelerated VGA BIOS
product: Intel(r) 82945GM Chipset Family Graphics Controller Hardware Version 0.0

X Server: Xorg
Driver used: # vesa

X.Org version: 1.11.4
dimensions: 1920x1080 pixels (507x285 millimeters)
depth of root window: 24 planes
[ 1803.600]
X.Org X Server 1.11.4
Release Date: 2012-01-27
[ 1803.600] X Protocol Version 11, Revision 0
Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 2080
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Fri 20 Apr 2012, 13:41    Post subject: .jwmrc  

are those recommandations in head of .jwmrc really actual?

Code:
<!-- IMPORTANT, ONLY EDIT /etc/xdg/templates/_root_.jwmrc -->
<!-- jwm menu for puppy Linux -->
<RootMenu label="Menu" labeled="false" height="24" onroot="3">
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 20 Apr 2012, 13:59    Post subject:  

Yes...you need to edit that template. When you run the fixmenus, that template will updated to replace the .jwmrc which is in use
Back to top
View user's profile Send private message 
majorfoo

Joined: 07 Mar 2011
Posts: 445
Location: Wish I knew

PostPosted: Fri 20 Apr 2012, 14:02    Post subject:  

Booted from live cd

sound ok
auto connected to internet

Abiword -ok
Gnumeric - received error that libgconf.2.so.4 was missing
Copied this lib from another distro and Gnumeric opened, however, received following messages

GConf Error: Configuration server couldn't be contacted: D-BUS error: Message did not receive a reply (timeout by message bus)
process 8983: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1070.
This is normally a bug in some application using the D-Bus library.
D-Bus not built with -rdynamic so unable to print a backtrace
Aborted
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 20 Apr 2012, 14:05    Post subject:  

Gparted is missing, yes. Interesting. Gparted package has been included but....

it seems that the needed libatkmm is missing and also symlink from gpartedbin to gparted.
Will be added.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 20 Apr 2012, 14:22    Post subject:  

Quote:
Gnumeric - received error that libgconf.2.so.4 was missing
Copied this lib from another distro and Gnumeric opened, however, received following messages

GConf Error: Configuration server couldn't be contacted: D-BUS error: Message did not receive a reply (timeout by message bus)
process 8983: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1070.
This is normally a bug in some application using the D-Bus library.
D-Bus not built with -rdynamic so unable to print a backtrace
Aborted


You should have used PPM and installed libgconf-2-4_3.2.5 with it. Then Gnumeric works.

Libgconf added to the pkgs specs file. Thanks.
Back to top
View user's profile Send private message 
majorfoo

Joined: 07 Mar 2011
Posts: 445
Location: Wish I knew

PostPosted: Fri 20 Apr 2012, 14:39    Post subject:  

pemasu wrote:


You should have used PPM and installed libgconf-2-4_3.2.5 with it. Then Gnumeric works.

Libgconf added to the pkgs specs file. Thanks.


Deleted libgconf that I copied from another distro and installed above from PPM.

Gnumeric now works.

Thanks for info. I will check PPM in future for missing libs before copying from another.
.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9126
Location: Stratford, Ontario

PostPosted: Fri 20 Apr 2012, 14:40    Post subject:  

CUPS won't detect networked printers. This can be fixed by using the snmp backend from Slacko.

CUPS won't print a test page because of missing content.

In the long run, it would be less trouble to downgrade 1.5 to 1.3.11.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 20 Apr 2012, 14:57    Post subject:  

It sounds promising when rcrsn51, our cups - printer master, suggests cups downgrade.

Yeah...well. Working cups - printing is all I want. It does not matter what version it is.

http://distro.ibiblio.org/quirky/pet_packages-wary5/
Quote:
cups-1.3.11-1-w5c.pet 2011-Oct-26 17:36:28 1.3M
cups-1.3.11-2-w5c.pet 2011-Nov-01 04:35:06 1.1
cups-1.3.11-w5c.pet 2011-Sep-09 07:14:52 1.3M


There is 3 versions of 1.3.11 cups. Which one would be the one to test and use ?
Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 2080
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Fri 20 Apr 2012, 16:34    Post subject:  

2 questions:

- why did the iso increase as much?

- why in «derivatives» as BK did start this new line himself?
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 1621

PostPosted: Fri 20 Apr 2012, 16:43    Post subject:  

pemasu wrote:

Do you have a link to ubuntu kernel sources.


Code:
git clone git://kernel.ubuntu.com/ubuntu/ubuntu-precise.git


All important updates and bug/security fixes are back-ported in all LTS kernels (like 3.2).

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 25 [373 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 23, 24, 25 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0865s ][ Queries: 13 (0.0068s) ][ GZIP on ]