Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 25 Jul 2014, 19:12
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Gnome-Mplayer v1.0.5 & v1.0.6b1 (Lucid 528-004)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Fri 23 Mar 2012, 08:31    Post subject:  Gnome-Mplayer v1.0.5 & v1.0.6b1 (Lucid 528-004)
Subject description: A simple GUI for Mplayer
 

Homepage:

http://code.google.com/p/gnome-mplayer/

Info:

A GTK2/GTK3 interface to MPlayer. The power of MPlayer combined with a friendly interface for your desktop; You can play all your multimedia (audio, video, CD, DVDs, and VCDs, streams etc.), organize, sort and create playlists, take screenshots while playing videos, be notified about media changes. Full DVD and MKV chapter support, when supported by Mplayer. Subtitle support with the ability to specify preferred audio and subtitle languages if the media supports it. Support for cover art retrieval from Amazon.com for audio media files with artist and/or album information contained in the file.



It requires all of these files to be installed.

PulseAudio 1.1 ( DBus not enabled )

http://www.datafilehost.com/download-0e0d0752.html
gnome-mplayer-1.0.5-i686.pet
Description 
pet

 Download 
Filename  gnome-mplayer-1.0.5-i686.pet 
Filesize  474.88 KB 
Downloaded  545 Time(s) 
speex-1.2rc1-i686.pet
Description 
pet

 Download 
Filename  speex-1.2rc1-i686.pet 
Filesize  765.98 KB 
Downloaded  438 Time(s) 
json-c-0.9-i686.pet
Description 
pet

 Download 
Filename  json-c-0.9-i686.pet 
Filesize  51.64 KB 
Downloaded  406 Time(s) 
gmtk-1.0.5-i686.pet
Description 
pet

 Download 
Filename  gmtk-1.0.5-i686.pet 
Filesize  262.46 KB 
Downloaded  433 Time(s) 

Last edited by chrome307 on Tue 27 Mar 2012, 06:23; edited 1 time in total
Back to top
View user's profile Send private message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Tue 27 Mar 2012, 06:22    Post subject:  

gnome-mplayer 1.0.6b1



gnome-mplayer-1.0.6b1-i686.pet
Description 
pet

 Download 
Filename  gnome-mplayer-1.0.6b1-i686.pet 
Filesize  484.5 KB 
Downloaded  352 Time(s) 
Back to top
View user's profile Send private message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Tue 27 Mar 2012, 07:26    Post subject:  

Dear puppians,

Gnome-player used to be a nice GUI before they shacked up with pulseaudio, which brings in heaps of unnecessary dependencies and results in slow/bad sound: http://forums.linuxmint.com/viewtopic.php?f=29&t=33725&start=0. Is there any way to disable the pulseaudio business? I tried configuring --without-pulseaudio, but it did not seem to work and I didn't want to spend too much time investigationg why. If you know how to kill those extra dependecies via a good configure line or a modified Makefile, please post instructions:)

With kind regards,
vovchik
Back to top
View user's profile Send private message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Wed 28 Mar 2012, 08:38    Post subject:  

Hi there

I have tried to re-compile the files not to use Pulse Audio and additional libs with the following:

Gnome-Mplayer 1.05

Code:


./configure --prefix=/usr --disable-nautilus --without-pulseaudio --without-libmusicbrainz3



Gnome-Mplayer 1.06b

Code:


./configure --prefix=/usr --disable-maintainer-mode --disable-nautilus --disable-schemas-compile --disable-schemas-install --without-dbus --without-pulseaudio --without-libnotify --without-libgpod --without-libmusicbrainz3



however this seems not to make any difference as it still requires the above.

Anyway here are the pet files and I have fixed the small error regarding the missing icon.
gnome-mplayer-1.0.6b1-i686.pet
Description  'Fixed' icon error
pet

 Download 
Filename  gnome-mplayer-1.0.6b1-i686.pet 
Filesize  469.25 KB 
Downloaded  295 Time(s) 
gnome-mplayer-1.0.5-i686.pet
Description  'Fixed' icon error
pet

 Download 
Filename  gnome-mplayer-1.0.5-i686.pet 
Filesize  471.73 KB 
Downloaded  246 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 28 Mar 2012, 10:44    Post subject:  

The trick is to compile gmtk without a trace of libpulse in your compiling environment and then compile with above disabling lithany gnome-mplayer without a trace of libpulse again in your puppy.
The configure.in checks if you have libpulse or its dev headers in your system and you cant disable it if it finds them.

Quote:
AC_ARG_WITH([pulseaudio],
[AS_HELP_STRING([--with-pulseaudio],
[PulseAudio device and volume support])],
[],
[with_pulseaudio=check])
AS_IF([test "x$with_pulseaudio" != xno],
[PKG_CHECK_MODULES(PULSE, [libpulse libpulse-mainloop-glib],[AC_DEFINE([HAVE_PULSEAUDIO],[1],[Define to 1 if you have PulseAudio development packages])],AC_MSG_NOTICE([Compiling without PulseAudio support]))
AC_SUBST(PULSE_DEFINES)
AC_SUBST(PULSE_CFLAGS)
AC_SUBST(PULSE_LIBS)
])


No trace of libpulse in my gnome-mplayer-1.0.6b1 compile
Information to Application: gnome-mplayer
linux-gate.so.1 => (0xffffe000)
libm.so.6 => /lib/libm.so.6 (0xb7702000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb75e5000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb720e000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb7178000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb715c000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb7136000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb711d000)
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb7111000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb709c000)
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb7000000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb6fbc000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6f50000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb6f27000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb6ee9000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb6ee5000)
libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb6ee0000)
librt.so.1 => /lib/librt.so.1 (0xb6ed7000)
libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xb6e0d000)
libgmtk.so.0 => /usr/lib/libgmtk.so.0 (0xb6df9000)
libgmlib.so.0 => /usr/lib/libgmlib.so.0 (0xb6df3000)
libasound.so.2 => /usr/lib/libasound.so.2 (0xb6d2b000)
libXss.so.1 => /usr/lib/libXss.so.1 (0xb6d28000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb6d0f000)
libc.so.6 => /lib/libc.so.6 (0xb6bc9000)
/lib/ld-linux.so.2 (0xb772a000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6bb0000)
libdl.so.2 => /lib/libdl.so.2 (0xb6bac000)
libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb6ba9000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb6ba6000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb6ba0000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xb6b91000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb6b88000)
libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb6b85000)
libXi.so.6 => /usr/lib/libXi.so.6 (0xb6b78000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb6b70000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb6b67000)
libz.so.1 => /usr/lib/libz.so.1 (0xb6b53000)
libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb6afa000)
libpng12.so.0 => /lib/libpng12.so.0 (0xb6ad6000)
libxcb-render-util.so.0 => /usr/lib/libxcb-render-util.so.0 (0xb6ad1000)
libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0xb6aca000)
libpcre.so.3 => /lib/libpcre.so.3 (0xb6a97000)
libresolv.so.2 => /lib/libresolv.so.2 (0xb6a83000)
libselinux.so.1 => /lib/libselinux.so.1 (0xb6a68000)
libbz2.so.1.0 => /lib/libbz2.so.1.0 (0xb6a56000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb6a30000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb6a2d000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6a28000)
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 28 Mar 2012, 11:06    Post subject:  

I can upload my used gmtk and gmtk dev libs - gnome-mplayer-1.0.6b1 and gecko-mediaplayer-1.0.6b1 here or to separate thread if there is interest. The compile has been done in Dpup Exprimo
Back to top
View user's profile Send private message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Thu 29 Mar 2012, 06:48    Post subject:  

Yes please Smile

Also thank you for the advice/tips provided!!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 30 Mar 2012, 01:36    Post subject:  

These are compiled in Dpup Exprimo. Gmtk is the needed dependency in newer Gnome-Mplayer.
gnome_NLS-mplayer-1.0.6b1.pet
Description 
pet

 Download 
Filename  gnome_NLS-mplayer-1.0.6b1.pet 
Filesize  251.81 KB 
Downloaded  274 Time(s) 
gnome-mplayer-1.0.6b1.pet
Description 
pet

 Download 
Filename  gnome-mplayer-1.0.6b1.pet 
Filesize  108.05 KB 
Downloaded  300 Time(s) 
gecko-mediaplayer-1.0.6b1.pet
Description 
pet

 Download 
Filename  gecko-mediaplayer-1.0.6b1.pet 
Filesize  200.55 KB 
Downloaded  313 Time(s) 
gmtk_DEV-1.0.5.pet
Description 
pet

 Download 
Filename  gmtk_DEV-1.0.5.pet 
Filesize  173.43 KB 
Downloaded  373 Time(s) 
gmtk-1.0.5.pet
Description 
pet

 Download 
Filename  gmtk-1.0.5.pet 
Filesize  40.01 KB 
Downloaded  321 Time(s) 
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3953
Location: Kiel,Germany

PostPosted: Fri 30 Mar 2012, 03:00    Post subject:  

gnugl..grumpf:

pemasu:
gnome-mplayer: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory

chrome:
gnome-mplayer: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory


do i need devx ?
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 30 Mar 2012, 04:06    Post subject:  

About my compile. I suppose you need that lib. Probably you are using something else than Dpup Exprimo ?
Back to top
View user's profile Send private message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Fri 30 Mar 2012, 05:20    Post subject:  

Dear pemasu,

Thanks for package. It works just fine in my Lucid 525 and Midnight, too.

With kind regards,
vovchik
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3953
Location: Kiel,Germany

PostPosted: Sat 31 Mar 2012, 04:55    Post subject:  

Yeah, was installing it on racy-5.2.2 .

Forgot also racy has glibc-2.10 and lucy 2.11 ...

Nevertheless i am compiling mplayer atm too
for my version of vlc-0.9.2 does not show files without .extension in the navigation browser and would not load them .

mplayer does and additionally plays flash video .

My gxines do not play .mp4 and .flv at all .

Detected that moving the video vindow at mplayer would also stop the music if wait for 1 second, while vlc stops the video(mp4) but still plays the music moving the window . This also occurs moving some other windows not related to mplayer . LOL .

Was looking for something that might work better with these little annoyances .

Looks like i would need to compile other user-interfaces for mplayer some time .

Apropos libpulse , pemasu :

Code:
#  /tmp/gnome-mplayer-1.0.6b1/gnome-mplayer-1.0.6b1/usr/bin/gnome-mplayer

/tmp/gnome-mplayer-1.0.6b1/gnome-mplayer-1.0.6b1/usr/bin/gnome-mplayer: error while loading shared libraries: libpulse-mainloop-glib.so.0: cannot ...

Very Happy
Back to top
View user's profile Send private message Visit poster's website 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Tue 03 Apr 2012, 07:06    Post subject:  

@ Karl Godt

Quote:


gnome-mplayer: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory



I built this application using Lucid 528-004 on the default iso.

When I installed my application and run this in terminal this is the output.

I have shown the additional libs that were used to ensure the application worked.

Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3953
Location: Kiel,Germany

PostPosted: Mon 09 Apr 2012, 17:47    Post subject:  

I have downloaded the source for gnome-mplayer from debian squeeze site 0.9.9.2 and this is the one that works for me best .

1.0.2,1.0.4,1.0.5,1.0.6 have problems with changing the video size (1:2,1:1,2:1) that does not work on the later ones . My Gtk is a mix of 2.14/2.16 and the screen gets messy with popup menus leaving artifacts, the buttons vanish with overlay of the main gtk-theme-color and others . Dont know if this is i810OLD Xorg driver related . Otherwise compiles ok on my Macpup-F3 installation .

Also there is a problem with the unpatched gtk source not having one or two stock-icon-names that are used in the gnome-mplayer source
gui.c
gtk_image_new_from_icon_name("media-optical", GTK_ICON_SIZE_MENU));
i could solve by adding
/usr/local/lib/X11/mini-icons/media-optical.png
from gtk+-2.24.x source
but not the missing "Open Location" icon (think it was something like "netwok-server" icon name ) .

And it was pemasus compile still having had traces of libpulse somewhere .

But this should not matter . Normally the default compiles by Barry are difficult to match being smaller, and why crippling anything ? I just compile with everything enabled but being to lazy to study configure --help . I mostly compile ./configure and am happy if this compiles Very Happy .

Today I compiled several udevs with their dependencies like kmod,usbutils,automake-1.11,and 6 more , plus mplayer-1.0.6 again Cool .

I dont think that on Lucy mplayer-1.0.6 shows the same irritating behaviour as on PL-4.3.1 , but will boot my 511 installation some day again and have a look .
Wink
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0900s ][ Queries: 13 (0.0039s) ][ GZIP on ]