Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 01:51
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Announcements
Legacy OS 4 Mini Released
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 10 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, ..., 8, 9, 10 Next
Author Message
Sage

Joined: 04 Oct 2005
Posts: 4819
Location: GB

PostPosted: Sat 24 Mar 2012, 02:08    Post_subject:  

Quote:
John usually advocated full install

Yes, of course, but how to get there?! I have my own subterfuges to achieve that, but John might need to edit his claim and advice. Invariably, I have an HD connected, which has swap space. Purely by chance, this was not the case on one test machine. Best advice for newcomers is to do a FULL on another s-o-t-a machine and transfer the disk. Saves a lot of time, as the install is preserved even if the old banger doesn't run with it.
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5939
Location: Kentucky

PostPosted: Sat 24 Mar 2012, 03:01    Post_subject:  

Hit the top 10 on Distrowatch..... Smile
Legacy OS.JPG
 Description   
 Filesize   30.09 KB
 Viewed   1651 Time(s)

Legacy OS.JPG

Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4819
Location: GB

PostPosted: Sat 24 Mar 2012, 03:18    Post_subject:  

Oh dear! Gave it some swap space, but the initial booting didn't seem to look/find/use it. KP after switch-root, not sync-ing, etc. This can be a major issue on old kit that it is designed to use, and almost (but not quite!) the death knell for old laptops, for which additional memory may not be available and/or insertable. In all these instances, it will be necessary to install remotely on modern HW, hardly meeting the prime directive? Some folks have difficulty mounting 2.5" IDE drives into new machines on account of needing an adapter, either 40w to 44w IDE or IDE-to-SATA. No idea what options are for jiggling with the boot up coding? if any...
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5939
Location: Kentucky

PostPosted: Sat 24 Mar 2012, 04:15    Post_subject:  

I've already successfully booted Legacy OS4 Mini on several machines, so I grabbed an old Windows 98 box off the shelf. 384 Mb of ram.... no swap.

Default boot, just hitting "enter" .... kernel panic.
Booting pfix=no ram ....... kernel panic.
Booting pfix=nocopy ..... kernel panic.

Running the latest Slacko live so no hardware issues.

-Computer-
Processor : Celeron (Mendocino)
Memory : 384MB (137MB used)

-Version-
Kernel : Linux 3.1.10-slacko_4gA (i686)
Compiled : #1 SMP Tue Mar 13 14:58:11 EST 2012

-Processor-
Name : Celeron (Mendocino)
Family, model, stepping : 6, 6, 5 (Pentium II/Pentium II Xeon/Celeron)
Vendor : Intel
-Configuration-
Cache Size : 128kb
Frequency : 434.24MHz
BogoMIPS : 868.66
Byte Order : Little Endian

Might need to reconsider those minimum specs.
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4819
Location: GB

PostPosted: Sat 24 Mar 2012, 04:47    Post_subject:  

Thanks for that confirmation, James. Just wondering: Celeron & Duron are low on cache. Needs further investigating!
Back to top
View user's profile Send_private_message 
russoodle


Joined: 12 Sep 2008
Posts: 667
Location: Down-Under in South Oz

PostPosted: Sat 24 Mar 2012, 09:26    Post_subject:  

Sage wrote:
Polished, as usual. Well done again, John!
For the record, now that Skype belongs to Beelzebub, perhaps it's time to decamp to PSIP, especially as smokey has given us such a detailed exposition of its use (www.smokey01.com/help/psip/psip-help.html?

Some of us have been using Psip now for several months with great success on various 5 series Puppys, but unless John has updated certain libs, the version we're using (v1.*-2.*) won't work with this release - the default known to work with Puppy 4.* series is Psip version 0.26.

_________________
This aging business really bugs me - it didn't bother me years ago, so why is it happening now??
meownplanet - puppylinuxstuff
Back to top
View user's profile Send_private_message 
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Sat 24 Mar 2012, 09:46    Post_subject:  

Hello Everyone,
Sorry about the kernel panic problem for some of you with Ram less then 512Mb's. On some test PC's Legacy OS 4 Mini refuses to load from the CD and tries to load itself in to Ram which it can't causing the Kernel Panic error. One fix is to temporary increase the Ram to 512Mb's do the install to Hard Drive before removing the added Ram.

I'm as unhappy about this as you are. I need help / advice on finding a fix to this. I know it comes down to a bug in one of the scripts during boot up. If someone finds the bug please let me know so I can fix this problem.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send_private_message Visit_website 
russoodle


Joined: 12 Sep 2008
Posts: 667
Location: Down-Under in South Oz

PostPosted: Sat 24 Mar 2012, 09:59    Post_subject:  

john biles wrote:
Hello Everyone,
Sorry about the kernel panic problem for some of you with Ram less then 512Mb's. On some test PC's Legacy OS 4 Mini refuses to load from the CD and tries to load itself in to Ram which it can't causing the Kernel Panic error. One fix is to temporary increase the Ram to 512Mb's do the install to Hard Drive before removing the added Ram.

I'm as unhappy about this as you are. I need help / advice on finding a fix to this. I know it comes down to a bug in one of the scripts during boot up. If someone finds the bug please let me know so I can fix this problem.

John, wouldn't passing a boot parameter such as "puppy pfix=noram" be of any use?

_________________
This aging business really bugs me - it didn't bother me years ago, so why is it happening now??
meownplanet - puppylinuxstuff
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sat 24 Mar 2012, 10:06    Post_subject:  

I guess my machine is too new? You care about the
older equipments so a Netbook from 2009 or 2010 or so
has LAN cards integrated into the motherboard that the
kernel has no driver for?

The LAN drivers for Acer D255 fail to get loaded in a way
that allow it to get internet

Is that situation something that comes with the goal and
nothing to do about? I like all the other things about it.

It looks incredibly nice and pleasant to use apart from no internet.

Thanks Russ,

It is not that important to me. I do have many other linux to play with.

_________________
I use Google Search on Puppy Forum
not an ideal solution though

Edited_time_total
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4819
Location: GB

PostPosted: Sat 24 Mar 2012, 11:14    Post_subject:  

Quote:
One fix is to temporary increase the Ram to 512Mb's

Yes, that's included in the canonical subterfuges I referred to. But, it may not be available to everyone, for all sorts of quite reasonable, errr reasons, and notably those cited for poor old lappies...
Let's hope some-one can assist with a solution, otherwise it kinda defeats the principle objective for deployment on ye olde machinery.
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4819
Location: GB

PostPosted: Sat 24 Mar 2012, 14:14    Post_subject:  

More bad news, John!
For reasons you may be aware of, when I first tested your L4, I had all new kit (<= couple of months old) on the bench.
Now I have changed back to old (but certainly not ancient) kit, I find L4 won't boot. Saluki 15 and LupuPlus boot just fine (I have these at hand, and although considerably smaller than L4, they, too, are very new). Tried everything - either get an early KP as described above, or, if the memory is increased to 512, booting stalls later in the process. The only other distro to exhibit similar problems on older kit is BK's PrecisePuppy, which is highly experimental and an unfair comparison. Assume I've rung all the changes of HW, including mem., video cards, etc. I may not know a jot about code, but HW is definitely my bag.
'Fraid it looks essential to urgently fix this issue or modify claims?

Later: to be fair, I tried Anti-X M11-486. No issues. Of course, this is not a RAM only resident distro (is it?) but Puppy always used to run regardless. In the event of insufficent memory, it retained control of the CD and access thereto when required, ie exactly like other liveCD s of similar size to L4.
Back to top
View user's profile Send_private_message 
russoodle


Joined: 12 Sep 2008
Posts: 667
Location: Down-Under in South Oz

PostPosted: Sat 24 Mar 2012, 14:52    Post_subject:  

Hello Nooby Smile
Why not post a request for drivers on this thread: http://www.murga-linux.com/puppy/index.php?f=62, remembering that this release is based on Puppy 4.1...

On the subject of Psip....i downloaded, installed and successfully ran Psip 0.26 tonight, after i figured out KMix and correctly configured my sound. As previously mentioned, later versions of Psip are incompatible with 4 series Puppys but 0.26 works like a charm. I was running Legacy OS 4 Mini live on a T42P lappie with 1GB RAM.

I've attached screenies of the interface and my KMix configuration:
Psip026-mainwindow.jpg
 Description   Psip-0.26 main interface
 Filesize   41.73 KB
 Viewed   1102 Time(s)

Psip026-mainwindow.jpg

kmix-input.jpg
 Description   KMix input settings
 Filesize   33.67 KB
 Viewed   1112 Time(s)

kmix-input.jpg

kmix-output.jpg
 Description   KMix output settings
 Filesize   34.25 KB
 Viewed   1088 Time(s)

kmix-output.jpg


_________________
This aging business really bugs me - it didn't bother me years ago, so why is it happening now??
meownplanet - puppylinuxstuff
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5939
Location: Kentucky

PostPosted: Sat 24 Mar 2012, 14:57    Post_subject:  

I did notice that even though I attempted booting "pfix=noram" and "pfix=nocopy" Puppy overrode the boot parameters and still attempted to load into ram which led to the kernel panic.
I'm not that familiar with the startup scripts but I seem to recall that if Puppy detects a certain amount of ram while booting it will override and load into ram.With the larger size of Legacy OS4 I'd assume that parameter would need to be tweaked upwards.
That's my guess anyway...... Smile
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5939
Location: Kentucky

PostPosted: Sat 24 Mar 2012, 15:02    Post_subject:  

Believe this is based on Puppy 4.21 with the 2.6.25.16 kernel.The thread with extra drivers is at http://www.murga-linux.com/puppy/viewtopic.php?p=237739#237739 . Same kernel as 4.1 anyway. Smile
Back to top
View user's profile Send_private_message 
russoodle


Joined: 12 Sep 2008
Posts: 667
Location: Down-Under in South Oz

PostPosted: Sat 24 Mar 2012, 15:08    Post_subject:  

Thanks James - brain's asleep while eyes are still partially open.....5.40am here Rolling Eyes
_________________
This aging business really bugs me - it didn't bother me years ago, so why is it happening now??
meownplanet - puppylinuxstuff
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 10 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, ..., 8, 9, 10 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Taking the Puppy out for a walk » Announcements
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0875s ][ Queries: 13 (0.0078s) ][ GZIP on ]