Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 04:33
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Installing Oki printer in 531(solved, thanks Rcrsn51 :-)
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Sat 17 Mar 2012, 12:17    Post_subject:  Installing Oki printer in 531(solved, thanks Rcrsn51 :-)  

I've downloaded the print driver file, foo2zjs.tar.gz into mnt/home and am trying to unpack it. It wants to open in a directory called mnt/dev_save/foo2zjs. On an older version of Puppy (421), according to directions http://www.murga-linux.com/puppy/viewtopic.php?t=37795I wrote at the time, it wanted to unpack into mnt/foo2zjs directory. I made a directory of that path but can't figure out how to direct the new files into it - unclear: should prompt 'open into'. I tried redirecting to the new directory without success (directory empty after trying to open).

It also asks 'only supported' or 'all' which causes all files in mnt/home to be listed. Very confusing. This noob assumes that the printer wants all files unpacked into an expected directory. I don't mind accepting default but don't want to screw up since I would not know how to undo any non-obvious changes.

This did not happen in 528, however the compile didn't seem to work as for 421 (couldn't 'make compile'). I don't care if I use 531 or 528 so hope you can help me one way or the other.

I'll probably need lots of help walking through the process. Maybe I should ask if it would be easier to make the oki file into a .pet and posted somewhere permanently instead of going through the longer process and having to install the devx compiler just for this reason alone. OTOH, the idea of a permanoob making a .pet is out of the question. Something about teaching an old dog new tricks (no real interest in geeky stuff, just want to get the printer working in a newer more stable Puppy).


Edit: I was trying to follow old directions for an old distro, which are not needed with Puppy 531. As you can see from following posts, Rcrsn51 has contributed mightily to Puppy's utility in making the OKI printer work straightforwardly. Just follow the directions in the link he gives and hopefully it will work for you.

Cheers
----------------------------------------------------

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN


Edited_times_total
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9159
Location: Stratford, Ontario

PostPosted: Sat 17 Mar 2012, 12:37    Post_subject:  

There is a PET for the foo2xxx package here. You haven't stated which OKI model you have, but I'm assuming that it is supported.
Back to top
View user's profile Send_private_message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Sat 17 Mar 2012, 13:41    Post_subject:  

Hi Rscrn51, thanks for that. Unfortunately OKI C3400 is not supported by that driver per the page here

http://foo2zjs.rkkda.com/

The below page has the right driver although I don't quite follow the logic (says foo2hiperc but below instructs to download foo2zjs which is the right driver)

http://foo2hiperc.rkkda.com/

What's next?

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN


Edited_times_total
Back to top
View user's profile Send_private_message 
greengeek

Joined: 20 Jul 2010
Posts: 2560
Location: New Zealand

PostPosted: Sat 17 Mar 2012, 13:49    Post_subject:  

Hi canbyte, if you are working within a frugal install, it may be well worth making a copy of your savefile before making further changes. (If you store a copy of the .2fs savefile on a different disk you can always remove a contaminated savefile and replace it with the backup copy if something goes wrong with the printer install)

I learnt this lesson the hard way recently Smile
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9159
Location: Stratford, Ontario

PostPosted: Sat 17 Mar 2012, 14:20    Post_subject:  

canbyte wrote:
Hi Rscrn51, thanks for that. Unfortunately OKI C3400 is not supported by that driver per the page here http://foo2zjs.rkkda.com/

Yes it is. You need to read down the page where it says that the OKI C3400 is supported by the foo2hiperc driver, which is part of the package.

I own an OKI C110, which works fine with the foo2xxx pet. I have also done a simulated install of your C3400 in Slacko and it worked fine.
Back to top
View user's profile Send_private_message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Sat 17 Mar 2012, 15:00    Post_subject:  

OMG Rcrsn51 ---- It works!!!
Sorry for my confusion / crossed post / not reading straight.

Thank you sooooo mucho.

A process I was dreading, which took 2 months the first time around in 421, completed in minutes, straightforward. No hickups.

Conclusion: Rcrsn51 has been busy in the last few years!!

What a wonderful contribution. Thanks again.

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN

Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9159
Location: Stratford, Ontario

PostPosted: Sat 17 Mar 2012, 15:50    Post_subject:  

Excellent. You're not the first person to be confused by the wording of the foo2zjs website.

How are you handling colour? Did you need to install the ICM data?

You might want to make a contribution to the author. (I have.)
Back to top
View user's profile Send_private_message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Sun 18 Mar 2012, 01:20    Post_subject:  

Rcrsn51 - no I didn't get the colour part installed and can't even recall what ICM refers to. Actually I prefer it that way- I know when printing with Puppy I don't have to remember to switch off colour to save on the more expensive inks. I think of Puppy as utilitarian and Windows as bloated-do-everything so I don't mind switching over for the very occasional need to print in colour.

It was such a relief to get the OKI working so I did the same routine for 528 and on the Compaq as well while it was all fresh in my mind. So easy.

Thanks again
Cheers

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0568s ][ Queries: 12 (0.0036s) ][ GZIP on ]