Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 09:58
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
I also need/want a PDF editor
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
mgh

Joined: 03 Mar 2012
Posts: 8

PostPosted: Tue 06 Mar 2012, 15:09    Post_subject:  I also need/want a PDF editor  

I have spent a few hours but have found no working solution.

Have downloaded a PET file for both PDFEdit, and Foxit, but neither work. FDFEdit will not even open, Foxit will open, but then when I try to open a PDF file it closes.

Both programs are in the menu.

I have slacko 5.3.1.

really like Okular that I am using with Bodhi Linux.

I know others are having same problem, but I found no solution here on the forums.

Any suggestions?

Thanks
Back to top
View user's profile Send_private_message 
darkcity


Joined: 23 May 2010
Posts: 2462
Location: near here

PostPosted: Tue 06 Mar 2012, 15:50    Post_subject:  

its strange neither package worked.

did you install them from the Puppy Package Manager?

if not where did you get them?

looks like pdfedit needs libqt-3.3.8 installed.

more info here-
http://puppylinux.org/wikka/pdf

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 
8-bit


Joined: 03 Apr 2007
Posts: 3380
Location: Oregon

PostPosted: Tue 06 Mar 2012, 16:21    Post_subject:  

Try running PdfEdit from a terminal.
The terminal should show you what files are missing and needed
Back to top
View user's profile Send_private_message 
mgh

Joined: 03 Mar 2012
Posts: 8

PostPosted: Tue 06 Mar 2012, 17:04    Post_subject:  

I can find nothing in the Puppy package manager under document or business for a PDF editor.

When I tried to run pdfedit via console, I got message "error while loading shared libraries, libaudio.so.2"

Unfortunately I am too new to Puppy to know how to find and install the library I am missing.

I will keep trying. Thanks for the help
Back to top
View user's profile Send_private_message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Tue 06 Mar 2012, 19:47    Post_subject: pdf editor
Sub_title: Use LibreOffice-3.4.5 Draw
 

The best editor I have found is Draw. Open the pdf in Draw. Edit it. Export as pdf.
Back to top
View user's profile Send_private_message Visit_website 
mgh

Joined: 03 Mar 2012
Posts: 8

PostPosted: Tue 06 Mar 2012, 21:07    Post_subject: Re: pdf editor
Sub_title: Use LibreOffice-3.4.5 Draw
 

Henry wrote:
The best editor I have found is Draw. Open the pdf in Draw. Edit it. Export as pdf.


Is there a way with Puppy to install only LibreOffice Draw? Or do I have to install the entire suite?

Thanks
Back to top
View user's profile Send_private_message 
Jasper


Joined: 25 Apr 2010
Posts: 1144
Location: England

PostPosted: Tue 06 Mar 2012, 22:00    Post_subject:  

Hi,

I'm also using Slacko 5.3.1 and the sfs version of LibreOffice works well and seems low on resources so it may not matter if you cannot install Draw as a standalone program.

My regards
Back to top
View user's profile Send_private_message 
mgh

Joined: 03 Mar 2012
Posts: 8

PostPosted: Tue 06 Mar 2012, 23:04    Post_subject:  

I'll give LibreOffice a try.
Back to top
View user's profile Send_private_message 
darkcity


Joined: 23 May 2010
Posts: 2462
Location: near here

PostPosted: Thu 08 Mar 2012, 14:19    Post_subject:  

PDFedit 0.45 works in Polarpup 005 and Wary 5 see-

http://murga-linux.com/puppy/viewtopic.php?t=70259

not much help if your on slacko ; -)

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 
mhanifpriatama

Joined: 22 Jan 2011
Posts: 60

PostPosted: Sat 28 Apr 2012, 02:40    Post_subject:  

I use inkscape 0.48 (not lite). But, you can only edit page by page.
Then, you can merge those pdf (use peasypdf, just write on terminal).
Note: you just open inkscape, then open pdf file, choose the page that what you want. After edit, save with .pdf filetype.
And, you must have font installed like in pdf's file.
Back to top
View user's profile Send_private_message 
mhanifpriatama

Joined: 22 Jan 2011
Posts: 60

PostPosted: Sat 28 Apr 2012, 02:56    Post_subject:  

This is a way to extract font from pdf and install to puppy.

First, download a script from this :
http://svn.ghostscript.com/ghostscript/trunk/gs/toolbin/extractFonts.ps

place extractFonts to a directory (example /root)
place your pdf's file to that directory
open terminal
type : cd /root then enter
type : gs -q -dNODISPLAY extractFonts.ps -c "(somefile.pdf) extractFonts quit"

open the directory with rox. Copy *.ttf to /root/.fonts (you must make that directory).
Back to top
View user's profile Send_private_message 
Puppyt

Joined: 09 May 2008
Posts: 568
Location: Gatton, Queensland

PostPosted: Sat 28 Apr 2012, 08:29    Post_subject:
Sub_title: pdfshuffler 0.5.1
 

I'm also in the hunt for an excellent pdf editor, but one that manages pages - reordering and cropping, differently to the way you seem to be describing. Have a look at "pdfshuffler" here http://murga-linux.com/puppy/viewtopic.php?p=329125#329125. I just wish I knew how to compile, or I might have a bash at constructing a pet of the latest version of the software here: http://sourceforge.net/projects/pdfshuffler/.
_________________
Toowoomba Linux Community
http://groups.google.com/group/toowoombalinux
Back to top
View user's profile Send_private_message Visit_website 
disciple

Joined: 20 May 2006
Posts: 6447
Location: Auckland, New Zealand

PostPosted: Sat 15 Sep 2012, 07:03    Post_subject:
Sub_title: pdfshuffler 0.5.1
 

Puppyt wrote:
I'm also in the hunt for an excellent pdf editor, but one that manages pages - reordering and cropping, differently to the way you seem to be describing. Have a look at "pdfshuffler" here http://murga-linux.com/puppy/viewtopic.php?p=329125#329125. I just wish I knew how to compile, or I might have a bash at constructing a pet of the latest version of the software here: http://sourceforge.net/projects/pdfshuffler/.

Pdfshuffler does not need to be compiled, as it is written in Python, which is a scripting language. So compiling should not be an issue unless some compiled dependencies are missing.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
glene77is


Joined: 17 Aug 2010
Posts: 112
Location: Memphis, TN, USA

PostPosted: Thu 15 Nov 2012, 09:00    Post_subject:  

@darkcity,

darkcity wrote:

PDFedit ...
not much help if your on slacko ; -)


I installed both Puppy Lucid 5.25 and Puppy Slacko 5.3.3, frugal.
I menu into one-or-the-other.

I boot Slacko normally for other reasons.
I boot Lucid in order to run PDFedit.

I do wish I had PDFedit working under Slacko.

I commonly use PDFedit to extract the ENTIRE text of a PDF file,
for a copy-paste into Libre-Office Write.

Libre-Office Draw will extract small portions of a PDF,
for copy-paste into Libre-Office Write,
but it is very cumbersome compared with PDFedit.

_________________
Puppy Linux is more fun than a barrel of M$ monkeys Razz
glene77is --- {^,^} --- electricity is shocking, Memphis, TN, USA.
Back to top
View user's profile Send_private_message Visit_website 
disciple

Joined: 20 May 2006
Posts: 6447
Location: Auckland, New Zealand

PostPosted: Thu 15 Nov 2012, 16:17    Post_subject:  

Quote:
I commonly use PDFedit to extract the ENTIRE text of a PDF file,
for a copy-paste into Libre-Office Write.

Do you get better results that way than just copying and pasting from your pdf viewer?

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0771s ][ Queries: 12 (0.0057s) ][ GZIP on ]