Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 05:38
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Geeqie Image Viewer
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 3 Posts_count   Goto page: Previous 1, 2, 3
Author Message
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 01 Mar 2012, 07:45    Post_subject:  

We can go on like this forever. It is a shame that Nooby fail with even the basic things.
Does he even know to do his own shoelaces?
Haha nope Nooby don't. He ggogled and found an Englishmen "Boyscout"
listing all the standard versions. Nooby still don't know how to do it.

the text where too English for him to grasp. But the drawings where nice.

Give me more give me more. If you guys can do it then show it to me Smile

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 01 Mar 2012, 12:12    Post_subject:  

I do like Geeqie also. I compiled Geeqie-1.0 in dpup exprimo. It has 3 edit with additions to edit with Fotoxx, mtPaint and Gimp. Fotoxx and mtPaint are included in dpup exprimo.

Imgur photo uploader has been included to the edit selection. It launches imgur photo uploader gui.
Imgur script needs Yad to work. Easily found from this forum.

Geeqie is sensitive to right libexiv2 versions. They are included in dpup exprimo due to Fotoxx so they are not in my pet.

But trying it in other puplet might be fruitless and you will need to hunt libexiv2 for it anyway.
And I dont have a clue how you can do that Very Happy
geeqie-1.0-dpup.pet
Description 
pet

 Download 
Filename  geeqie-1.0-dpup.pet 
Filesize  436.34 KB 
Downloaded  541 Time(s) 
geeqie_NLS-1.0-dpup.pet
Description 
pet

 Download 
Filename  geeqie_NLS-1.0-dpup.pet 
Filesize  580.52 KB 
Downloaded  429 Time(s) 
geeqie_DOC-1.0-dpup.pet
Description 
pet

 Download 
Filename  geeqie_DOC-1.0-dpup.pet 
Filesize  266.1 KB 
Downloaded  427 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 01 Mar 2012, 15:30    Post_subject:  

Thanks Pemasu. The one I used to test install on Slacko
where another one named i486 while yours is named dpup
in same place.

So maybe both lack the lib needed for slackware?
I give it a try. Thanks for wanting to find solution.

Edit yes it says that I need this one libexiv2.so.9

I try to start it to see what happens

# geeqie
geeqie: error while loading shared libraries: libexiv2.so.9: cannot open shared object file: No such file or directory

Ah okay. So much for Slacko being the next official Puppy.
I mean if it fails to do Geeqie then what usage is it?

Does Saluki do Geeqie? Which pet would be best for it?

Don't seems to work in Saluki either. I only tested the i486 version.
Missing libexiv2.so.6 instead of libexiv2.so.9
Google pnly find RPM versions of libexiv2.so.9
Would it be possible to remake such for Puppy?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
jrb


Joined: 11 Dec 2007
Posts: 1040
Location: Smithers, BC, Canada

PostPosted: Fri 02 Mar 2012, 10:57    Post_subject:  

nooby wrote:
Ah okay. So much for Slacko being the next official Puppy.
I mean if it fails to do Geeqie then what usage is it?

Would it be possible to remake such for Puppy?

Heres an install script which will create the libexiv2.so.9 link needed by geeqie-1.0-dpup.pet in whatever puppy you happen to be using.

I tried it in Slacko - Very Happy ,Racy - Very Happy , Lucid - Sad . Give it a try and see what happens.
Here's the code:
Code:
#!/bin/sh
 cd /usr/lib

 #for libexiv2
 IV=`ls --file-type libexiv2.so.* | grep -v @`
 ln -s $IV -T libexiv2.so.9
 
 if [ -e /usr/lib/libexiv2.so.9 ]
   then
      xmessage "install successfull"
   else
      xmessage "install failed"
 fi

This could be included in a pinstall.sh as outlined in Make your pinstall.sh script work in all puppies
Cheers, J

Note: I had to place in tar.gz file to attach it. Just click on file to extract it and then use.
geeqie-dpup-install.tar.gz
Description  Install Geeqie-dpup in other pups
gz

 Download 
Filename  geeqie-dpup-install.tar.gz 
Filesize  293 Bytes 
Downloaded  413 Time(s) 
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 02 Mar 2012, 11:35    Post_subject:  

Thanks jrb. I have reuploaded the geeqie-1.0-dpup pet with pinstall.sh script. I also fixed the edit with so that now it really shows the application links and can launch other applications.
As bonus....it has now imgur photo uploader edit with functionality and the uploading script has been included.
Happy photo uploading.
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 02 Mar 2012, 15:05    Post_subject:  

Thanks to both of you
Oh and Jemimah told us she has added Geeqie to the Saluki repo too.

What version that is remains to see. So for Slacko and Racy I should use
your version? and for Saluki I most likely should use Jemimah's version.

I give it a try.

But doing script or tar I usually fail with such. But if pemasu has
included it in that pet then it just works ? Well I will find out.
I will reboot and see what happens.

Haha I got so disappointed with Slacko and saluki that I deleted both of them.
So typical nooby. A moody guy

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 02 Mar 2012, 15:10    Post_subject:  

pemasu wrote:
I do like Geeqie also. I compiled Geeqie-1.0 in dpup exprimo. It has 3 edit with additions to edit with Fotoxx, mtPaint and Gimp. Fotoxx and mtPaint are included in dpup exprimo.

Imgur photo uploader has been included to the edit selection. It launches imgur photo uploader gui.
Imgur script needs Yad to work. Easily found from this forum.

Geeqie is sensitive to right libexiv2 versions. They are included in dpup exprimo due to Fotoxx so they are not in my pet.

But trying it in other puplet might be fruitless and you will need to hunt libexiv2 for it anyway.
And I dont have a clue how you can do that Very Happy

is it this link or should I look for your account at Smokey o Russoodle or
something? not sure where it is the latest version?
http://www.murga-linux.com/puppy/viewtopic.php?p=608631#608631

Edit Thanks to all involved
I got it workin for Slacko and Saluki and dpup and lucid too Much appreciated Smile

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
amj

Joined: 28 Jan 2011
Posts: 28

PostPosted: Wed 06 Jun 2012, 05:24    Post_subject:  

I stumbled across this thread yesterday and decided to add a comment.

I'm pleased to hear someone is trying to keep the old gqview going, it's easily the most sensible and convenient image viewer I have ever found.

One of several reasons I was started experimenting with Puppy was because the Lucid Puppy 520 documentation told me I could install Debian packages.

So I installed the Debian package <gqview_2.0.1-1_i386.deb> and it works. I have three puppy systems (two Lucid 520 and one Lucid 525) and from my point of view, gqview works perfectly on all three systems. I'm not going to claim I've tested every last bit of funcionality, but the core functionality all works as it should.
Back to top
View user's profile Send_private_message 
Eyes-Only


Joined: 10 Aug 2006
Posts: 1046
Location: La Confederation Abenaquaise

PostPosted: Wed 06 Jun 2012, 08:49    Post_subject:    

Thank you so very much pemasu for compiling Geeqie for dpup and doing such an exquisite job of it at that! It works beautifully! - especially upon both my Slacko and my 3-Headed-Dog. Smile

I really appreciate the fine work you've done for we Puppians who can't do these type of things. You - and those of your calibre - greatly increase our computer enjoyment. Keep up the great work one and all!

Chhers/Amicalement,

Eyes-Only
"L'Peau-Rouge d'Acadie"

_________________
*~*~*~*~*~*
Proud user of LXpup and 3-Headed Dog. Cool
*~*~*~*~*~*
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Wed 06 Jun 2012, 08:57    Post_subject:  

Pemasu is a true Gem.
_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
Pelo


Joined: 10 Sep 2011
Posts: 3221
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 22 Nov 2013, 01:05    Post_subject: Geeqie 1.1 Slacko PPM  

Slacko has geeqie-1.1 available in its PPM
Printing stuff is here. I have no printer. So I dont know if geeqie does it. But it should.
Print.jpg
 Description   
 Filesize   72.99 KB
 Viewed   284 Time(s)

Print.jpg

geeqie-1.1.png
 Description   
 Filesize   13.04 KB
 Viewed   283 Time(s)

geeqie-1.1.png

Back to top
View user's profile Send_private_message YIM 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 22 Nov 2013, 06:57    Post_subject:  

I use one of the older one daily
but I am so noob that I don't dare to test
a new one but thanks very much fpr all the effort.

what one of the older lack is that when one go
from one picture to next and it is an animated Gif
then it only show a still while Viewnior automatically
realize that one want to see it animated.

Have I forgot to check some box about that or is the new one
maybe better at such?

I usually use Lupu so maybe Ican update slacko with this one
and keep the old one for Lupu? do they ahve files that get overrridden
if one have two?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 3 Posts_count   Goto page: Previous 1, 2, 3
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0822s ][ Queries: 13 (0.0111s) ][ GZIP on ]