Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 21:38
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.4.12 with 3.4.2 kernel.
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 87, 88, 89 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 25 Feb 2012, 10:58    Post subject:  

backi. Good news. I thought about asking you to check the md5sum....since your drivers should have been troubleless.
I am relieved....anyway....I found one realtek driver more r8169.ko which also needs firmware. Somehow I forgot to add it. I will create new release which have it and I also fix those 2 bugs which Shinobar pointed out with firstrun package.
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 4220
Location: Earth

PostPosted: Sat 25 Feb 2012, 15:17    Post subject: Running OK  

5X327 working fine as a Live Meda OS.

Although this is not a problem, I am curious why the OS RAM needs reduce when SLACKO Pristine is boot from multi-session Live media, then SAMBA subsystem installed, then the session saved onto the Live media at system reboot. When PC is rebooted, SAMBA is running, RAM usage is less than it was before shutdown ???

This has "in no way" impacted system operations.

But, I'm just curious for an explanation. (Reported here with reports)

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 601
Location: Pennsylvania U.S.

PostPosted: Mon 27 Feb 2012, 21:48    Post subject: 3.2.7 Kernel  

Last few days I've been doing some rather extensive testing with Dpup Exprimo 5.X.3.2.7 with 3.2.7 kernel.

Everything is working just 'Great' and I've encountered but one single problem with a previous installed slideshow program however that was quickly fixed with a simple re-install!

Now... pemasu... you worked with me before on a different thread on my wifi... I never did get it going with any other puppy version including previous versions of Exprimo and 'I want to thank you for all the time spent there'... however... to put some icying on your cake... I am posting this message from Exprimo with the 3.2.7 kernel and yes... 'I'm running on WiFi!!!' Wink

Just want to thank you for having the guts to go for the newer kernel when it seems all others are kind of holding back for one thing or another. There isn't any question in my mind that the newer kernel is in fact the reason I am now on wireless network! Oh... besides... it seems everything else a bit better and faster too! 'Keep after it!'

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 601
Location: Pennsylvania U.S.

PostPosted: Tue 28 Feb 2012, 00:47    Post subject: Exprimo Desktop  

Just a quick Pic of one of the desktops with the new kernel!
Dpup-Desktop-1.png
 Description   
 Filesize   321.48 KB
 Viewed   1730 Time(s)

Dpup-Desktop-1.png


_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 28 Feb 2012, 03:42    Post subject:  

sszindian. That was good news. Could you check what driver module you are using with your wireless. I would like to know if my firmware update was also useful.
Check with Barrys simple network setup ie SNS the loaded module name in the first panel. It is announced there.
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3402
Location: Sydney Australia

PostPosted: Tue 28 Feb 2012, 06:34    Post subject:  

Mr pemasu has succeeded with loading the dreaded b43

in this Dell Studio XPS 1340

Nothing to do, Frisbee just picked it up when I clicked the connect button.

Impressive.

And many thanks.....Chris.

:::::::::::::

Windows inf reads....

DriverVer=09/20/2007, 4.170.25.12
CatalogFile =BCM43XX.CAT
CatalogFile.NTamd64=BCM43XX64.CAT
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 28 Feb 2012, 07:24    Post subject:  

Pupzo posted about bug with heavy encryption in dpup exprimo 5.X.13.6 thread. The same bug applies with 5.X.3.2.8 build.
Losetup binary does not do its work. I have included in attached fix pet the working version from Racy.
If you want to create heavy encrypted savefile....for example for usb stick usage and you are afraid that the stick with your important stuff will be stolen....
Install this pet....use ext2 as savefile filesystem and in next boot the password - aes - handling works and you can mount the savefile.
This fix migth be needed for light encryption also....but that is unsafe anyway....lol...

cthisbear. That is also good news...it looks like that the wireless drivers....firmware updates really do its job.
It gives confirmation that kernel updates are sometimes useful.
heavy-encryption-fix-0.0.1.pet
Description 
pet

 Download 
Filename  heavy-encryption-fix-0.0.1.pet 
Filesize  10.54 KB 
Downloaded  561 Time(s) 
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 601
Location: Pennsylvania U.S.

PostPosted: Tue 28 Feb 2012, 09:28    Post subject: Module request  

pemasu:

(Module you requested for my wifi setup)

Hmmm... BK's Simple Network doesn't seem to want to come up anywhere? Frisbee takes over!!! anyway, I'm certain the module is rt2800usb as I well remember that from all other 'try's' previously with the SNS.

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 28 Feb 2012, 09:33    Post subject:  

Okay...In console...sns should awaken sns.
And in console....lsmod...tells all loaded modules.
rt2800usb.ko got new firmware rt2870.bin. It was one of those updated ones.
Code:
# modinfo rt2800usb
filename:       /lib/modules/3.2.7-dpup/kernel/drivers/net/wireless/rt2x00/rt2800usb.ko
license:        GPL
firmware:       rt2870.bin
description:    Ralink RT2800 USB Wireless LAN driver.
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 601
Location: Pennsylvania U.S.

PostPosted: Tue 28 Feb 2012, 11:41    Post subject:  Got it  

OK... I see it!
sns-2.png
 Description   
 Filesize   23.14 KB
 Viewed   1581 Time(s)

sns-2.png

sns-1.png
 Description   
 Filesize   66.09 KB
 Viewed   804 Time(s)

sns-1.png


_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 433
Location: GERMANY

PostPosted: Wed 29 Feb 2012, 07:07    Post subject:  

Hi pemasu !
Using mostly this derivat now for testing . (using DpupExprimo 327 on a Usb stick)
Exept in the beginning ,it did not save my keyboard country settings (german ).
Solved this with downloading - installing language pack .

So far.....can not find anything wrong . (in case i find ...will give you feedback )
Thanks for your hard work .
Cheers !!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 29 Feb 2012, 19:02    Post subject:  

Thank you all of the feedback. I have somewhat cleaned and updated more the firmwares for wireless drivers. I also compiled latest 3.2.8 kernel. It has now also driver for intel gma 5/600 graphics.
Nouveau kernel module has been included and through woof nouveau_unload script has been included.
I used the latest woof2 commit. All previous bugs has been fixed, remedy suggestions by Shinobar.
Heavy encryption bug has been fixed.

So Dpup Exprimo 5.X.3.2.8 with kernel 3.2.8 - SMP -hyperthreading - hibernation included has been uploaded.

Download link: http://www.smokey01.com/pemasu/DpupSqueeze5X/DpupExprimo5X328/

Kernel sources and pet: http://www.smokey01.com/pemasu/Kernel_sources/kernel-3.2.8/
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5710
Location: Kentucky

PostPosted: Wed 29 Feb 2012, 20:51    Post subject:  

Downloaded. Testing to begin shortly.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5710
Location: Kentucky

PostPosted: Wed 29 Feb 2012, 22:31    Post subject:  

Now that the threat of a tornado has left my area......... 5.X3.2.8 live pfix=ram on my main Athlon XP box. All basics working on initial boot.

# report-video
Dpup Exprimo, version 5.X.3.2.8 on Wed 29 Feb 2012

Chip description:
0.0 VGA compatible controller
nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev c1)
oem: NVidia
product: NV18 () Board Chip Rev A2

X Server: Xorg
Driver used: is

X.Org version: 1.7.7
dimensions: 1440x900 pixels (411x263 millimeters)
depth of root window: 24 planes

...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz
#
-Computer-
Processor : AMD Athlon(tm) XP 2400+
Memory : 1033MB (176MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Wed 29 Feb 2012 08:32:24 PM CST
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : VIA8233 - VIA 8235

Frugal install coming shortly........
Back to top
View user's profile Send private message 
Fishy

Joined: 26 Jan 2006
Posts: 202

PostPosted: Wed 29 Feb 2012, 22:41    Post subject:  

Works great, no problems at all. One question though, does it support more than 4 giigs of ram?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 87, 88, 89 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0910s ][ Queries: 13 (0.0153s) ][ GZIP on ]