Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 12:53
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Grub4DosConfig
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 19 of 23 Posts_count   Goto page: Previous 1, 2, 3, ..., 17, 18, 19, 20, 21, 22, 23 Next
Author Message
noryb009

Joined: 20 Mar 2010
Posts: 539

PostPosted: Thu 28 Apr 2011, 21:22    Post_subject:  

gcmartin:

Add this to your menu.lst:
Code:

find --set-root --ignore-floppies /path/to/file.iso
map /path/to/file.iso (hd32)
map --hook
root (hd32)
chainloader (hd32)
boot


More info here: http://diddy.boot-land.net/grub4dos/files/map.htm#hd32

EDIT:
Just read the thread you linked.
1) Install GRUB4DOS to the USB
2) Create/edit menu.lst in the root(?) of the drive with the above code
3) Set boot flag.
4) Reboot and start from the USB.
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 28 Apr 2011, 22:26    Post_subject:  

Yes such code works on USB but it fail to boot iso on internal HDD that are formatted in NTFS unless you make a partition with ext2 or such or go the USB route while Grub2 using the loop thing can boot from hdd if one have grub2 on the usb but the iso on the internal hdd I am on such now Peppermint-Ice-10012010.iso
_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
vanchutr

Joined: 05 Aug 2006
Posts: 427

PostPosted: Fri 29 Apr 2011, 21:24    Post_subject:  

This is my works. It may be good on others systems? Please test it and give me more informations!

How to boot an .iso from grub
1. I'd make an iso file with this code

Code:

mkisofs -R -b grldr -no-emul-boot -boot-load-size 4 -o grldr.iso iso_root


*** The grldr.iso contains these files: ..., vmlinuz, initrd.gz, pup-432.sfs, ... and others appropriates stuffs

2. Copy the made "grldr.iso" to C: (C: is an Windows' partition - fat 32). This is an partition is managed by grub loader.
3. Start Windows and run "WinContig" to defrag C: partition
4. Now restart the machine. Then I can boot the made "grldr.iso". This is the menu entry to boot the .iso file:
Code:

title TEST 1 BOOT PUPPY ISO ON C AND RUN IN RAM
find --set-root --ignore-floppies /grldr.iso
map /grldr.iso (hd32)
map --hook
root (hd32)
chainloader (hd32)
boot


*** If I don't use "WinContig" -> Boot this "grldr.iso", I will meet this error: "Error 60: File for drive emulator must be in one contiguous disk area".
NB: Before test this, I'd renamed all the pup-432.sfs in hard disk (in all partitions). This is sure to know that the system boot "grldr.iso"
This will help me to test new puppy's .iso (without need virtualbox or other emulator ... may be?)

Thank
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sat 30 Apr 2011, 03:40    Post_subject:  

vanchutr , yes thanks, the reason it works are that you have Fat32 while AFAIK all new computers sold in Sweden with Windows on them have format NTFS that was so on the latest 5 computers that I bought since 2003 and I don't plan to buy another one. Smile

Sure you can wipe out all the Ms or you can take away the warranty from the OEM by resizing the whole thing. I am not into such things. I want true Dual boot with total compatibility and grub2 on the usb stick gives me that.

It start booting from the usb but take the iso from the HDD. No change to the Ms Windows is needed.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Mon 05 Sep 2011, 22:26    Post_subject:  

Using v1.7 on a frugal install ext4 flashdrive. several times on different boxes it would not recognize puppy frugal installs on the hdd. either on ext3 or ext4 would not recognize the os.

have not read all pages but this is probable known bug. I reverted to v1.6ish and did recognizes those previously lost pups. hope helps.
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2630
Location: Japan

PostPosted: Sat 29 Oct 2011, 11:28    Post_subject: UPDATE: grub4dos-0.4.4.v1.7.1  

Was failed with some environmnt when the 1st partition is ext4 file system.
grub4dos-0.4.4.v1.7.1.pet (Update: 29 Oct 2011) now available. See top post of this ropic.
You are encouraged to give feed back as a replay of this topic.

* 29oct11 v1.7.1: fix was failed with ext4(thanks to jim3630 and billtoo), drive letter, gtkdialog4 thanks to 01micko, help button, no sort probepart, bootable check

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Wed 02 Nov 2011, 17:19    Post_subject:  

Quote:
grub4dos-0.4.4.v1.7.1.pet (Update: 29 Oct 2011) now available. See top post of this ropic.
You are encouraged to give feed back as a replay of this topic.

* 29oct11 v1.7.1: fix was failed with ext4(thanks to jim3630 and billtoo), drive letter, gtkdialog4 thanks to 01micko, help button, no sort probepart, bootable check

Shinobar, I am not clear. Are these bugs in the latest 1.7.1 version? If so, is there a fix coming soon? Thanks.
Back to top
View user's profile Send_private_message 
Ray MK


Joined: 05 Feb 2008
Posts: 765
Location: UK

PostPosted: Wed 02 Nov 2011, 17:51    Post_subject:  

Hi playdayz

My understanding is -

The failing was in 1.7 - where if the first parttion on a drive
was formated ext4 - grub4dos failed to work.
(ext2, ext3 as first partition worked)

grub4dos 1.7.1 fixed the failing ext4 first partition scenario.

HTH - very best regards - Ray
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2630
Location: Japan

PostPosted: Wed 02 Nov 2011, 21:55    Post_subject:  

@playdayz
v1.7.1 is bug fixed version as Ray says.
But i tested on the Lucid Puppy 528, the old (version v1.7) still works with no problem.

Means you need not upgrade grub4dos as for the lupu 528 version.
Consider to upgrade at next lucid test release if you have a plan.

Ray MK wrote:
The failing was in 1.7 - where if the first parttion on a drive
was formated ext4 - grub4dos failed to work.

Right. But the failure depends on the version of util-linux(fdisk).
It occurs on Racy beta 2. (Potentially on Wary 5.2, Slacko if users manually install grub4dosconfig v1.7.)
No problem on Lucid 528, LupQ-511, Quickset Wary-511-01q...

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Fri 13 Jan 2012, 18:20    Post_subject:  

I think grub4dosconfig is having difficulty with my card reader.

Code:
grub4dosconfig
BINSTALLER=bootlace.com
sda(MBR)_250.1GB_ATA_WDC_WD2500BEKT-6
fd0_(FLOPPY_DISK)
mmcblk0p_0kB_
sdb_160.0GB_WD_1600BEV_External
sdd_1.9GB__USB_Flash_Memory

# df -h /mnt/mmcblk0p1/
Filesystem            Size  Used Avail Use% Mounted on
/dev/mmcblk0p1        3.9G   83M  3.8G   3% /mnt/mmcblk0p1


You can see it's reporting 0kb but it's not doing the right thing with partition name, which is I suppose should be mmcblk0, not mmcblk0p. The device names with these card readers seem not to follow the normal naming convention.
Back to top
View user's profile Send_private_message Visit_website 
shinobar


Joined: 28 May 2009
Posts: 2630
Location: Japan

PostPosted: Sun 15 Jan 2012, 10:44    Post_subject: Grub4DosConfig v1.7.2  

UPDATE: grub4dos-0.4.4.v1.7.2.pet

v1.7.2: fix was mmc card(ex. mmcblk0p1) failed(thanks to jemimah), which vmlinuz and initrd should be taken(thanks to Karl)

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
don570


Joined: 10 Mar 2010
Posts: 3307
Location: Ontario

PostPosted: Sat 07 Apr 2012, 12:58    Post_subject:  

I used pemasu's exprimo which has the Enlightenment WM


It seems to have a bug when scripts don't finish nicely with 0

so when I close grub4dos I get this....


It's a common bug. It usually can be solved by putting a zero
after exit. So for example I did the following

line 623 of usr/sbin/grub4dosconfig
change
Code:
[ "$EXIT" = "OK" ] || exit


to

Code:
[ "$EXIT" = "OK" ] || exit 0
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2630
Location: Japan

PostPosted: Mon 30 Apr 2012, 06:29    Post_subject: Grub4DosConfig v1.7.9  

Test release: grub4dos-0.4.4.v1.7.9.pet (2012-04-30)
http://shino.pos.to/linux/puppy/
# 28apr12 v1.7.9: improved detecting special puppies like LHP, advanced menu, old menus, legacy grub compatible menu, splash image, text domain, exit status (thanks to don)
Document
This release is not bugfix, but improved and has new features. Welcome your feedback.

Highlight of the new features:
  1. Pupplet detection
    Detects LazY Puppy, LightHousePup, was not auto-detected.
  2. Advanced menu
    Advanced menu is shown behind the top menu, at the second page.
  3. Old menus
    The grub4dosconfig makes back up the existing old menus. You can go back with choosing the "Previous menu" in the 'Advanced menu'.
  4. Splash image
    You can make background image behind the bootup menu. The image will need to be in the .xpm format and must be 640x480 pixels with a maximum of 14 colours. Place the image file with name 'splash.xpm' at the same place of the 'menu.lst' file. You can make your original splash image by using the mtpaint or the gimp. (Grub4dos Guide - Creating a Splash Image)
    EDIT: You need to comment out the 'color' line both from menu.lst and menu-advanced.lst if you use the splash image.
    menu*.lst wrote:
    # menu.lst produced by grub4dosconfig-v1.7.9
    #color white/blue black/cyan white/black cyan/black
    splashimage=/splash.xpm

  5. Legacy grub compatible
    you can take the "Legacy compatible 'menu.lst'" option. Then the grub4dosconfig avoids grub4dos specific commands. Note that this option is only for ones who want and can manage it.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
Pete22


Joined: 08 May 2009
Posts: 239
Location: Utah, USA

PostPosted: Tue 01 May 2012, 20:23    Post_subject:  

It now will recognize lhp!!!! That really makes my day. Very Happy

Trying it out I noticed a few possible bugs.

If I select the advanced menu, it highlights everything instead of one line.
If I go back to main menu, it will still have all the lines highlighted.


Is that how you meant for the new version to work?

I also noticed it did not see Legacy puppy.


Pete
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2630
Location: Japan

PostPosted: Tue 01 May 2012, 23:00    Post_subject: using splash  

Pete22 wrote:
If I select the advanced menu, it highlights everything instead of one line.
If I go back to main menu, it will still have all the lines highlighted.

Yeh, i realized the problem with using splash image.
Comment out the 'color' line both from menu.lst and menu-advanced.lst if you use the splash image.
menu*.lst wrote:
# menu.lst produced by grub4dosconfig-v1.7.9
#color white/blue black/cyan white/black cyan/black
splashimage=/splash.xpm

Pete22 wrote:
I also noticed it did not see Legacy puppy.

Which puppy do you mean?

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 19 of 23 Posts_count   Goto page: Previous 1, 2, 3, ..., 17, 18, 19, 20, 21, 22, 23 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1103s ][ Queries: 13 (0.0131s) ][ GZIP on ]