Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 05:14
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Making the Tenda wireless-N USB adapter work in Lucid
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
torgo

Joined: 09 Sep 2011
Posts: 44

PostPosted: Sun 18 Dec 2011, 18:55    Post_subject:  Making the Tenda wireless-N USB adapter work in Lucid
Sub_title: (no luck in Slacko, but it's great in Lucid.)
 

MicroCenter (web site and a handful of stores scattered across the U.S) carries a brand of dirt cheap wireless routers and adapters called Tenda. The USB wireless-N adapters are nearly always OVERPRICED for $10 each.

$10 to add wireless-N to any computer with a free USB port? That's tough to pass up. But the obvious question is whether we can get it to work.

The good news is that with a little tinkering, I was able to get it working quite well in Lucid. No luck so far in Slacko though - not sure what the difference is, but the same trick and same module that works fine in Lucid is a total no-go in Slacko.

So for anyone out there (especially my fellow newbies) who have or might be considering getting that Tenda W311U stick, here's what you need to know to make it work in Lucid 5.28:

It probably won't work straight out of the box. The reason is that there are two different modules that both show up as the "right" one. You have to unload and blacklist the "bad" one, reboot, and configure using the "good" one. Of course, that means you'll have to create a save file to do it (or do it from a frugal or full installation).




Short version for those who know this stuff: unload and blacklist the "rt2800usb" module. The one you want to use is "rt2870sta". It will load on its own after you reboot.



Step by step version for beginners like me:

1) When you first boot from the CD and get past the video configuration prompt, you'll next get the Simple Network Wizard prompt to configure your wireless connection. Just close it. The Simple Network Wizard won't help. You need the "regular" (Dougal's) network configuration tool instead. Click the Control icon (opens the PupControlPanel, or PCP), click the Network tab, and click the Network Setup button.

2) You'll see "rt2800usb" listed as the Module in the row for interface WLAN0. We need to unload it. Click the "Load Module" button.

3) Click the "More" tab and then the "Unload" button. Click the arrow for the drop-down list and select "rt2800usb", then click the "Unload" button.

4) You'll get a warning prompt asking if you want to blacklist this module so that Puppy won't try to load it every time you boot. YES, you want to blacklist this module.

5) The sneaky part: loading or reloading the correct module usually won't work at this point. You have to reboot (and create a save file) and give that module a fresh start. So cancel/exit/close everything and reboot. (And obviously, create a save file - otherwise you'd be right back at step one after rebooting.)

6) Again, skip the simple network setup wizard and use the regular network setup tool instead. Click the Control icon, network tab, and network setup button to open it.

7) You'll probably see "usb" listed as the module for WLAN0 now. This is one of the funky things in Puppy that might need a minor correction in a future version. The module is actually rt2800sta, but it shows up on the interface list as simply "usb".

You can click the Load Module button, More tab, and Unload button and see that rt2800sta is the name of the module that is actually loaded. (And if it isn't already loaded, use the Load Module button to load it. Scroll down the list, click on "rt2800sta", and click the load button.) When you're done, click Cancel to get out of the "Load a network module" window and back to the main Puppy Network Wizard window.

8.) Click the WLAN0 button. Then click the Wireless button to configure it. A window will pop up asking if you want to add this module to the list of modules that supports WPA encryption. Yes, you do. Click "Add To List".

The next window will list usb as the module name and wext as the supplicant driver. Just click the "OK" button.

9) You should be ready to connect to your particular wireless network. Click the big "Scan" button and select your network. You're probably familiar with the process from here.

10) But if you haven't done this before... after you select your network from the list, click the button to choose the type of security and enter the key or password as needed. Click the "Save" button to save your configuration first, then click "Use This Profile" to connect.

After it connects, it will take you back to the "configure network interface" window. You'll need to click the Auto DHCP button to connect to the internet. (With wireless connections, you might have to do this every time you boot.)




Hopefully that will help my fellow beginners get a decent introduction to Puppy's wireless network configuration tool, not to mention getting a bargain of a USB adapter working with our favorite OS.

(Micro Center also has their own store brand of USB flash drives that are dirt cheap. I'll be giving a few of my friends a Lucid CD, wireless-N adapter and 16 GB flash drive with a preconfigured save file for the holidays this year...)

I haven't had any luck getting this process (or the rt2870sta or rt2800usb modules) to work with Slacko yet. That's fine with me, because I'm happy with Lucid. But if anyone figures out how to get this device working in Slacko, please post so that others can use it.
Back to top
View user's profile Send_private_message 
cthisbear

Joined: 29 Jan 2006
Posts: 3417
Location: Sydney Australia

PostPosted: Mon 19 Dec 2011, 06:27    Post_subject:  

torgo :

Welcome to Puppy mate.

Great to see that some users post their fixes for others to use.

Seasons Greetings....and happy days.

Chris..
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1519
Location: Maine, USA

PostPosted: Thu 29 Dec 2011, 20:38    Post_subject:  

torgo, cthisbear,
There may be a simpler way to have the correct module get loaded. And it might also work in Slacko, assuming it has the preferred module.

Instead of the blacklist hassle, go into the Menu > System > BootManager and select "Give preference to one module over another". Scroll to the bottom of the list and enter:
rt2800usb:rt2870sta
and click OK.

On the next reboot, the correct module should be used.
Richard
Back to top
View user's profile Send_private_message 
torgo

Joined: 09 Sep 2011
Posts: 44

PostPosted: Sat 31 Dec 2011, 04:54    Post_subject:  

Thanks for the info, rerwin. Setting the priority is indeed a viable alternative.

I still prefer to blacklist the "bad" module, because you end up having to reboot twice in order to set the priority. (You have to create a save file and reboot before you can set the priority. And then you have to reboot a second time for it to take effect.)

But one thing I'll still have to try out... I'll have to see if I can make a custom CD with either that priority entry or with the blacklist entry included on the disc. It would be really helpful if only the proper module would load when booting clean from the CD.




Unfortunately, I haven't found any module that works with the Tenda 311U in Slacko. So at least for now, I'm sticking with Lucid. The Slacko CD has been banished to a junk drawer.
Back to top
View user's profile Send_private_message 
torgo

Joined: 09 Sep 2011
Posts: 44

PostPosted: Sat 31 Dec 2011, 14:19    Post_subject:  

Update: I edited /etc/rc.d/MODULESCONFIG to include the rt2800usb:rt2870sta preference and made a new Lucid CD with the modified config file.

Booting from that CD allows the wireless-N adapter to work even without creating a save file.

It still won't work with the Simple Network Setup tool that pops up when you boot. (I think that has something to do with WPA support, and I might eventually try to figure out how to fix that one.) You have to close that down and go through the regular Network Wizard instead. It works just fine when set up with the Network Wizard tool.




Bottom line: I can attest that the little $10 Tenda adapter from MicroCenter does work with Lucid 5.25 and Lucid 5.28. You have to make sure the rt2870sta module is the only one that gets loaded, and you have to use the regular Network Wizard to set it up, but after that everything's great.

Just don't buy it if you use Slacko, as none of the modules appear to work for it. Spend a little more and get a different Wireless-N adapter instead.
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1519
Location: Maine, USA

PostPosted: Sat 31 Dec 2011, 18:24    Post_subject:  

torgo,
Thanks for trying my suggestion.
Quote:
Update: I edited /etc/rc.d/MODULESCONFIG to include the rt2800usb:rt2870sta preference and made a new Lucid CD with the modified config file.
That is exactly what my next recommendation would be. Good thinking. I gather that you have used the preference without the blacklist, so that I can confidently make the preference change to lucid pup's MODULESCONFIG. Who knows, how many others you have helped by reporting the problem and testing this solution. Thanks.

As for Slacko, have you reported your situation in the Bugs thread for it?
http://www.murga-linux.com/puppy/viewtopic.php?p=576105&search_id=311336713#576105
Maybe there is another driver needed. Tempestuous often provides updated or missing drivers, particularly for networking.
Richard
Back to top
View user's profile Send_private_message 
torgo

Joined: 09 Sep 2011
Posts: 44

PostPosted: Sat 31 Dec 2011, 19:12    Post_subject:  

Either the preferences change or the blacklist entry will get it done on a new CD. I went with the preferences method because it seemed less extreme. (But for a save file, I still prefer the blacklist method. It's quicker to set up the device that way.)


I don't know how many people have other devices that actually need the rt2800usb as opposed to how many have devices like the Tenda that will have this conflict. So I don't know if a change to the default MODULESCONFIG would do more harm than good.

I can only report that one device, the Tenda W311U wireless-N USB adapter, initially boots with BOTH the rt2800usb and rt2870sta modules getting loaded in the Network Wizard in Lucid 5.25 and 5.28. The rt2800usb causes some kind of conflict, preventing the device from working.

Eliminating the rt2800usb - either by blacklist or by preferences - solves that problem. The rt2870sta module seems to work just fine.

The other remaining issues are:

(1) the rt2870sta module shows up as "usb" on the list of interfaces. And when it gets added to the list of WPA compatible modules (/etc/network-wizard/wpa-modules), it again gets listed as "usb".

That strikes me as a minor bug, and it was a major source of newbie confusion until I figured out which module was the one being called "usb".

(2) the Simple Network Setup is still a no-go. I think it's because the module isn't initially set up to support WPA. But that's just a guess - I'm a beginner, so I really don't know anything at all about the drivers.


I might try again with Slacko at some point. I haven't tested out all the modules yet, but I'm not optimistic. The same rt2800usb module loads by default (without the rt2870sta), but neither one of them seems to work.

I haven't reported it (other than in this thread), as I haven't tried out all the other modules.

Thanks again...
Back to top
View user's profile Send_private_message 
nriacone

Joined: 06 Feb 2012
Posts: 3

PostPosted: Tue 07 Feb 2012, 10:39    Post_subject: Tenda WM311M & Slacko
Sub_title: Use Tenda W311M in Slacko
 

Does the Tenda W311M use the same module as the W311U?

Also, has anyone had any luck with getting the Tenda device discussed previously to work in Slacko?

Thanks in advance.
Back to top
View user's profile Send_private_message 
torgo

Joined: 09 Sep 2011
Posts: 44

PostPosted: Wed 08 Feb 2012, 01:44    Post_subject:  

At least for me, still no luck at all getting the W311U to work in Slacko.

The Windows driver is the 2870 (as in the rt2870sta module). But I've tried loading that driver using the NDIS wrapper, and all it does is crash Slacko. None of the modules work with it.



At the moment, I wouldn't buy the W311U or any Tenda stick for use with Puppy. Even in Lucid, you have to use the Network Wizard (NOT the Simple Network Setup tool) to connect the W311U to a wireless network.

If you already have one of them (or more - my company has a handful of the bloody things), the instructions in this thread will at least help you use it with Lucid. But if you haven't bought it yet, you'd be better off getting something else.



Were you planning to order the W311M specifically from Micro Center? If so, check their web site again. The listing says "W311M" and the picture shows the W311M, but the text gives the description for the W311U.

Obviously there's a mistake there somewhere, and I think the one they actually carry is the "U", not the "M". At least the "U" is the one I've seen on the store shelves.



One alternative: I've had much better success using the Netgear WN111v2 with Puppy, in both Lucid and Slacko. (Someone mentioned having problems on an old 486 machine, but I've had no trouble at all with it on more modern gear - including an eight year old laptop.)

Tiger Direct still carries them ($15), and you can typically find them cheap on eBay.


Can anyone else recommend other inexpensive USB Wireless-N sticks that work with Slacko?
Back to top
View user's profile Send_private_message 
nriacone

Joined: 06 Feb 2012
Posts: 3

PostPosted: Wed 08 Feb 2012, 09:08    Post_subject: W311M in Lucid
Sub_title: Still Can Not Get W311M to Work in Lucid 5.2.8
 

When I try to setup the W311M in 5.2.8 the system does not give show anything for WLAN0. What could I be missing. I have unloaded the ETH0 module so that does not seem to be the issue. I am also in the same boat with the Tenda's, I have four of them. They do work fine with WinXP Pro.

Any suggestions as to why the system is not being recognized?
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5263
Location: Australia

PostPosted: Wed 08 Feb 2012, 20:31    Post_subject:  

nriacone wrote:
When I try to setup the W311M in 5.2.8 the system does not give show anything for WLAN0.
...
Any suggestions as to why the system is not being recognized?

To answer that we need to know the USB device ID of your wifi dongle, by running the "lsusb" command ...
but I can already find the result of that command here -
http://forums.linuxmint.com/viewtopic.php?f=53&t=90640
Apparently your USB device ID is 148f:5370

So your W311M is distinctly different to the W311U;
you need the Ralink rt5370sta driver, available here -
http://www.murga-linux.com/puppy/viewtopic.php?p=481085#481085

Please take careful note of the title of that forum thread, regarding compatibility.
Back to top
View user's profile Send_private_message 
torgo

Joined: 09 Sep 2011
Posts: 44

PostPosted: Mon 13 Feb 2012, 01:03    Post_subject:  

The thread where tempestuous posted the 5370 driver also has some good background info on the Ralink RT3070, which helps explain why W311U users are having issues. ( Thanks for that info, tempestuous! )


The W311U is based on the RT3070. The catch is that Ralink made changes to the driver - and to the chip itself - so that Linux users really have no idea what driver (if any currently available) would be the perfect one.

The original 3070 driver mirrored a lot of the 2870 code and was typically compatible with the 2870 driver - and for that matter, the Windows driver on the unit's CD is the rt2870.inf file. But later devices are not fully in line with the 2870 code.

Many of those devices work with the later 3370 driver instead. But some fall somewhere "in between" and don't work 100% perfectly with either driver. The W311U is one of those.

Tempestuous also created a pet file for an older version of a true 3070 driver. (Thanks again, tempestuous!) Alas, the W311U doesn't quite fit with that one either. It works, as does the 3370, but no better than it does with the original rt2870sta module.

The W311U can work with pretty much any of the drivers in that family in Lucid - but you can't use the Simple Network Setup tool with any of them. You have to go through the Network Wizard.

Also, for some odd reason, setting preferences in the boot manager doesn't seem to work when using the 3070/3370/3572 drivers. Lucid will try to load both the 2800usb and 2870sta drivers automatically, even if you set a preference to some other driver. You have to blacklist the ones that you don't want to load.

So at least for now, Lucid and the regular RT2870sta module appear to be the best combination for anyone stuck holding a handful of W311U's. Use Lucid rather than Slacko, use the boot manager either to give preference to the 2870 or to blacklist the 2800, and stick with the Network Wizard tool.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1132s ][ Queries: 12 (0.0175s) ][ GZIP on ]